Results 1 to 8 of 8

Thread: Lubuntu 19.04 - Can't change Plymouth theme for text boot

  1. #1
    Join Date
    Dec 2006
    Location
    Hamburg, Germany
    Beans
    117
    Distro
    Lubuntu 19.04 Disco Dingo

    Lubuntu 19.04 - Can't change Plymouth theme for text boot

    Problem: I cannot set up the text boot theme for Plymouth in Lubuntu 19.04.
    Edit: I want to see messages during boot but get GUI again
    Question: Is there anyone who was succeeded in lubuntu-text theme?
    Question: Is there a way to set up a Plymouth theme which enables text boot?
    None of the commands below help. Even tried them with sudo-update grub, no success.
    Code:
    sudo update-alternatives --install /usr/share/plymouth/themes/default.plymouth default.plymouth /usr/share/plymouth/themes/lubuntu-text/lubuntu-text.plymouth 100
    sudo update-alternatives --config default.plymouth 
    sudo update-alternatives --config text.plymouth
    sudo update-initramfs -u (EDIT: I forgot to mention this command before, now added)
    My understanding is, that playing with /etc/default/grub won't work here because Plymouth takes over control by running in initramfs, and registering itself as service to systemd. Thus playing with following variables won't help. I have tried all the combinations below, nothing changed.
    Code:
    # 10.06.2019 "quite" "splash" did not work
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=...
    # 10.06.2019 "text" below did not work 
    GRUB_CMDLINE_LINUX=""
    Last edited by pencuse; 2 Weeks Ago at 09:14 AM. Reason: typo fix
    Computer: Dell Latitude E7440 (since December 2017); CPU: Intel Core i7-4600U, 2 cores, 4 threads; HDD: 256 GB SSD; RAM: 8 GB DDR3L; Graphics: Intel HD 4400 (integrated in the CPU)
    Registered Linux User #454206

  2. #2
    Join Date
    Mar 2017
    Location
    Gubertino
    Beans
    930
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Lubuntu 19.04 - Can't change Plymouth theme for text boot

    Edit:Misunderstanding... probably not what you want as you will boot into terminal.
    Try changing to text boot with systemd.
    https://ubuntuforums.org/showthread....8#post13863348
    Last edited by guber2; 2 Weeks Ago at 07:46 AM.

  3. #3
    Join Date
    Mar 2017
    Location
    Gubertino
    Beans
    930
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Lubuntu 19.04 - Can't change Plymouth theme for text boot

    FYI I tried the method outlined in the post below but do not see any plymouth splash.
    The command given to test plymouth shows my changes though.
    I am using an ssd...and boots pretty fast ...maybe not enough time for plymouth to load.

    https://askubuntu.com/questions/1046...creen-in-18-04

  4. #4
    Join Date
    Dec 2006
    Location
    Hamburg, Germany
    Beans
    117
    Distro
    Lubuntu 19.04 Disco Dingo

    Re: Lubuntu 19.04 - Can't change Plymouth theme for text boot

    Quote Originally Posted by guber2 View Post
    FYI I tried the method outlined in the post below but do not see any plymouth splash.
    The command given to test plymouth shows my changes though.
    I am using an ssd...and boots pretty fast ...maybe not enough time for plymouth to load.

    https://askubuntu.com/questions/1046...creen-in-18-04
    Hi guber2, thanks for your effort. What I really want is to see boot messages and then get the GUI again, as you have assumed correctly later on. I already tried the stuff in the URL you have mentioned above (except for initframfs update - which I forgot to mention in the original post as well) - all my commands in my original post are actually from that URL..

    The Lubuntu-text theme of Plymouth does not show anything but one text, which I cannot follow. Probably boot sequence is very fast like yours because I also have an SSD, where my boot sequence lasts less than 10 seconds. Without a Plymouth theme the only possible way I can figure out to see them again is to disable video mode during boot, enable text mode. That requires a complete uninstallation of Plymouth.

    I will look other Plymouth themes which would save me effort to disable video mode. Maybe there is one theme which also shows the boot messages...
    Last edited by pencuse; 2 Weeks Ago at 08:32 AM. Reason: fixed typo
    Computer: Dell Latitude E7440 (since December 2017); CPU: Intel Core i7-4600U, 2 cores, 4 threads; HDD: 256 GB SSD; RAM: 8 GB DDR3L; Graphics: Intel HD 4400 (integrated in the CPU)
    Registered Linux User #454206

  5. #5
    Join Date
    Dec 2006
    Location
    Hamburg, Germany
    Beans
    117
    Distro
    Lubuntu 19.04 Disco Dingo

    Re: Lubuntu 19.04 - Can't change Plymouth theme for text boot

    Other posts mentioning that boot on SSD is so fast.
    https://ubuntuforums.org/showthread.php?t=2340103
    https://www.reddit.com/r/pop_os/comm...utdown_screen/

    Probably it doesn't make sense to look at these on a machine with SSD.
    I will set this to SOLVED.

    Important information: Ubuntu Wiki about this is wrong. I have tried "splash" stuff. It doesn't work. Ubuntu Wiki of Plymouth is very old (4 years as of now) - to be updated.

    Possible Solutions (proposed, not tried, not searched on web)
    1. slow down the boot
    2. disable video mode during boot, enable text mode.
    3. Uninstall Plymouth (if it helps)
    Last edited by pencuse; 2 Weeks Ago at 09:15 AM. Reason: typo fix
    Computer: Dell Latitude E7440 (since December 2017); CPU: Intel Core i7-4600U, 2 cores, 4 threads; HDD: 256 GB SSD; RAM: 8 GB DDR3L; Graphics: Intel HD 4400 (integrated in the CPU)
    Registered Linux User #454206

  6. #6
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,493
    Distro
    Ubuntu Development Release

    Re: Lubuntu 19.04 - Can't change Plymouth theme for text boot

    #Open a terminal
    sudo gedit /etc/default/grub
    #change line 6 to "text" on the end

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="text"
    GRUB_CMDLINE_LINUX=""
    sudo update-grub
    Last edited by garvinrick4; 1 Week Ago at 05:57 AM. Reason: update-grub
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:


  7. #7
    Join Date
    Mar 2017
    Location
    Gubertino
    Beans
    930
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Lubuntu 19.04 - Can't change Plymouth theme for text boot

    You are confusing text.plymouth with grub's text option.
    text.plymouth still displays a splash but without animation. It's a fallback mode for unsupported gfx.
    Just editng grub as garvinrick4 shows should work.
    Attached Images Attached Images

  8. #8
    Join Date
    Dec 2006
    Location
    Hamburg, Germany
    Beans
    117
    Distro
    Lubuntu 19.04 Disco Dingo

    Re: Lubuntu 19.04 - Can't change Plymouth theme for text boot

    Quote Originally Posted by guber2 View Post
    You are confusing text.plymouth with grub's text option.
    text.plymouth still displays a splash but without animation. It's a fallback mode for unsupported gfx.
    Just editng grub as garvinrick4 shows should work.
    I couldn't find one in internet what exactly "text.plymouth" does. That's why.

    Quote Originally Posted by garvinrick4 View Post
    GRUB_CMDLINE_LINUX_DEFAULT="text"
    Only the entry above gives what I wanted (in /etc/default/grub). My boot takes less than 10 seconds, and the text runs very fast, but I can see finally the boot messages.

    Thanks!
    Last edited by pencuse; 2 Weeks Ago at 09:40 AM.
    Computer: Dell Latitude E7440 (since December 2017); CPU: Intel Core i7-4600U, 2 cores, 4 threads; HDD: 256 GB SSD; RAM: 8 GB DDR3L; Graphics: Intel HD 4400 (integrated in the CPU)
    Registered Linux User #454206

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •