Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Slow boot with errors....

  1. #21
    Join Date
    Mar 2010
    Beans
    8,760
    Distro
    Ubuntu Mate

    Re: Slow boot with errors....

    I thought I was onto something but apparently not.

    The only other references I could find to those specific errors mentioned in the first post was a possible corruption of the swap partition.

    The suggested solution was to reformat swap but I honestly do not know if that will work.

    Any other ideas?

  2. #22
    Join Date
    Jan 2014
    Location
    The Endless Ocean
    Beans
    171
    Distro
    Xubuntu

    Re: Slow boot with errors....

    Quote Originally Posted by Rubi1200 View Post
    I thought I was onto something but apparently not.

    The only other references I could find to those specific errors mentioned in the first post was a possible corruption of the swap partition.

    The suggested solution was to reformat swap but I honestly do not know if that will work.

    Any other ideas?
    Thank you for checking If I'm not mistaken newer versions of Ubuntu have switched to using a swap file ?? If that's the case then maybe upgrading could be a solution ??
    [ R E V I Z I I S ]

  3. #23
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow boot with errors....

    I have a swap partition during a test install it just used it. I wanted the swap file just to see if it worked.
    It was a lot of steps, but if you follow them, you can delete a swap partition and add a swap file.
    If you reinstall, be sure to either delete swap partition first or you can click on swap partition and say do not use which I did do on another test install.
    Be sure to remove old entry from fstab and add new entry. And edit /etc/initramfs-tools/conf.d/resume to avoid issues.

    https://wiki.manjaro.org/index.php?t...dd_a_/swapfile
    https://devanswers.co/guide-creating...-ubuntu-16-04/
    fred@cosmic-z97:~$ sudo fallocate -l 2G /swapfile
    [sudo] password for fred:
    fred@cosmic-z97:~$ ls -lh /swapfile
    -rw-r--r-- 1 root root 2.0G Jun 26 15:19 /swapfile
    fred@cosmic-z97:~$ sudo chmod 600 /swapfile
    fred@cosmic-z97:~$ ls -lh /swapfile
    -rw------- 1 root root 2.0G Jun 26 15:19 /swapfile
    fred@cosmic-z97:~$ sudo mkswap /swapfile
    Setting up swapspace version 1, size = 2 GiB (2147479552 bytes)
    no label, UUID=0231a740-006b-4d3b-ad96-bc963a45be9c
    fred@cosmic-z97:~$ sudo mount -a
    fred@cosmic-z97:~$ sudo swapon /swapfile
    fred@cosmic-z97:~$ sudo swapon --show
    NAME TYPE SIZE USED PRIO
    /dev/sda4 partition 1.9G 0B -2
    /dev/sdb7 partition 2.1G 0B -3
    /swapfile file 2G 0B -4
    fred@cosmic-usbssd:~$ y
    swapon: /swapfile: insecure permissions 0644, 0600 suggested.
    fred@cosmic-usbssd:~$ sudo chmod 0600 /swapfile
    fred@cosmic-usbssd:~$ ls -lh /swapfile
    -rw------- 1 root root 2.0G Jul 5 12:56 /swapfile
    Last edited by oldfred; June 10th, 2019 at 05:26 PM.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #24
    Join Date
    Jan 2014
    Location
    The Endless Ocean
    Beans
    171
    Distro
    Xubuntu

    Re: Slow boot with errors....

    Quote Originally Posted by oldfred View Post
    I have a swap partition during a test install it just used it. I wanted the swap file just to see if it worked.
    It was a lot of steps, but if you follow them, you can delete a swap partition and add a swap file.
    If you reinstall, be sure to either delete swap partition first or you can click on swap partition and say do not use which I did do on another test install.
    Be sure to remove old entry from fstab and add new entry. And edit /etc/initramfs-tools/conf.d/resume to avoid issues.

    https://wiki.manjaro.org/index.php?t...dd_a_/swapfile
    https://devanswers.co/guide-creating...-ubuntu-16-04/
    fred@cosmic-z97:~$ sudo fallocate -l 2G /swapfile
    [sudo] password for fred:
    fred@cosmic-z97:~$ ls -lh /swapfile
    -rw-r--r-- 1 root root 2.0G Jun 26 15:19 /swapfile
    fred@cosmic-z97:~$ sudo chmod 600 /swapfile
    fred@cosmic-z97:~$ ls -lh /swapfile
    -rw------- 1 root root 2.0G Jun 26 15:19 /swapfile
    fred@cosmic-z97:~$ sudo mkswap /swapfile
    Setting up swapspace version 1, size = 2 GiB (2147479552 bytes)
    no label, UUID=0231a740-006b-4d3b-ad96-bc963a45be9c
    fred@cosmic-z97:~$ sudo mount -a
    fred@cosmic-z97:~$ sudo swapon /swapfile
    fred@cosmic-z97:~$ sudo swapon --show
    NAME TYPE SIZE USED PRIO
    /dev/sda4 partition 1.9G 0B -2
    /dev/sdb7 partition 2.1G 0B -3
    /swapfile file 2G 0B -4
    fred@cosmic-usbssd:~$ y
    swapon: /swapfile: insecure permissions 0644, 0600 suggested.
    fred@cosmic-usbssd:~$ sudo chmod 0600 /swapfile
    fred@cosmic-usbssd:~$ ls -lh /swapfile
    -rw------- 1 root root 2.0G Jul 5 12:56 /swapfile
    Thank you very much for this super detailed reply. Going to give this a go tomorrow, but for now this thread is solved. Thank you everyone that offered help....
    [ R E V I Z I I S ]

  5. #25
    Join Date
    Dec 2017
    Location
    RockyMts
    Beans
    1,170

    Re: Slow boot with errors....

    Yet another oldfred enter in my ubuntu collection. Thanks

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •