Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 42

Thread: Postfix

  1. #31
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,867
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Postfix

    Hey just a tip, when posting the main.cf file -- it might be easier for readability purposes to cut out all the commented lines: I usually do something like
    cat main.cf | grep -v ^# | grep -v ^$

    smtp_sasl_password_maps = hash:/usr/local/etc/postfix/sasl_passwd

    You sure you have a file located in this directory?

  2. #32
    Join Date
    Jun 2019
    Beans
    19

    Re: Postfix

    I purged postfix and then reinstalled postfix. I then chose "No Configuration". When I try to send an email now I get this message: https://imgur.com/a/ipDls1B


    Here is what the main.cf.proto file looks like: https://imgur.com/a/wNYXpkI
    Last edited by rjphares; June 17th, 2019 at 03:34 PM.

  3. #33
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,867
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Postfix

    Ok I just set this up on a new Ubuntu Server and can confirm it will work -- or it did for me at least.
    I followed the instructions here:
    https://www.linode.com/docs/email/po...ian-or-ubuntu/

    I wanted port 465 and not 587 as I've stated earlier so I made the following modifications
    /etc/postfix/sasl/sasl_passwd

    Code:
    smtp.gmail.com <your_gmail_username>:<your gmail app specific password>
    I put the following at the bottom of my main.cf file:

    Code:
    # Manual Configuation for Gmail
    ## SASL Options
    smtp_sasl_auth_enable = yes
    smtp_sasl_security_options = noanonymous
    smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd
    
    ## TLS Options
    smtp_use_tls = yes
    smtp_tls_security_level = encrypt
    ##Following line required for port 465
    smtp_tls_wrappermode = yes
    tls_random_source = dev:/dev/urandom
    
    ## Relay host
    relayhost = [smtp.gmail.com]:465
    
    disable_vrfy_command = yes

    Hopefully that helps -- Admittedly I've set this up before, however this process took me all of 5 minutes. It took me longer to construct this post than setup the mail server.

  4. #34
    Join Date
    Jun 2019
    Beans
    19

    Re: Postfix

    I am unable to send an email. I still get this message: https://imgur.com/a/ipDls1B

  5. #35
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Postfix

    I refer you back to post 12 in this thread again - your test emails could be bouncing.

    The log entries in post25 tell me that at least some of your test messages are not getting to where they should:
    Code:
    May 31 12:16:16 DESKTOP-K50P15B postfix/cleanup[747]: 6B8138000000033AC8: message-id=<20190531161616.6B8138000000033AC8@rjphares.localdomain>
    May 31 12:16:16 DESKTOP-K50P15B postfix/qmgr[741]: 6B8138000000033AC8: from=<root@DESKTOP-K50P15B.localdomain>, size=422, nrcpt=2 (queue active)
    May 31 12:16:16 DESKTOP-K50P15B postfix/error[754]: 6B8138000000033AC8: to=<d@DESKTOP-K50P15B.localdomain>, relay=none, delay=0.04, delays=0.03/0/0/0.01, dsn=5.0.0, status=bounced (DESKTOP-K50P15B.localdomain)
    May 31 12:16:16 DESKTOP-K50P15B postfix/error[754]: 6B8138000000033AC8: to=<rjphares@DESKTOP-K50P15B.localdomain>, relay=none, delay=0.05, delays=0.03/0/0/0.02, dsn=5.0.0, status=bounced (DESKTOP-K50P15B.localdomain)
    May 31 12:16:16 DESKTOP-K50P15B postfix/cleanup[747]: 75C48B000000033AC6: message-id=<20190531161616.75C48B000000033AC6@rjphares.localdomain>
    May 31 12:16:16 DESKTOP-K50P15B postfix/bounce[749]: 6B8138000000033AC8: sender non-delivery notification: 75C48B000000033AC6
    May 31 12:16:16 DESKTOP-K50P15B postfix/qmgr[741]: 75C48B000000033AC6: from=<>, size=2756, nrcpt=1 (queue active)
    May 31 12:16:16 DESKTOP-K50P15B postfix/qmgr[741]: 6B8138000000033AC8: removed
    May 31 12:16:16 DESKTOP-K50P15B postfix/error[748]: 75C48B000000033AC6: to=<root@DESKTOP-K50P15B.localdomain>, relay=none, delay=0.03, delays=0.02/0/0/0.01, dsn=5.0.0, status=bounced (DESKTOP-K50P15B.localdomain)
    Forum DOs and DON'Ts
    Please use CODE tags
    Including your email address in a post is not recommended
    My Blog

  6. #36
    Join Date
    Jun 2019
    Beans
    19

    Re: Postfix

    Do you know what I typed that could have produced those error message? Since I deleted postfix and reinstalled with "No Configuration" I have been unable to find a mail.log file.

  7. #37
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,867
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Postfix

    I think you need to install with internet configuration. See this post about log files for mail/postfix: https://askubuntu.com/questions/3947...tfix-log-files

  8. #38
    Join Date
    Jun 2019
    Beans
    19

    Re: Postfix

    I am not sure the configuration is correct but this is the output : https://imgur.com/a/g5s5fJB

  9. #39
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,867
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Postfix

    Yikes - the postfix daemon isn't even running -- I'm not sure why. Something is screwed up with your postfix installation.

  10. #40
    Join Date
    Jun 2019
    Beans
    19

    Re: Postfix

    Success. I changed my hostname to DESKTOP-K50P15B. Really excited to have solved this issue and couldn't have done it with out all the advice.

    https://imgur.com/a/ZGhbSnU

Page 4 of 5 FirstFirst ... 2345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •