Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Keyboard/typing issues after updating to Ubuntu 18.04.2

  1. #1
    Join Date
    Jul 2014
    Beans
    12

    Keyboard/typing issues after updating to Ubuntu 18.04.2

    I recently had a hard drive crash, I was using Ubuntu 16.04.6 - so I reinstalled Ubuntu 18.04.2. Finally got everything mostly restored to the way it was before.

    But I'm encountering a really weird and annoying problem. Sometimes when typing - like when typing up this post - the spacebar seem to stick and when I hit the spacebar it doesn't actually space. This appears to be preceded by the text that I am typing being underlined as I type. It's really annoying because I can type and be 6 or 7 words after before I notice that the spacebar didn't actually put a space between the words.

    I suppose it could be a mechanical keyboard issue... but this keyboard was working fine before 18.04.2 - seems to be an issue with something that Ubuntu 18.04.2 installed or didn't install.

    Is this perhaps a known issue with an easy fix? I haven't found anything in my search that resolves this.

    I'm using IceWM as my windows manager (I like simplicity) so I'd really need to know what configuration files to edit rather than through some GUI specific instructions. I only seem to notice the issue in applications like pluma, Thunderbird, and FireFox. xterm does not appear to be affected by this, but maybe that's because it doesn't have a textarea?

    I'm just looking for any possible solutions. It's just really annoying because I never know when the spacebar is going to take and when it is not.

  2. #2
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    2,972
    Distro
    Xubuntu

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    The first thing that I would do would be took connect another keyboard and see what happens.

  3. #3
    Join Date
    Jul 2014
    Beans
    12

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    Same thing with a different keyboard.

    It doesn't happen all the time. It's just anybody's guess as to when it will happen. But the text being underlined as Itype it is usually a sign that it is going to happen relatively soon.

    Perhaps I'm typing too fast for the system to recognize the keys? I really don't know.

  4. #4
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    Try this:
    Code:
    sudo apt-get install xserver-xorg-input-all
    You will need to reboot.
    And if that still dose not work, go to setting -> Universal Access -> Typing Assist -> Slow Keys
    >>>And turn off Slow Keys
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  5. #5
    Join Date
    Jul 2014
    Beans
    12

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    Already done the xserver-xorg-input-all and rebooted. That didn't seem to help.

    I don't have a "Settings ->Universal Access ..." I'm using IceWM. What actual binary is that calling?I can run the binary from an xterm. That's typically what I do. That's why I like Icewm.It's just a basic windows manager, and I can run whatever Ineed to by using an xterm or gmrun.

  6. #6
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    If your not running Gnome, that would have been a good thing to mention right off the get go.
    Code:
    sudo apt remove --purge autoremove xserver-xorg-input-all && sudo apt install xserver-xorg-input-all
    EDIT: I forgot to add:
    Fortunately, it’s quite easy to do.
    Code:
    # Install xkbset for managing keyboard options
    sudo apt-get install xkbset
    # Disable slow-keys
    xkbset -sl
    # Disable accessibility so slow-keys won't turn back on
    xkbset -a
    Good Luck
    Last edited by 1fallen; May 28th, 2019 at 06:44 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  7. #7
    Join Date
    Jul 2014
    Beans
    12

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    Hmm.

    Did all of that. Issue still appears to be present. Must be something that Ihave installed that is conflicting with something else. But I do not know what that something might be. Are there any X.org logs stored any where? Iguess Icould stop lightdm and run X straight from the console, that way errors might be reported on the console.

    Issue is just annoying as ****. Because Inever know when it's going to happen.

  8. #8
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    This is just a poke in the dark:
    Code:
    inxi -G
    Return the output please.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  9. #9
    Join Date
    Jul 2014
    Beans
    12

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    Graphics: Card: Intel 82Q35 Express Integrated Graphics Controller
    Display Server: x11 (X.Org 1.20.1 ) drivers: intel (unloaded: modesetting,fbdev,vesa)
    Resolution: 1280x1024@60.02hz
    OpenGL: renderer: Mesa DRI Intel Q35 version: 1.4 Mesa 18.2.8

    Anything important there?

  10. #10
    Join Date
    Jul 2014
    Beans
    12

    Re: Keyboard/typing issues after updating to Ubuntu 18.04.2

    Ah. I think I may have had a break through!

    Seems to be happening when I'm typing a capital letter. Holding shift + the spacebar doesn't create a space. Is that a setting or something you are aware of? Apparently my pinking finger has a slower reaction time than the rest of my fingers and seems to want to stick on the shift key when I'm hitting the space bar. I'm sure my typing method hasn't changed between Ubuntu 16 and Ubuntu 18. So it's probably a setting some where that needs to be enabled or disabled.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •