Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Graphics problem sometimes on boot

  1. #1
    Join Date
    Aug 2007
    Location
    Luxembourg
    Beans
    232
    Distro
    Ubuntu 20.04 Focal Fossa

    Question Graphics problem sometimes on boot

    My wife has a Lenovo All-in-one which has regular (say 1 in 3) Graphics problems on boot.
    This is a new problem, the system has been stable for a long time.
    System: Xubuntu 18.04 LTS fully up to date. Not using proprietary drivers. Intel hardware, built in graphics.

    On those boots that it fails, it is OK at the start, GRUB menu OK, then colored snow.
    With the good boots, there is never a graphic problem later

    I do not know where to start. I did check RAM, it is good. Plenty of disk space free.
    Hardware? It is an all-in-one so this is tricky.
    Drivers?
    Should I re-install?
    Which logs should I look at / post ?

    Your advice appreciated.

  2. #2
    Join Date
    Dec 2017
    Location
    RockyMts
    Beans
    1,169

    Re: Graphics problem sometimes on boot

    Lets have a look at your computer specs for a start. In terminal:
    Code:
    sudo apt install inxi
    Then please post the output of:
    Code:
    inxi -b

  3. #3
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Graphics problem sometimes on boot

    Sometimes i get such an issue (for a short while at boot time); usually it is related to temperature/humidity weather changes.
    It can also be a video cable oxydation; in such a case, unplug/plug is enough to solve the problem.

  4. #4
    Join Date
    Aug 2007
    Location
    Luxembourg
    Beans
    232
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Graphics problem sometimes on boot

    Now I'm in trouble with the wife for not treating her problem with the urgency it needs !

    Cruzer : thanks for the idea and here is the output:

    Code:
           
        family@Lenovo-C260:~$ inxi -b
        System:    Host: Lenovo-C260 Kernel: 4.15.0-50-generic i686 bits: 32
                   Desktop: Xfce 4.12.3 Distro: Ubuntu 18.04.2 LTS
        Machine:   Device: desktop System: LENOVO product: 10160 v: Lenovo C260 serial: 
        N/A
                   Mobo: LENOVO model: INVALID v: SDK0F82993 WIN serial: N/A
                   UEFI [Legacy]: LENOVO v: IXKT24AUS date: 09/19/2014
        CPU:       Dual core Intel Celeron J1800 (-MCP-) speed/max: 1919/2582 MHz
        Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
                   Display Server: x11 (X.Org 1.19.6 )
                   drivers: modesetting (unloaded: fbdev,vesa)
                   Resolution: 1600x900@59.97hz
                   OpenGL: renderer: Mesa DRI Intel Bay Trail x86/MMX/SSE2
                   version: 4.2 Mesa 18.2.8
        Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
                   driver: r8169
                   Card-2: Realtek RTL8188EE Wireless Network Adapter
                   driver: rtl8188ee
        Drives:    HDD Total Size: 500.1GB (8.7% used)
        Info:      Processes: 193 Uptime: 3:16 Memory: 1915.0/3935.8MB
                   Client: Shell (bash) inxi: 2.3.56 
        family@Lenovo-C260:~$
    Dino: useful comment
    It seems to happen mostly on the first boot in the morning.
    But strangely, it is Summer now, so why would the temperature be a problem now?
    As for "in such a case, unplug/plug is enough to solve the problem", this is an All-In-One so not so easy to unplug.

    Your further comments/ideas are welcome (and may help to save my relationship with my wife)
    Last edited by deadflowr; May 27th, 2019 at 05:48 PM. Reason: switch tags; from quote to code

  5. #5
    Join Date
    Aug 2007
    Location
    Luxembourg
    Beans
    232
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Graphics problem sometimes on boot

    Pressure from wife.

    So Bump

  6. #6
    Join Date
    Dec 2017
    Location
    RockyMts
    Beans
    1,169

    Re: Graphics problem sometimes on boot

    Sorry for not getting back sooner, I don't always get a email notification.

    Since your on the latest kernel and this recently started try going back to the previous kernel. This can be done at boot in the grub menu.

    https://help.ubuntu.com/community/Grub2/Submenus

    And I would like a closer look at your video, please post the output of:
    Code:
    lshw -c video

  7. #7
    Join Date
    Aug 2007
    Location
    Luxembourg
    Beans
    232
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Graphics problem sometimes on boot

    Here it is:

    Code:
    family@Lenovo-C260:~$ sudo lshw -c video
    [sudo] password for family:
      *-display                 
           description: VGA compatible controller
           product: Atom Processor Z36xxx/Z37xxx Series Graphics & Display
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 0e
           width: 32 bits
           clock: 33MHz
           capabilities: pm msi vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:92 memory:90000000-903fffff memory:80000000-8fffffff ioport:3050(size=8) memory:c0000-dffff
    family@Lenovo-C260:~$
    Last edited by deadflowr; May 27th, 2019 at 05:48 PM. Reason: switched tags; from quote to code

  8. #8
    Join Date
    Dec 2017
    Location
    RockyMts
    Beans
    1,169

    Re: Graphics problem sometimes on boot

    Hello

    Did you try the previous (older) kernel?

    Something else that is worth a try is "nomodeset".

    https://ubuntuforums.org/showthread.php?t=1613132

    These suggestions are off the top of my head. I'm hoping to get lucky. There may be bug reports on this and I need to take a look around the internet for that and other possibilities related to Lenovo and your graphic card. However being Memorial Day here I will not have the time for this right now. So maybe someone else will chime in with ideas or I'll be back with you later.

  9. #9
    Join Date
    Aug 2007
    Location
    Luxembourg
    Beans
    232
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Graphics problem sometimes on boot

    IMPORTANT NEW INFORMATION

    The problem remains as described, but it appears it is provoked by a shutdown problem.

    My wife had described the problem as one that affected the first boot in the morning. Thereafter, it seemed OK. So I was mislead into thinking of hardware, heating etc.

    This morning, as a test, I did 8 boots.

    1st,3,5 and 7 failed. 2nd,4,6 and 8 worked.

    Now I need to add another fact which seemed irrelevant at the time of my first post.

    As noted the PC runs Xubuntu 18 LTS fully up to date. The shutdown process does not complete, and never has. The PC shutdown gets to the final screen and then freezes. So for a couple of years she has closed down by holding down the power switch. Until 1 month ago this did not create a new boot failure. But now it does.

    Let me go carefully through the test of this morning.

    START
    Start boot, Lenovo screen OK, peeps OK, grub screen OK, then coloured snow.
    Force shutdown by using power switch.
    Start boot, Lenovo screen OK, peeps OK, grub screen OK, then normal Xubuntu start.
    Normal Xubuntu shutdown initiated.
    Shutdown start OK, then freezes on final Xubuntu screen.
    Force shutdown by using power switch.
    Go to START

    So the problem appears to be created by a partial Xubuntu shutdown. Something must be left in an error state which then provokes the next boot to stop with coloured snow.

    This is a strange one. Any ideas?

  10. #10
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    7,927
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Graphics problem sometimes on boot

    By default, processes are given 90 seconds to finish before they are killed and the shutdown can finalise properly. It is possible to shorten this period. It does seem likely that there is something still running when you yank the power.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •