Results 1 to 5 of 5

Thread: How can I hide desktop icons?

  1. #1
    Join Date
    May 2019
    Beans
    1

    Question How can I hide desktop icons?

    The title pretty much says it all, I wish to hide my desktop icons, I'm running Ubuntu 19.04. I've tried to run 'sudo gsettings set org.gnome.desktop.background show-desktop-icons false' and when I run 'sudo gsettings get org.gnome.desktop.background show-desktop-icons' it outputs 'false'. I've also tried switching it on and off both in the command line and Gnome Tweaks. Any help would be appreciated, thanks!

  2. #2
    Join Date
    Oct 2018
    Location
    England, United Kingdom
    Beans
    52

    Re: How can I hide desktop icons?

    Unfortunately I don't see how with the new extension being used however if by hiding you mean the folder and the trash can then install gnome-tweaks from the terminal then load gnome-tweaks up and under the extension menu section you'll see the Desktop Icon extension listed click on the settings on that extension and turn the slider of the personal folder and the rubbish bin to off then it should be hidden you can't however remove that extension fully otherwise it'll remove the ubuntu-desktop component which is not wise to do.

  3. #3
    Join Date
    Feb 2015
    Beans
    Hidden!
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: How can I hide desktop icons?

    Quote Originally Posted by breaktheebeat View Post
    ... I'm running Ubuntu 19.04. I've tried to run 'sudo gsettings set org.gnome.desktop.background show-desktop-icons false' and when I run 'sudo gsettings get org.gnome.desktop.background show-desktop-icons' it outputs 'false'....
    I've never run the gsettings command or dconf-editor with sudo to change such user settings with Ubuntu. Your attempts to set them there will most likely be affecting the setting for the root account, if the setting even exists as the root account normally is locked and you don't log into a desktop for root (again, under NORMAL circumstances). This is probably why the second "get" command failed as well. Edit: I just noted that it seems your command did work if the result was "false" but has only affected the root acoount settings because of sudo being used. I slightly misread your opening post initially there.

    Try them again without sudo eg...
    Code:
    gsettings set org.gnome.desktop.background show-desktop-icons false
    and
    Code:
    gsettings get org.gnome.desktop.background show-desktop-icons
    I am actually not running the main Ubuntu flavor so can't test this fully here. I'm either on Xubuntu 18.04 or Ubuntu Mate 18.04 (dual booting the two) but over the years have used the Unity and gnome desktops extensively, I just don't run a gnome based desktop at all at the moment.

    Hope this works for you, good luck. Yeti.
    Last edited by yetimon_64; May 20th, 2019 at 01:13 AM. Reason: noted command worked but for root account because of sudo usage

  4. #4
    Join Date
    Feb 2010
    Location
    Summerwind
    Beans
    13,788
    Distro
    Ubuntu Budgie Development Release

    Re: How can I hide desktop icons?

    Have you checked settings/desktop or in the gnome tweak tool ?
    “Start where you are. Use what you have. Do what you can".

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Flavors

  5. #5
    Join Date
    Oct 2018
    Location
    England, United Kingdom
    Beans
    52

    Re: How can I hide desktop icons?

    Quote Originally Posted by yetimon_64 View Post
    I've never run the gsettings command or dconf-editor with sudo to change such user settings with Ubuntu. Your attempts to set them there will most likely be affecting the setting for the root account, if the setting even exists as the root account normally is locked and you don't log into a desktop for root (again, under NORMAL circumstances). This is probably why the second "get" command failed as well. Edit: I just noted that it seems your command did work if the result was "false" but has only affected the root acoount settings because of sudo being used. I slightly misread your opening post initially there.

    Try them again without sudo eg...
    Code:
    gsettings set org.gnome.desktop.background show-desktop-icons false
    and
    Code:
    gsettings get org.gnome.desktop.background show-desktop-icons
    I am actually not running the main Ubuntu flavor so can't test this fully here. I'm either on Xubuntu 18.04 or Ubuntu Mate 18.04 (dual booting the two) but over the years have used the Unity and gnome desktops extensively, I just don't run a gnome based desktop at all at the moment.

    Hope this works for you, good luck. Yeti.
    Just so you know I would have suggested this to the OP if it worked but I've already tried and tested those commands on the day of release the Desktop Icon extension overwrites it and forces the desktop icons on you.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •