Results 1 to 6 of 6

Thread: Unable to locate package libmbedtls-dev

  1. #1
    Join Date
    May 2019
    Beans
    3

    Unable to locate package libmbedtls-dev

    I currently have a computer running Windows 10 with an encrypted BitLocker hard drive. The employee who used it has left but the files remain on his drive. We do not have admin access for the computer. We are trying the dislocker route but we are having trouble installing it on the computer. The hard drive is completely full so we can't install Ubuntu on it per say - so we are running Ubuntu 19.04 Disco Dingo on a bootable USB. I am able to install all packages needed for dislocker but libmbedtls-dev.

    Alternatively, I cannot just do sudo apt install dislocker either because it returns that message of "Unable to locate package."

    These issues may be because we are running off a bootable usb, I am not sure. Please advise thank you so much.

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Unable to locate package libmbedtls-dev

    Found here: https://packages.ubuntu.com/disco/libmbedtls-dev
    I'm not sure what link your following but have a look here also: https://github.com/Aorimn/dislocker/tree/develop
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  3. #3
    Join Date
    May 2019
    Beans
    3

    Re: Unable to locate package libmbedtls-dev

    When I open the .deb and click Install - a progress appears, and nothing happens. It will flash and the Install button is still there.

  4. #4
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Unable to locate package libmbedtls-dev

    Quote Originally Posted by mnewber1 View Post
    When I open the .deb and click Install - a progress appears, and nothing happens. It will flash and the Install button is still there.
    Put the .deb file in your Downloads folder if it's not already there then run
    Code:
    sudo apt install Downloads/name.deb
    changing where I've shown name to whatever the file is called.
    DISTRO: Xubuntu 18.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  5. #5
    Join Date
    May 2019
    Beans
    3

    Re: Unable to locate package libmbedtls-dev

    Code:
    ubuntu@ubuntu:~/Downloads$ sudo apt install libmbedtls-dev_2.4.2-1+deb9u3_amd64.deb
    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    E: Unable to locate package libmbedtls-dev_2.4.2-1+deb9u3_amd64.deb
    E: Couldn't find any package by glob 'libmbedtls-dev_2.4.2-1+deb9u3_amd64.deb'
    E: Couldn't find any package by regex 'libmbedtls-dev_2.4.2-1+deb9u3_amd64.deb'
    
    Here is the response, doesn't seem to work either.

  6. #6
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    9,993
    Distro
    Ubuntu

    Re: Unable to locate package libmbedtls-dev

    To use apt install it requires full path.
    Code:
    sudo apt install /full/path/to/deb-file.deb
    But that said, if running a live session, or from usb, check if community(universe ) repository is enabled, or just run the enable command anyway
    Code:
    sudo add-apt-repository universe
    sudo apt update
    then see if the package is there.
    (Hint: it should be, if it isn't something's wrong with your apt configuration.)

    You can also install dislocker from there as well as it too is a universe package.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •