Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Problem with Samba between ubuntu server and windows 10 client

  1. #21
    Join Date
    Dec 2009
    Beans
    6,201

    Re: Problem with Samba between ubuntu server and windows 10 client

    Seems strange since I did not browse to all those subfolders manually in Muziek.
    That one I'm going to have to think about.

    Is the connection to the server a "mapped drive" in Win10?

    And do you have an application that automatically connects to that "drive" at login?

    Locks don't usually survive when the client disconnects and especially when the server reboots or smbd restarts so I'm not sure why it shows all those connections.

  2. #22
    Join Date
    May 2019
    Beans
    13

    Re: Problem with Samba between ubuntu server and windows 10 client

    Quote Originally Posted by Morbius1 View Post
    That one I'm going to have to think about.

    Is the connection to the server a "mapped drive" in Win10?

    And do you have an application that automatically connects to that "drive" at login?

    Locks don't usually survive when the client disconnects and especially when the server reboots or smbd restarts so I'm not sure why it shows all those connections.
    Yes mapped drives in windows, like this:



    Code:
    net use
    New connections will be remembered.
    
    
    Status       Local     Remote                    Network
    
    -------------------------------------------------------------------------------
    OK           Q:        \\LINUXSERVER\Disc5       Microsoft Windows Network
    Unavailable  T:        https://unrealbe.stackstorage.com/remote.php/webdav/
                                                    Web Client Network
    OK           U:        \\LINUXSERVER\Disc6       Microsoft Windows Network
    OK           V:        \\LINUXSERVER\Dataserver  Microsoft Windows Network
    OK           W:        \\LINUXSERVER\Disc4       Microsoft Windows Network
    OK           X:        \\LINUXSERVER\Disc3       Microsoft Windows Network
    OK           Y:        \\LINUXSERVER\Disc2       Microsoft Windows Network
    OK           Z:        \\LINUXSERVER\Disc1       Microsoft Windows Network
    The command completed successfully.
    As far as I know nothing connects automatically besides explorer.

  3. #23
    Join Date
    Dec 2009
    Beans
    6,201

    Re: Problem with Samba between ubuntu server and windows 10 client

    I cannot reproduce your symptoms.

    I took a test server that I do terrible things to for testing purposes and replaced its smb.conf with yours - after making changes to "tim" and such. I couldn't even get samba to run unless I removed the reference to the lock directory. Even after that change it ran - not very well - but it ran and never disconnected.

    Did you follow a HowTo to set up this server or did you make incremental changes to the standard smb.conf over time in an effort to fix the problem you described here?

    I personally don't know where to go from here. Sorry.

  4. #24
    Join Date
    May 2019
    Beans
    13

    Re: Problem with Samba between ubuntu server and windows 10 client

    Quote Originally Posted by Morbius1 View Post
    I cannot reproduce your symptoms.

    I took a test server that I do terrible things to for testing purposes and replaced its smb.conf with yours - after making changes to "tim" and such. I couldn't even get samba to run unless I removed the reference to the lock directory. Even after that change it ran - not very well - but it ran and never disconnected.

    Did you follow a HowTo to set up this server or did you make incremental changes to the standard smb.conf over time in an effort to fix the problem you described here?

    I personally don't know where to go from here. Sorry.

    Did you follow a HowTo to set up this server or did you make incremental changes to the standard smb.conf over time in an effort to fix the problem you described here?
    Definitly the second part. The thing is this used to work fine, no idea what broke it (maybe a windows update)

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •