Results 1 to 3 of 3

Thread: Help with OpenGL in an old laptop

  1. #1
    Join Date
    May 2019
    Beans
    2

    Help with OpenGL in an old laptop

    Hi, I installed Lubuntu 18.0.4 in this 9 year old hp laptop: https://support.hp.com/au-en/document/c02246342
    I tried to play a game I got on steam but it doesn't run at all. This is the log from the game:

    Code:
    Desktop is 1366 x 768 @ 60 Hz
    Unable to find a supported OpenGL core profile
    Failed to create valid graphics context: please ensure you meet the minimum requirements
    E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer
    [Vulkan init] extensions: count=2
    [Vulkan init] extensions: name=VK_EXT_debug_report, enabled=0
    [Vulkan init] extensions: name=VK_EXT_debug_utils, enabled=0
    Vulkan error VK_ERROR_INCOMPATIBLE_DRIVER (-9) file: ./Runtime/GfxDevice/vulkan/VKContext.cpp, line: 313
    Vulkan detection: 0
    No supported renderers found, exiting
    /home/garcia/.local/share/Steam/steamapps/common/Fantasy Strike/FS_Linux.bin() [0xbc7757]
    /home/garcia/.local/share/Steam/steamapps/common/Fantasy Strike/FS_Linux.bin() [0x9d26a0]
    /home/garcia/.local/share/Steam/steamapps/common/Fantasy Strike/FS_Linux.bin() [0x990d1e]
    /home/garcia/.local/share/Steam/steamapps/common/Fantasy Strike/FS_Linux.bin() [0x451a71]
    /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe6) [0x7f77d27bbb96]
    /home/garcia/.local/share/Steam/steamapps/common/Fantasy Strike/FS_Linux.bin() [0x45d4f0]
     
    (Filename:  Line: 590)
    So I went to https://01.org/linuxgraphics/downloa...s-stack-recipe
    for a driver but my hardware is not in the sported hardware list.

    The video driver I got is i915.

    And this is what I get from the system profiler:
    system_information.png

  2. #2
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,533
    Distro
    Xubuntu 18.10 Cosmic Cuttlefish

    Re: Help with OpenGL in an old laptop

    The program complains that it needs at least openGL version 3.2. This site tells me that your graphics unit only supports openGL 2.1. So it's not going to work. The game needs features in your hardware that aren't present.

  3. #3
    Join Date
    May 2019
    Beans
    2

    Re: Help with OpenGL in an old laptop

    Thanks, I guess that's it :/

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •