Results 1 to 8 of 8

Thread: start up script

  1. #1
    Join Date
    Dec 2010
    Beans
    96
    Distro
    Ubuntu Gnome 16.04 Xenial Xerus

    start up script

    Hi. I want to disable caps lock once and forever and i added given script to both /etc/profile and ~/.profile:

    xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"

    However it doesn't work. What the proper place for a given script?

  2. #2
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    758
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: start up script

    Comments deleted because they did not contribute to discussion.
    Last edited by him610; 1 Week Ago at 01:30 PM. Reason: Self edit
    Cheers,
    I am not an expert on anything, but I pretend to be one at times.
    Software expands to consume available system resources.

  3. #3
    Join Date
    Dec 2017
    Beans
    671

    Re: start up script


  4. #4
    Join Date
    Dec 2010
    Beans
    96
    Distro
    Ubuntu Gnome 16.04 Xenial Xerus

    Re: start up script

    ~/.Xmodmap with text inside
    keycode 66 = Shift_L NoSymbol Shift_L
    doesn't work as well. Neither .xsessionrc/.xsession/.Xsession with text
    xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"
    Last edited by icegood; 1 Week Ago at 08:42 AM.

  5. #5
    Join Date
    Dec 2010
    Beans
    96
    Distro
    Ubuntu Gnome 16.04 Xenial Xerus

    Re: start up script

    tried setxkbmap -option caps:none as well

  6. #6
    Join Date
    Mar 2017
    Location
    Gubertino
    Beans
    887
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: start up script

    Are you using Kubuntu as your distro info indicates?

  7. #7
    Join Date
    Dec 2010
    Beans
    96
    Distro
    Ubuntu Gnome 16.04 Xenial Xerus

    Re: start up script

    No, unubtu 16.04 LTS. I will change setting here

  8. #8
    Join Date
    Mar 2017
    Location
    Gubertino
    Beans
    887
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: start up script

    In ubuntu 16.04 you can disable with dconf via terminal....
    Code:
    dconf write /org/gnome/desktop/input-sources/xkb-options "['caps:none']"
    To set back to default...
    Code:
    dconf reset /org/gnome/desktop/input-sources/xkb-options
    You can find other xkb-options for the capslock key towards the end of the following file.
    Open in gedit...
    Code:
    gedit /usr/share/X11/xkb/rules/base.lst
    From memory you can also use the GUI, "gnome-tweak-tool" but be aware it may pull in gnome-shell as a dependency.
    You appear to already be using gnome-shell though.
    Last edited by guber2; 1 Week Ago at 10:46 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •