Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

  1. #1
    Join Date
    Dec 2014
    Beans
    40

    Exclamation Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    After 5 days out of home, today I was back, and the PC, after suggesting me an update (done without problem), proposed me the 19.04 upgrade. I tried to do this but the upgrade failed with these two warnings:


    E:Repository 'http://deb.opera.com/opera stable InRelease' changed its 'Origin' value from 'Opera Software ASA' to 'Opera Software AS', W:This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
    E:The repository 'http://archive.canonical.com/ubuntu saucy Release' no longer has a Release file.


    At first I removed Opera, I don't use it anymore since it was amazingly slow to start. I removed also Skype that I had installed twice.
    the second message was still making me fail the upgrade:


    E:The repository 'http://archive.canonical.com/ubuntu saucy Release' no longer has a Release file.


    I did what is suggested oon the link:
    https://askubuntu.com/questions/9735...ntu-saucy-rele
    despite it is not quite new. It was the only suggestion I found on the net.


    I restarted the computer and I received again a suggestion for an update. This update failed with the following message:


    Ubuntu The installation or removal of a software package failed. It is something so fast that I was unable to copy the details.


    No way, now to reach the request to upgrade the System.


    I reinstalled Opera, and Skype, and disinstalled them again with no success.


    I am non a skillful Ubuntu user, so I would like to have a step-by-step help to clean the problems in my computer and upgrade Ubuntu to 19.04.


    Many thanks in advance,


    Carlo

  2. #2
    Join Date
    Dec 2017
    Beans
    660

    Re: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    Saucy? If your install is that old you should really consider a fresh install and not a upgrade.

    But let us have a look at what you have for a sources list. Please post the output of...
    Code:
    cat /etc/apt/sources.list && ls /etc/apt/sources.list.d/*.list
    Last edited by cruzer001; 3 Weeks Ago at 01:32 AM. Reason: Hello Bashing-om :)

  3. #3
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,200
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    cruzer001; Hello -

    Let's "suppose" those problematic sources are still in the system and still in effect,
    Post back - between code tags - the out puts of terminal commands:
    Code:
    cat -n /etc/apt/sources.list
    tail -v -n +1 /etc/apt/sources.list.d/*
    code tag tutorial:
    http://ubuntuforums.org/showthread.p...8#post12776168

    and we see what it is going to take to make it not so.

    clean - we like clean
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  4. #4
    Join Date
    Dec 2014
    Beans
    40
    Hi Thank you first for your kind help.
    My current Ubuntu version is 18.10, I really have no idea why I have this reference to SAUCY.

    The command you ask me to do gave the following output:

    Code:
    ~$ cat /etc/apt/sources.list && ls /etc/apt/sources.list.d/*.list
    deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu xenial-security main restricted universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu xenial-security main restricted universe multiverse
    #deb http://archive.ubuntu.com/ubuntu xenial-proposed restricted main universe multiverse
    #deb-src http://archive.ubuntu.com/ubuntu xenial-proposed restricted main universe multiverse
    deb http://archive.canonical.com/ubuntu xenial partner
    deb-src http://archive.canonical.com/ubuntu xenial partner
    /etc/apt/sources.list.d/behda-ppa-trusty.list
    /etc/apt/sources.list.d/caffeine-developers-ppa-saucy.list
    /etc/apt/sources.list.d/caffeine-developers-ppa-trusty.list
    /etc/apt/sources.list.d/canonical_partner.list
    /etc/apt/sources.list.d/diesch-testing-trusty.list
    /etc/apt/sources.list.d/djcj-ubuntu-vlc-stable-utopic.list
    /etc/apt/sources.list.d/flacon-ubuntu-ppa-utopic.list
    /etc/apt/sources.list.d/google-chrome.list
    /etc/apt/sources.list.d/jd-team-jdownloader-saucy.list
    /etc/apt/sources.list.d/mc3man-ubuntu-trusty-media-utopic.list
    /etc/apt/sources.list.d/opera.list
    /etc/apt/sources.list.d/opera-stable.list
    /etc/apt/sources.list.d/plushuang-tw-ubuntu-uget-stable-xenial.list
    /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_drawers_ubuntu.list
    /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_u-splitter_ubuntu.list
    /etc/apt/sources.list.d/rvm-ubuntu-smplayer-artful.list
    /etc/apt/sources.list.d/rvm-ubuntu-smplayer-bionic.list
    /etc/apt/sources.list.d/rvm-ubuntu-smplayer-zesty.list
    /etc/apt/sources.list.d/skype-stable.list
    /etc/apt/sources.list.d/starws-box-ubuntu-deadbeef-player-utopic.list
    /etc/apt/sources.list.d/strukturag-libde265-trusty.list
    /etc/apt/sources.list.d/team-xbmc-ubuntu-ppa-xenial.list
    /etc/apt/sources.list.d/ubuntu-wine-ppa-trusty.list
    /etc/apt/sources.list.d/videolan-master-daily-saucy.list
    /etc/apt/sources.list.d/vivaldi-beta.list
    /etc/apt/sources.list.d/vivaldi.list
    /etc/apt/sources.list.d/vivaldi-snapshot.list
    /etc/apt/sources.list.d/webupd8team-ubuntu-java-utopic.list
    /etc/apt/sources.list.d/webupd8team-ubuntu-java-wily.list


    The second command gave this output:

    Code:
    ~$ cat -n /etc/apt/sources.list
         1    deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
         2    deb-src http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
         3    deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
         4    deb-src http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
         5    deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
         6    deb-src http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
         7    deb http://archive.ubuntu.com/ubuntu xenial-security main restricted universe multiverse
         8    deb-src http://archive.ubuntu.com/ubuntu xenial-security main restricted universe multiverse
         9    #deb http://archive.ubuntu.com/ubuntu xenial-proposed restricted main universe multiverse
        10    #deb-src http://archive.ubuntu.com/ubuntu xenial-proposed restricted main universe multiverse
        11    deb http://archive.canonical.com/ubuntu xenial partner
        12    deb-src http://archive.canonical.com/ubuntu xenial partner
    ~$

    Finally, this is the third output

    Code:
    ~$ tail -v -n +1 /etc/apt/sources.list.d/*
    ==> /etc/apt/sources.list.d/behda-ppa-trusty.list <==
    
    
    ==> /etc/apt/sources.list.d/behda-ppa-trusty.list.save <==
    
    
    ==> /etc/apt/sources.list.d/caffeine-developers-ppa-saucy.list <==
    # deb http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu vivid main # disabled on upgrade to trusty disabled on upgrade to utopic disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/caffeine-developers-ppa-saucy.list.distUpgrade <==
    # deb http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu vivid main # disabled on upgrade to trusty disabled on upgrade to utopic disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/caffeine-developers-ppa-saucy.list.save <==
    # deb http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu vivid main # disabled on upgrade to trusty disabled on upgrade to utopic disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/caffeine-developers-ppa-trusty.list <==
    # deb-src http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/caffeine-developers-ppa-trusty.list.distUpgrade <==
    # deb-src http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/caffeine-developers-ppa-trusty.list.save <==
    # deb-src http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/canonical_partner.list <==
    deb http://archive.canonical.com/ubuntu/ cosmic partner
    
    
    ==> /etc/apt/sources.list.d/canonical_partner.list.distUpgrade <==
    deb http://archive.canonical.com/ubuntu/ cosmic partner
    
    
    ==> /etc/apt/sources.list.d/canonical_partner.list.save <==
    deb http://archive.canonical.com/ubuntu/ bionic partner
    
    
    ==> /etc/apt/sources.list.d/diesch-testing-trusty.list <==
    # deb http://ppa.launchpad.net/diesch/testing/ubuntu utopic main # disabled on upgrade to utopic
    # deb-src http://ppa.launchpad.net/diesch/testing/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/diesch-testing-trusty.list.distUpgrade <==
    # deb http://ppa.launchpad.net/diesch/testing/ubuntu utopic main # disabled on upgrade to utopic
    # deb-src http://ppa.launchpad.net/diesch/testing/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/diesch-testing-trusty.list.save <==
    # deb http://ppa.launchpad.net/diesch/testing/ubuntu utopic main # disabled on upgrade to utopic
    # deb-src http://ppa.launchpad.net/diesch/testing/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/djcj-ubuntu-vlc-stable-utopic.list <==
    # deb http://ppa.launchpad.net/djcj/vlc-stable/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/djcj/vlc-stable/ubuntu utopic main
    # deb-src http://ppa.launchpad.net/djcj/vlc-stable/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/djcj-ubuntu-vlc-stable-utopic.list.distUpgrade <==
    # deb http://ppa.launchpad.net/djcj/vlc-stable/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/djcj/vlc-stable/ubuntu utopic main
    # deb-src http://ppa.launchpad.net/djcj/vlc-stable/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/djcj-ubuntu-vlc-stable-utopic.list.save <==
    # deb http://ppa.launchpad.net/djcj/vlc-stable/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/djcj/vlc-stable/ubuntu utopic main
    # deb-src http://ppa.launchpad.net/djcj/vlc-stable/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/flacon-ubuntu-ppa-utopic.list <==
    # deb http://ppa.launchpad.net/flacon/ppa/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/flacon/ppa/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/flacon-ubuntu-ppa-utopic.list.distUpgrade <==
    # deb http://ppa.launchpad.net/flacon/ppa/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/flacon/ppa/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/flacon-ubuntu-ppa-utopic.list.save <==
    # deb http://ppa.launchpad.net/flacon/ppa/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/flacon/ppa/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/google-chrome.list <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main 
    
    
    ==> /etc/apt/sources.list.d/google-chrome.list.distUpgrade <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main 
    
    
    ==> /etc/apt/sources.list.d/google-chrome.list.save <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main 
    
    
    ==> /etc/apt/sources.list.d/jd-team-jdownloader-saucy.list <==
    # deb http://ppa.launchpad.net/jd-team/jdownloader/ubuntu trusty main # disabled on upgrade to trusty disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/jd-team/jdownloader/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/jd-team-jdownloader-saucy.list.distUpgrade <==
    # deb http://ppa.launchpad.net/jd-team/jdownloader/ubuntu trusty main # disabled on upgrade to trusty disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/jd-team/jdownloader/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/jd-team-jdownloader-saucy.list.save <==
    # deb http://ppa.launchpad.net/jd-team/jdownloader/ubuntu trusty main # disabled on upgrade to trusty disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/jd-team/jdownloader/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/mc3man-ubuntu-trusty-media-utopic.list <==
    # deb http://ppa.launchpad.net/mc3man/trusty-media/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/mc3man/trusty-media/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/mc3man-ubuntu-trusty-media-utopic.list.distUpgrade <==
    # deb http://ppa.launchpad.net/mc3man/trusty-media/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/mc3man/trusty-media/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/mc3man-ubuntu-trusty-media-utopic.list.save <==
    # deb http://ppa.launchpad.net/mc3man/trusty-media/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/mc3man/trusty-media/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/opera.list <==
    # This file makes sure that Opera Browser is kept up-to-date
    # as part of regular system upgrades
    
    
    deb http://deb.opera.com/opera/ stable non-free #Opera Browser (final releases)
    
    
    # The line above will make sure you get all final public releases.
    # Uncomment the following line if you want to get alpha and beta
    # releases, too.
    
    
    # deb http://deb.opera.com/opera-beta/ stable non-free #Opera Browser (beta releases)
    
    
    ==> /etc/apt/sources.list.d/opera.list.distUpgrade <==
    # This file makes sure that Opera Browser is kept up-to-date
    # as part of regular system upgrades
    
    
    deb http://deb.opera.com/opera/ stable non-free #Opera Browser (final releases)
    
    
    # The line above will make sure you get all final public releases.
    # Uncomment the following line if you want to get alpha and beta
    # releases, too.
    
    
    # deb http://deb.opera.com/opera-beta/ stable non-free #Opera Browser (beta releases)
    
    
    ==> /etc/apt/sources.list.d/opera.list.save <==
    # This file makes sure that Opera Browser is kept up-to-date
    # as part of regular system upgrades
    
    
    deb http://deb.opera.com/opera/ stable non-free #Opera Browser (final releases)
    
    
    # The line above will make sure you get all final public releases.
    # Uncomment the following line if you want to get alpha and beta
    # releases, too.
    
    
    # deb http://deb.opera.com/opera-beta/ stable non-free #Opera Browser (beta releases)
    
    
    ==> /etc/apt/sources.list.d/opera-stable.list <==
    # This file makes sure that Opera Browser is kept up-to-date
    # as part of regular system upgrades
    
    
    # deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases) disabled on upgrade to xenial
    
    
    ==> /etc/apt/sources.list.d/opera-stable.list.distUpgrade <==
    # This file makes sure that Opera Browser is kept up-to-date
    # as part of regular system upgrades
    
    
    # deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases) disabled on upgrade to xenial
    
    
    ==> /etc/apt/sources.list.d/opera-stable.list.save <==
    # This file makes sure that Opera Browser is kept up-to-date
    # as part of regular system upgrades
    
    
    # deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases) disabled on upgrade to xenial
    
    
    ==> /etc/apt/sources.list.d/plushuang-tw-ubuntu-uget-stable-xenial.list <==
    # deb http://ppa.launchpad.net/plushuang-t...-stable/ubuntu yakkety main # disabled on upgrade to yakkety
    # deb-src http://ppa.launchpad.net/plushuang-t...-stable/ubuntu xenial main
    
    
    ==> /etc/apt/sources.list.d/plushuang-tw-ubuntu-uget-stable-xenial.list.distUpgrade <==
    # deb http://ppa.launchpad.net/plushuang-t...-stable/ubuntu yakkety main # disabled on upgrade to yakkety
    # deb-src http://ppa.launchpad.net/plushuang-t...-stable/ubuntu xenial main
    
    
    ==> /etc/apt/sources.list.d/plushuang-tw-ubuntu-uget-stable-xenial.list.save <==
    # deb http://ppa.launchpad.net/plushuang-t...-stable/ubuntu yakkety main # disabled on upgrade to yakkety
    # deb-src http://ppa.launchpad.net/plushuang-t...-stable/ubuntu xenial main
    
    
    ==> /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_drawers_ubuntu.list <==
    # deb https://private-ppa.launchpad.net/co...drawers/ubuntu trusty main #Added by software-center; credentials stored in /etc/apt/auth.conf disabled on upgrade to trusty disabled on upgrade to vivid
    
    
    ==> /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_drawers_ubuntu.list.distUpgrade <==
    # deb https://private-ppa.launchpad.net/co...drawers/ubuntu trusty main #Added by software-center; credentials stored in /etc/apt/auth.conf disabled on upgrade to trusty disabled on upgrade to vivid
    
    
    ==> /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_drawers_ubuntu.list.save <==
    # deb https://private-ppa.launchpad.net/co...drawers/ubuntu trusty main #Added by software-center; credentials stored in /etc/apt/auth.conf disabled on upgrade to trusty disabled on upgrade to vivid
    
    
    ==> /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_u-splitter_ubuntu.list <==
    # deb https://private-ppa.launchpad.net/co...plitter/ubuntu trusty main #Added by software-center; credentials stored in /etc/apt/auth.conf disabled on upgrade to trusty disabled on upgrade to vivid
    
    
    ==> /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_u-splitter_ubuntu.list.distUpgrade <==
    # deb https://private-ppa.launchpad.net/co...plitter/ubuntu trusty main #Added by software-center; credentials stored in /etc/apt/auth.conf disabled on upgrade to trusty disabled on upgrade to vivid
    
    
    ==> /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_u-splitter_ubuntu.list.save <==
    # deb https://private-ppa.launchpad.net/co...plitter/ubuntu trusty main #Added by software-center; credentials stored in /etc/apt/auth.conf disabled on upgrade to trusty disabled on upgrade to vivid
    
    
    ==> /etc/apt/sources.list.d/rvm-ubuntu-smplayer-artful.list <==
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu artful main
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu artful main
    
    
    ==> /etc/apt/sources.list.d/rvm-ubuntu-smplayer-artful.list.distUpgrade <==
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu artful main
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu artful main
    
    
    ==> /etc/apt/sources.list.d/rvm-ubuntu-smplayer-artful.list.save <==
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu artful main
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu artful main
    
    
    ==> /etc/apt/sources.list.d/rvm-ubuntu-smplayer-bionic.list <==
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu bionic main
    
    
    ==> /etc/apt/sources.list.d/rvm-ubuntu-smplayer-bionic.list.distUpgrade <==
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu bionic main
    
    
    ==> /etc/apt/sources.list.d/rvm-ubuntu-smplayer-zesty.list <==
    # deb http://ppa.launchpad.net/rvm/smplayer/ubuntu cosmic main # disabled on upgrade to artful disabled on upgrade to bionic disabled on upgrade to cosmic
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu zesty main
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu zesty main
    
    
    ==> /etc/apt/sources.list.d/rvm-ubuntu-smplayer-zesty.list.distUpgrade <==
    # deb http://ppa.launchpad.net/rvm/smplayer/ubuntu cosmic main # disabled on upgrade to artful disabled on upgrade to bionic disabled on upgrade to cosmic
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu zesty main
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu zesty main
    
    
    ==> /etc/apt/sources.list.d/rvm-ubuntu-smplayer-zesty.list.save <==
    # deb http://ppa.launchpad.net/rvm/smplayer/ubuntu bionic main # disabled on upgrade to artful disabled on upgrade to bionic
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu zesty main
    # deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu zesty main
    
    
    ==> /etc/apt/sources.list.d/skype-stable.list <==
    # deb [arch=amd64] https://repo.skype.com/deb stable main # disabled on upgrade to bionic
    
    
    ==> /etc/apt/sources.list.d/skype-stable.list.distUpgrade <==
    # deb [arch=amd64] https://repo.skype.com/deb stable main # disabled on upgrade to bionic
    
    
    ==> /etc/apt/sources.list.d/skype-stable.list.save <==
    # deb [arch=amd64] https://repo.skype.com/deb stable main # disabled on upgrade to bionic
    
    
    ==> /etc/apt/sources.list.d/starws-box-ubuntu-deadbeef-player-utopic.list <==
    # deb http://ppa.launchpad.net/starws-box/...-player/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/starws-box/...-player/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/starws-box-ubuntu-deadbeef-player-utopic.list.distUpgrade <==
    # deb http://ppa.launchpad.net/starws-box/...-player/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/starws-box/...-player/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/starws-box-ubuntu-deadbeef-player-utopic.list.save <==
    # deb http://ppa.launchpad.net/starws-box/...-player/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/starws-box/...-player/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/strukturag-libde265-trusty.list <==
    # deb http://ppa.launchpad.net/strukturag/libde265/ubuntu utopic main # disabled on upgrade to utopic
    # deb-src http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
    # deb-src http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/strukturag-libde265-trusty.list.distUpgrade <==
    # deb http://ppa.launchpad.net/strukturag/libde265/ubuntu utopic main # disabled on upgrade to utopic
    # deb-src http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
    # deb-src http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/strukturag-libde265-trusty.list.save <==
    # deb http://ppa.launchpad.net/strukturag/libde265/ubuntu utopic main # disabled on upgrade to utopic
    # deb-src http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
    # deb-src http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/team-xbmc-ubuntu-ppa-xenial.list <==
    # deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu yakkety main # disabled on upgrade to yakkety
    # deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
    
    
    ==> /etc/apt/sources.list.d/team-xbmc-ubuntu-ppa-xenial.list.distUpgrade <==
    # deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu yakkety main # disabled on upgrade to yakkety
    # deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
    
    
    ==> /etc/apt/sources.list.d/team-xbmc-ubuntu-ppa-xenial.list.save <==
    # deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu yakkety main # disabled on upgrade to yakkety
    # deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
    
    
    ==> /etc/apt/sources.list.d/ubuntu-wine-ppa-trusty.list <==
    # deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu vivid main # disabled on upgrade to utopic disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/ubuntu-wine-ppa-trusty.list.distUpgrade <==
    # deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu vivid main # disabled on upgrade to utopic disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/ubuntu-wine-ppa-trusty.list.save <==
    # deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu vivid main # disabled on upgrade to utopic disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty main
    
    
    ==> /etc/apt/sources.list.d/videolan-master-daily-saucy.list <==
    # deb http://ppa.launchpad.net/videolan/master-daily/ubuntu trusty main # disabled on upgrade to trusty disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/videolan/master-daily/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/videolan-master-daily-saucy.list.distUpgrade <==
    # deb http://ppa.launchpad.net/videolan/master-daily/ubuntu trusty main # disabled on upgrade to trusty disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/videolan/master-daily/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/videolan-master-daily-saucy.list.save <==
    # deb http://ppa.launchpad.net/videolan/master-daily/ubuntu trusty main # disabled on upgrade to trusty disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/videolan/master-daily/ubuntu saucy main
    
    
    ==> /etc/apt/sources.list.d/vivaldi-beta.list <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/beta/deb/ stable main # disabled on upgrade to xenial
    
    
    ==> /etc/apt/sources.list.d/vivaldi-beta.list.distUpgrade <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/beta/deb/ stable main # disabled on upgrade to xenial
    
    
    ==> /etc/apt/sources.list.d/vivaldi-beta.list.save <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/beta/deb/ stable main # disabled on upgrade to xenial
    
    
    ==> /etc/apt/sources.list.d/vivaldi.list <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/stable/deb/ stable main
    
    
    ==> /etc/apt/sources.list.d/vivaldi.list.distUpgrade <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/stable/deb/ stable main
    
    
    ==> /etc/apt/sources.list.d/vivaldi.list.save <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/stable/deb/ stable main
    
    
    ==> /etc/apt/sources.list.d/vivaldi-snapshot.list <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/snapshot/deb/ stable main
    
    
    ==> /etc/apt/sources.list.d/vivaldi-snapshot.list.distUpgrade <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/snapshot/deb/ stable main
    
    
    ==> /etc/apt/sources.list.d/vivaldi-snapshot.list.save <==
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    # deb http://repo.vivaldi.com/snapshot/deb/ stable main
    
    
    ==> /etc/apt/sources.list.d/webupd8team-ubuntu-java-utopic.list <==
    # deb http://ppa.launchpad.net/webupd8team/java/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/webupd8team-ubuntu-java-utopic.list.distUpgrade <==
    # deb http://ppa.launchpad.net/webupd8team/java/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/webupd8team-ubuntu-java-utopic.list.save <==
    # deb http://ppa.launchpad.net/webupd8team/java/ubuntu vivid main # disabled on upgrade to vivid
    # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu utopic main
    
    
    ==> /etc/apt/sources.list.d/webupd8team-ubuntu-java-wily.list <==
    # deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main # disabled on upgrade to xenial
    # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu wily main
    
    
    ==> /etc/apt/sources.list.d/webupd8team-ubuntu-java-wily.list.distUpgrade <==
    # deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main # disabled on upgrade to xenial
    # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu wily main
    
    
    ==> /etc/apt/sources.list.d/webupd8team-ubuntu-java-wily.list.save <==
    # deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main # disabled on upgrade to xenial
    # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu wily main
    ~$

    Many thanks again

    One more thing:
    Since you will be my "doctor" in this session, I must tell you I live in Italy, so my time is GMT+1 (+Legal Time). And... I was born in 1956, but still willing to learn!
    I deeply dislike Windows (I am obliged to use it at work, until July, then I will go in retirement ) and at home I have only Ubuntu.

    Carlo
    Last edited by deadflowr; 3 Weeks Ago at 06:47 PM. Reason: posts merged

  5. #5
    Join Date
    Dec 2017
    Beans
    660

    Re: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    You say that your on 18.10, but your sources.list says your running Xenial 16.04.

    You have a tall stack of inactive PPAs in sources.list.d and a few active ones that do not belong there.

    I would suggest removing all PPAs and then trying another upgrade, but lets wait and see what Bashing-om has to say.

    Italy! I lived in Vicarello for a few years

  6. #6
    Join Date
    Dec 2014
    Beans
    40

    Re: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    Just now I did
    lsb_release -a
    Code:
    lsb_release -aNo LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 18.10
    Release:	18.10
    Codename:	cosmic
    And the screenshot of my ubuntu is:Screenshot from 2019-04-24 19-40-27.png

    I did all the upgrades since I have Ubuntu. It maybe the first version on THIS computer was on 2016.

  7. #7
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,533
    Distro
    Xubuntu 18.10 Cosmic Cuttlefish

    Re: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    Something weird is going on. The only explanantion I can think of right now is that you upgraded to 18.10, then restored the software sources for 16.04 from a backup (leading to almost no updates at all, as the updated packages for 16.04 have earlier version numbers than the outdated packages on 18.10). Actually, I can imagine a failed upgrade doing such a thing when a backup of the 16.04 sources.list was still around.

    Just to check this theory, what do you get from
    Code:
    apt-cache policy base-files
    Version 9.4ubuntu4.8 is the one belonging to your software sources, version 10.1ubuntu7 the one that should tell you that you're running Ubuntu 18.10.

  8. #8
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    Well I at this point agree with Impavidus something very wonky here >> If you don't show the correct version Impavidus is showing like:
    Code:
    apt policy base-files
    base-files:
      Installed: 10.1ubuntu9
      Candidate: 10.1ubuntu9
      Version table:
     *** 10.1ubuntu9 500
            500 http://archive.ubuntu.com/ubuntu disco/main amd64 Packages
            100 /var/lib/dpkg/status
    I have used "sed" for a number of years now changing my source lists, with very few problems. I don't use "do-release-upgrade -d" any more.
    Code:
     sudo sed -i 's/cosmic/disco/g' /etc/apt/sources.list
    Update and Upgrade again:
    Code:
    sudo apt update 
    sudo apt full-upgrade
    Before enabling all your PPA's first check they are supported for (19.04)
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  9. #9
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,200
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    carlo-sanguineti - Hey

    In addition to the ups excellent advisements will be good to know the gpg-key situation. There is a 40 key limit,
    Code:
    ls /etc/apt/trusted.gpg.d | wc -l
    Pending what "apt-cache policy base-files" reveals for which direction we take off in.

    takes a lot to clean up a big mess
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  10. #10
    Join Date
    Dec 2014
    Beans
    40

    Re: Problems with upgrade to Ubuntu 19.04 - Situation deteriorating.

    Hello,

    the output is:
    Code:
    :~$ apt-cache policy base-filesbase-files:
      Installed: 10.1ubuntu7
      Candidate: 10.1ubuntu7
      Version table:
     *** 10.1ubuntu7 100
            100 /var/lib/dpkg/status
         9.4ubuntu4.8 500
            500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
         9.4ubuntu4 500
            500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    Thank You for your help
    Carlo

Page 1 of 5 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •