Page 5 of 8 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 74

Thread: Slow booting of Ubuntu?

  1. #41
    Join Date
    Apr 2019
    Beans
    47

    Re: Slow booting of Ubuntu?

    I'm starting to believe it's this version of Ubuntu that is slow in booting up in general. Thanks for the feedback and help guys. Oldfred I'm going to try sudo apt autoremove --purge snapd and that's going to be it. I went over the link in post 6, thank you by the way, regarding the vacuum option / instructions and i really don't think that it's the right solution for this computer at this point in time. I just know it's going to lead to other issues down the track.

    I just ran sudo apt autoremove --purge snapd and this was the output

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package 'snapd' is not installed, so not removed
    0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.


    Thanks for the tip about software centre. Come to think of it i don't believe i need software centre for the time being so i might as well remove it. I suppose i can always re install it later.

    I think I'll just put this slow boot up aside for the time being and just live with it.

    I don't know about you guys, but i think there should be another label other than solved because i don't believe for a second that I'm the only one experiencing slow boot up. Having said that if you guys are in agreement i will change the post to solved if there's no other label to use.

    Thanks guys for your time and patience and advice. I appreciate it.
    Last edited by swangnation; April 30th, 2019 at 12:43 PM.

  2. #42
    Join Date
    Apr 2019
    Beans
    47

    Re: Slow booting of Ubuntu?

    I think i may have discovered the problem guys. Bare with me on this.

    when i run sudo blkid i get the following output :
    Code:
    /dev/sda1: UUID="5DC3-6837" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="e000da08-a5a8-4be8-8daf-7cd675391fb6"
    /dev/sda2: UUID="9de9c2ba-62f7-432d-80a6-d71aed4140c8" TYPE="ext4" PARTUUID="f8c6f955-f15a-4264-ae44-b0b2cc49360b"
    Then when i run cat /etc/fstab i get the following output :

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/sda2 during installation
    UUID=9de9c2ba-62f7-432d-80a6-d71aed4140c8 /               ext4    errors=remount-ro 0       1
    # /boot/efi was on /dev/sda1 during installation
    UUID=5DC3-6837  /boot/efi       vfat    umask=0077      0       1
    /swapfile                                 none            swap    sw              0       0
    /swapfile non swap sw 0 0

    I created an 8gb swap file. Why isn't it showing up here and is it possible that the system is trying to find it but can't, gives up on trying to find it and THEN boots up?

  3. #43
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow booting of Ubuntu?

    Ubuntu default install now uses a swap file, which you show.
    You do not show a swap partition nor the system trying to mount a swap partition.

    Does this show swap file?
    ls -lh /swapfile
    sudo swapon --show
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #44
    Join Date
    Apr 2019
    Beans
    47

    Re: Slow booting of Ubuntu?

    Quote Originally Posted by oldfred View Post
    Ubuntu default install now uses a swap file, which you show.
    You do not show a swap partition nor the system trying to mount a swap partition.

    Does this show swap file?
    ls -lh /swapfile
    sudo swapon --show
    sudo swapon --show :


    Code:
    NAME      TYPE SIZE USED PRIO
    /swapfile file   8G   0B   -2
    hmmm

  5. #45
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow booting of Ubuntu?

    How much RAM do you have if not 16GB or more swap is too large.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #46
    Join Date
    May 2019
    Beans
    1

    Re: Slow booting of Ubuntu?

    I'm not experiencing any slow boot on my site. I only have 8gb ram mind you.

  7. #47
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow booting of Ubuntu?

    Slow boot should not be related to RAM unless you have less than 2GB.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #48
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow booting of Ubuntu?

    I just made the following changes, did not test all at once so not sure which made real difference

    turned off NetworkManager-wait
    Changed systemctl daily timer for
    housecleaned systemctl logs
    changed from quiet splash to noplymouth, will see boot process rather than Ubuntu logo
    sudo apt install libblockdev-crypto2 libblockdev-mdraid2
    turned off printer when rebooting

    fred@Bionic-Z170N:~$ systemd-analyze
    Startup finished in 2.794s (kernel) + 8.918s (userspace) = 11.712s
    graphical.target reached after 8.899s in userspace

    Was over 30 sec, then after some changes, mid 20 sec. Now about 12 sec.

    I can post details if desired, of how I changed settings, but late now, so signing off.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  9. #49
    Join Date
    Apr 2019
    Beans
    47

    Re: Slow booting of Ubuntu?

    i have 4gb ram Oldfred. with
    Code:
    systemd-analyze blame
    i get the following :

    Code:
    18.589s systemd-journal-flush.service
             17.987s plymouth-quit-wait.service
             15.099s dev-sda2.device
             13.453s systemd-tmpfiles-setup-dev.service
             11.443s apt-daily-upgrade.service
              4.709s grub-common.service
              4.523s udisks2.service
              4.473s networkd-dispatcher.service
              3.468s preload.service
              3.418s ModemManager.service
              3.005s systemd-sysctl.service
              2.871s NetworkManager.service
              2.612s accounts-daemon.service
              2.526s motd-news.service
              2.217s apt-daily.service
              1.844s user@121.service
              1.560s apport.service
              1.492s keyboard-setup.service
              1.425s systemd-resolved.service
    Why can't i just disable the top 5 services so they don't boot up? AM I able to disable them without running into any issues?

  10. #50
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow booting of Ubuntu?

    I cleared systemd journal, saved several GB as now MB. May be slow reading/writing on boot if large.
    Added this command to a script I run weekly on housecleaning.

    https://ma.ttias.be/clear-systemd-journal/
    https://unix.stackexchange.com/quest...ear-journalctl
    du -hs /var/log/journal/
    ls -lath /var/log/journal/*/ | tail -n 2
    Clear logs over 10 days
    sudo journalctl --vacuum-time=10d

    Changed grub parameters to add noplymounth & remove quiet splash (fastboot only for skylake and newer or it may make issues):
    GRUB_CMDLINE_LINUX_DEFAULT="noplymouth i915.fastboot=1"
    sudo nano /etc/default/grub
    sudo update-grub

    https://ubuntu-mate.community/t/shor...-service/12297
    This is Debian bug #844453. apt-daily.service shouldn't be run during boot
    in /etc/systemd/system/apt-daily.timer.d/override.conf
    /etc/systemd/system

    https://askubuntu.com/questions/8004...-daily-service
    sudo systemctl edit apt-daily.timer
    # apt-daily timer configuration override
    [Timer]
    OnBootSec=15min
    OnUnitActiveSec=1d
    AccuracySec=1h
    RandomizedDelaySec=30min
    systemctl status plymouth-quit-wait.service
    https://ubuntu-mate.community/t/shor...-service/12297
    sudo systemctl edit apt-daily.timer
    file:///etc/systemd/system/apt-daily.timer.d
    https://bugs.launchpad.net/ubuntu/+s...t/+bug/1667769
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 5 of 8 FirstFirst ... 34567 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •