Page 2 of 7 FirstFirst 1234 ... LastLast
Results 11 to 20 of 67

Thread: Slow booting of Ubuntu?

  1. #11
    Join Date
    Apr 2019
    Beans
    32

    Re: Slow booting of Ubuntu?

    Quote Originally Posted by TheFu View Post
    Did that "proposed" snapd solution work or not? It isn't clear.

    I didn't suggest running in text-only mode, at least that wasn't my intention. If you are new to Linux, that would probably turn your computer into a doorstop. Most people need a GUI to do 99% of what they want a desktop.

    I suggested installing gnome-desktop using the normal package manager, then removing the gnome parts inside snaps with snap remove. The order matters. I don't know if this works or not. It could leave the system in a bad situation where reloading is the only option. Don't do it without having good backups for anything you cannot lose.

    I would expect that removing each of the installed snaps BEFORE removing the snapd subsystem would be necessary. Before that, installing the non-snap version of the packages using apt or synaptic or apt-get or aptitude is probably what you want. This is all guessing.

    Be certain you have backups.
    It has helped however I'm now more adamant that its the grub configuration that needs to be edited also because i think i've done all i can WITHOUT editing the grub configuration manually.

  2. #12
    Join Date
    Apr 2019
    Beans
    32

    Re: Slow booting of Ubuntu?

    Quote Originally Posted by TheFu View Post
    Did that "proposed" snapd solution work or not? It isn't clear.

    I didn't suggest running in text-only mode, at least that wasn't my intention. If you are new to Linux, that would probably turn your computer into a doorstop. Most people need a GUI to do 99% of what they want a desktop.

    I suggested installing gnome-desktop using the normal package manager, then removing the gnome parts inside snaps with snap remove. The order matters. I don't know if this works or not. It could leave the system in a bad situation where reloading is the only option. Don't do it without having good backups for anything you cannot lose.

    I would expect that removing each of the installed snaps BEFORE removing the snapd subsystem would be necessary. Before that, installing the non-snap version of the packages using apt or synaptic or apt-get or aptitude is probably what you want. This is all guessing.

    Be certain you have backups.

    Just wondering if this is normal??

    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0001,0002,0003,0004
    Boot0001* ubuntu
    Boot0002* UEFI:CD/DVD Drive
    Boot0003* UEFI:Removable Device
    Boot0004* UEFI:Network Device
    grub-install: info: executing efibootmgr -b 0001 -B.
    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0002,0003,0004
    Boot0002* UEFI:CD/DVD Drive
    Boot0003* UEFI:Removable Device
    Boot0004* UEFI:Network Device
    grub-install: info: executing efibootmgr -c -d /dev/sda -p 1 -w -L ubuntu -l \EFI\ubuntu\shimx64.efi.
    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0000,0002,0003,0004
    Boot0002* UEFI:CD/DVD Drive
    Boot0003* UEFI:Removable Device
    Boot0004* UEFI:Network Device
    Boot0000* ubuntu
    Installation finished. No error reported.

    from the above i get the impression it's trying to boot up 3 times?? I'm confused

  3. #13
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow booting of Ubuntu?

    It looks like it listed your UEFI entries with ubuntu as 0001, then deleted 0001 and showed entries.
    Then did a new install of ubuntu as 0000 and showed entries again.
    Does ubuntu entry work?
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #14
    Join Date
    Apr 2019
    Beans
    32

    Re: Slow booting of Ubuntu?

    Quote Originally Posted by oldfred View Post
    It looks like it listed your UEFI entries with ubuntu as 0001, then deleted 0001 and showed entries.
    Then did a new install of ubuntu as 0000 and showed entries again.
    Does ubuntu entry work?
    Silly question but what do you mean by ubuntu entry??

    Just so you can get an idea of how long its been since I've used any linux, the last time was back in the dial up days of the mid nineties when i had red hat version 4 along with the manual which is almost as thick as me lol....which i still have by the way.

    I've also been forgetting to turn off my automatic updates which has not helped at all! Just turned them off a minute ago and as of now...i will not updating anything for quite a while unless absolutely necessary.
    Last edited by swangnation; 4 Weeks Ago at 10:45 AM.

  5. #15
    Join Date
    Apr 2019
    Beans
    32

    Re: Slow booting of Ubuntu?

    Hi guys, I'm determined to get to the bottom of this slow boot time. In the previous posts I've explained that i have run a purge on snapd applications/programs and then reinstalled as per instructions in the link suggested and it has definitely helped. So prior to purge, my boot up time ( boot up time meaning from power on to login screen ) was 1 minute 18 seconds. Now my boot up time is is 59 seconds. In the last hour i have turned off all of my auto updates wherever i have found them because the auto updates have not helped at all! Dumb mistake on my part there.

    Now I'll explain what happens when i power on : Blank purple screen for between 20 - 30 seconds, then screen goes black for about 3 seconds, then purple screen again with "ubuntu" and the 4 dots progress right beneath for about 10 seconds and then the login screen.

    Late last night i did a grub install -v and the following came up : Note that this is before i turned off my auto updates, not sure if that means anything in this context.

    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0001,0002,0003,0004
    Boot0001* ubuntu
    Boot0002* UEFI:CD/DVD Drive
    Boot0003* UEFI:Removable Device
    Boot0004* UEFI:Network Device
    grub-install: info: executing efibootmgr -b 0001 -B.
    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0002,0003,0004
    Boot0002* UEFI:CD/DVD Drive
    Boot0003* UEFI:Removable Device
    Boot0004* UEFI:Network Device
    grub-install: info: executing efibootmgr -c -d /dev/sda -p 1 -w -L ubuntu -l \EFI\ubuntu\shimx64.efi.
    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0000,0002,0003,0004
    Boot0002* UEFI:CD/DVD Drive
    Boot0003* UEFI:Removable Device
    Boot0004* UEFI:Network Device
    Boot0000* ubuntu
    Installation finished. No error reported.

    Now in the last hour i have turned off my auto updates and have solemnly vowed ( to myself ) to never upgrade unless absolutely necessary and ran grub install -v again and this is what came up :

    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0002,0003,0004
    Boot0002* UEFI:CD/DVD Drive
    Boot0003* UEFI:Removable Device
    Boot0004* UEFI:Network Device
    grub-install: info: executing efibootmgr -c -d /dev/sda -p 1 -w -L ubuntu -l \EFI\ubuntu\shimx64.efi.
    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0000,0002,0003,0004
    Boot0002* UEFI:CD/DVD Drive
    Boot0003* UEFI:Removable Device
    Boot0004* UEFI:Network Device
    Boot0000* ubuntu
    Installation finished. No error reported.

    Not sure whats happened there or why.

    Now I'm going to list what comes up in my grub customizer in order of appearance, sorry by the way but i unable to post screenshots at this point in time.

    List Configuration:
    ubuntu
    menu entry / script linux
    • advaced menu for ubuntu

    submenu
    ubunutu, with linux 4.18.0-18 generic
    menu entry / script linux
    ubunutu, with linux 4.18.0-18 generic (recovery mode)
    menu entry / script linux
    ubunutu, with linux 4.18.0-17 generic I have unchecked this box myself. If it's wrong to do this please correct me
    menu entry / script linux
    ubunutu, with linux 4.18.0-17 generic (recovery mode) I have unchecked this box myself. If it's wrong to do this please correct me
    menu entry / script linux
    sytem setup
    menu entry / script : uefi-firmware

    General Settings:
    Default Entry : has predefined box checked and (first entry) option selected in dropdown menu. Note in dropdown menu there are the following options Ubuntu, ubunutu, with linux 4.18.0-18 generic, ubunutu, with linux 4.18.0-18 generic (recovery mode) and sytem setup

    Visibility : Show menu box is checked, i have unchecked "look for other operating systems" as i only have ubuntu and the boot default entry box is checked at 0 seconds.

    Kernel Parameters :
    Quiet splash
    generate recovery entires box is checked


    I hope this helps you guys in pointing me in the right direction becuase i do believe the boot time can be quicker. As mentioned above, it's the blank purple screen that just hangs for 20-30 seconds that takes up the longest time and i do believe it can be reduced. By how much i'm not sure

    Again.......i will thank you guys for your patience.

  6. #16
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow booting of Ubuntu?

    Do not know grub customizer as the minor changes I do to grub, I just edit the files.

    You may need a boot parameter. Did you review post #6.

    What brand/model system?
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  7. #17
    Join Date
    Apr 2019
    Beans
    32

    Re: Slow booting of Ubuntu?

    Quote Originally Posted by oldfred View Post
    Do not know grub customizer as the minor changes I do to grub, I just edit the files.

    You may need a boot parameter. Did you review post #6.

    What brand/model system?

    I just ran these

    journalctl --disk-usage
    Archived and active journals take up 680.0M in the file system.


    journalctl -b --unit systemd-journald
    -- Logs begin at Fri 2019-03-29 10:41:38 AEDT, end at Thu 2019-04-25 23:20:12 AEST. --
    Apr 25 20:06:56 praetorian systemd-journald[270]: Journal started
    Apr 25 20:06:56 praetorian systemd-journald[270]: Runtime journal (/run/log/journal/bc694bc40adf4926b81c2dc0b5371e5f) is 4.2M, max 33.8M, 29.5M free.
    Apr 25 20:06:57 praetorian systemd-journald[270]: Time spent on flushing to /var is 11.579874s for 771 entries.
    Apr 25 20:06:57 praetorian systemd-journald[270]: System journal (/var/log/journal/bc694bc40adf4926b81c2dc0b5371e5f) is 656.0M, max 4.0G, 3.3G free.

    system is asus x055e amd quadcore 4gb ram
    Brand meaning ubuntu version? 18.04.2 Lts?

  8. #18
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    16,340
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Slow booting of Ubuntu?

    Things that can slow down booting:
    * BIOS boot order that doesn't have the Ubuntu Grub disk listed first. If the BIOS has to check all USB devices first or some optical media, going through all of those can take time.
    * Lots of devices connected, especially USB.

    Built a new system a few months ago. Installed one of those 37-in-5 media panels on the front. It provided 4 USB2 ports, 2 USB3 ports and slots for SDHC, MicroSC, CF, SONY MS, MS2 and a few other slot formats. All the slots go into 1 USB2 header on the MB. The 4xUSB2 ports go into another header and the USB3 ports yet another header. I tested them all and they all worked. Great. But reboots where taking 3-5 minutes. Because each of those slots might have storage to boot, so the OS decided to check each one. Checking normal USB ports is relatively fast but checking each of those slots seems to take 20+ seconds. I don't reboot that system much, so I ignored it for a month. Then I was doing some work that required multiple reboots and that was driving nuts, so I unplugged all the USB2 connections, leaving just the USB3 and eSATA connection. Boots were fast again.

    If you think the logs are taking too much space, why don't you reduce the allowed size? There's a journald.conf file for that. You can also tweak the logrotate.d/ config files as you like. And if you really don't want much storage used, consider using a RAMdisk for logs like imbedded systems do.

    OTOH, if you only reboot once a month, does a slow boot matter?
    Code:
    $ uptime 
     11:59:58 up 19 days,  3:44,  3 users,
    or
    Code:
    $ uptime
     11:59:44 up 7 days,  4:50,  6 users,
    If you reboot daily, would a slight change in habit make this a non-issue? Boot the computer, then get some coffee, by the time you return, it is ready. Visit most enterprise companies and this happens 50K times every morning.

  9. #19
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Slow booting of Ubuntu?

    Did you update UEFI & SSD firmware?
    You may need boot parameter as many models of Asus ahve needed pci=nomsi.
    Try by editing grub when you boot and remove quiet splash parameters, so you see boot process. It will go by quickly but may give some clues.
    If parameter works we can make it permanent by simple edit to /etc/default/grub.

    Asus x541ua Update of UEFI & SSD firmware solved issues
    https://ubuntuforums.org/showthread.php?t=2414431
    How to install Ubuntu on ASUS F556U, JournalError error? add pci=nomsi
    https://askubuntu.com/questions/1079...081221#1081221
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  10. #20
    Join Date
    Apr 2019
    Beans
    32

    Re: Slow booting of Ubuntu?

    Sorry oldfred. Been busy and until now, I've been quite reluctant to open the grub. I have now. I hope this gives you and anyone else a better idea of whats going on with this laptop, I'm going to have a look at the links you posted shortly. AMD have never been all that good. I might have to consider adding a permanent boot parameter because a friend of mine suggested looking into it at the very least as AMD structure is different to Intel.

    GRUB_DEFAULT="0"
    GRUB_TIMEOUT_STYLE="hidden"
    GRUB_TIMEOUT="0"
    GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL="console"

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE="640x480"

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID="true"

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    export GRUB_COLOR_NORMAL="light-gray/black"
    export GRUB_COLOR_HIGHLIGHT="light-green/black"
    GRUB_DISABLE_OS_PROBER="true"

Page 2 of 7 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •