Results 1 to 5 of 5

Thread: Ubuntu Mate 19.04 boots up in terminal instead of Mate desktop environment

  1. #1
    Join Date
    Apr 2019
    Beans
    2

    Ubuntu Mate 19.04 boots up in terminal instead of Mate desktop environment

    After installing Ubuntu Mate 19.04 I wanted to change the lockscreen wallpaper and didn't find a direct way of doing in the wallpaper/display setting. Hence I renamed the wallpaper currently used for the lockscreen and replaced it with a soft link with the wallpaper of my choice - and it worked fine.


    Then after reading through some forums, I stumbled upon installing lightDM-gtk-greeter package from the terminal. However, I didn't find a quick way to control lockscreen wallpaper and hence I removed it via terminal commands:
    ```sudo apt-get purge lighDM*```


    And then rebooted the system which led to booting up in the terminal mode.
    I assume/guess after purging (this may not be the right/clean way to remove a package) there should be some init file which I may have to tweak. Maybe that init file is still looking for lightDM stuff and as it is not there it got defaulted to booting up in terminal mode.


    Please, can anyone help
    1. guide me through this? how to recover
    2. and explain what may have gone wrong
    3. and good practices to uninstall applications the right/clean way?


    PS: This is my day 2 using Linux for a desktop environment. Pardon for asking something obvious.
    Last edited by nishi10; 4 Weeks Ago at 01:51 PM.

  2. #2
    Join Date
    Jun 2016
    Beans
    1,825
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Ubuntu Mate 19.04 boots up in terminal instead of Mate desktop environment

    It would help to know exactly what was purged. Log in in terminal mode, then check /var/log/apt/history.log for the log entry showing the results of running the rogue command, by running this -

    Code:
    less /var/log/apt/history.log
    Please post the full log entry here (everything between the associated Start-Date and End-Date).

    As for what went wrong? LightDM is the program that displays the graphical login screen, so purging it will result in the system using terminal mode for the login.
    Last edited by halogen2; 4 Weeks Ago at 02:24 PM.

  3. #3
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Ubuntu Mate 19.04 boots up in terminal instead of Mate desktop environment

    Forum Feedback and Help is not for general support enquiries.

    Thread moved to General Help.
    Ubuntu 16.04 Desktop Guide - Ubuntu 18.04 Desktop Guide - Forum Guide to BBCode - Using BBCode code tags - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  4. #4
    Join Date
    Apr 2008
    Location
    Norwich CT
    Beans
    2,498
    Distro
    Ubuntu Mate

    Re: Ubuntu Mate 19.04 boots up in terminal instead of Mate desktop environment

    Uh, lightdm being absent is why you're booting to terminal. Lightdm is a display manager, which is what you log in to get the windows manager (the desktop)

    Try reinstalling lightdm, and reboot. It may well solve your problem.

    I drink my Ubuntu black, no sugar.
    Ubuntu user 28819

  5. #5
    Join Date
    Apr 2019
    Beans
    2

    Re: Ubuntu Mate 19.04 boots up in terminal instead of Mate desktop environment

    Correcting my terminology here: by lock screen, I meant greeter screen.
    What was I trying to do: change the wallpaper on the greeter screen.


    Initially I failed to find a native/pre-installed application which changes the login/greeter screen's wallpaper. I installed lightDM-gtk-greeter package and then I found a simpler/native way to change the wallpaper so instead of removing gtk-greeter I purged every package that was named lightDM*
    Which also removed slick-greeter and the settings package. (That was not the clean way of doing it, I agree)


    So from your feedback, I reinstalled lightdm slick-greeter and lightdm-settings and now I have got the desktop environment back and I see there is indeed an application called: Login Window where I can easily change the greeter screen's wallpaper and I don't need lightDM-gtk-greeter for that.


    This time I did apt-get remove lightdm-gtk-greeter lightdm-gtk-greeter-settings so that it won't conflict with slick-greeter.


    Thanks a ton, all!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •