Results 1 to 6 of 6

Thread: IPv6 issue

  1. #1
    Join Date
    Apr 2019
    Beans
    2

    Exclamation IPv6 issue

    I am using Ubuntu 16.04 LTS . After installed Radvd to get Router advertisement work, i found that the ping can only reach to ipv6 link-local address(self own or others ).
    When ping global ipv6 address or even loopback address ::1 ,it returns “ping: unkown host xxxxxx” right away.
    BTW, ping to ipv4 address are all OK.
    That is WHY? How to fix this?

    Thanks very very much.

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    26,068
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: IPv6 issue

    Thread moved to Networking & Wireless a more appropriate sub-forum.

  3. #3
    Join Date
    Apr 2019
    Beans
    2

    Re: IPv6 issue

    I did same processes on two machines and got same reault.

  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    13,882
    Distro
    Kubuntu Development Release

    Re: IPv6 issue

    Do you need to support IPv6? I'll often disable it entirely by adding the lines

    Code:
    net.ipv6.conf.all.disable_ipv6=1
    net.ipv6.conf.default.disable_ipv6=1
    to the bottom of /etc/sysctl.conf and rebooting.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,707
    Distro
    Ubuntu 18.10 Cosmic Cuttlefish

    Re: IPv6 issue

    Are you quite confident that your router supports IPv6, as well as your internet appliance (cable modem, DSL modem, etc.) and your ISP? Do other devices on the same network get a real IPv6 address like this?
    Code:
    5: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 5c:c5:d4:0e:64:a6 brd ff:ff:ff:ff:ff:ff
        inet 192.168.0.xx/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp3s0
           valid_lft 171816sec preferred_lft 171816sec
        inet6 2600:1700:xxxx839:4547:4c4b:71f4:4d6c/64 scope global temporary dynamic 
           valid_lft 603818sec preferred_lft 85364sec
        inet6 2600:1700:xxxx839:ed1a:bd8d:e5a:17ef/64 scope global dynamic mngtmpaddr noprefixroute
    Or do they get fe80xxx place-holder addresses?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  6. #6
    Join Date
    Apr 2008
    Location
    Southern California, USA
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: IPv6 issue

    Quote Originally Posted by SeijiSensei View Post
    Do you need to support IPv6? I'll often disable it entirely by adding the lines

    Code:
    net.ipv6.conf.all.disable_ipv6=1
    net.ipv6.conf.default.disable_ipv6=1
    to the bottom of /etc/sysctl.conf and rebooting.
    I use this to prefer ipv4 over ipv6:
    Code:
    sudo sed -i 's/#\(.*96  100.*\)/\1/' /etc/gai.conf

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •