Results 1 to 9 of 9

Thread: Help getting wine 1.4 on Ubuntu 18.10 64-bit

  1. #1
    Join Date
    Apr 2019
    Beans
    4

    Help getting wine 1.4 on Ubuntu 18.10 64-bit

    I want to play this (https://appdb.winehq.org/objectManag...sion&iId=21910)game, but no version of proton will run it and the best version of wine seems to be 1.4. However, I either can't get it to compile when downloaded from winehq or install the binary from launchpad. Playonlinux won't work either, the game isn't available in the list and it's on steam. Please help me install wine 1.4. Thanks.

  2. #2
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Help getting wine 1.4 on Ubuntu 18.10 64-bit

    Thread moved to Wine for a better fit

  3. #3
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Help getting wine 1.4 on Ubuntu 18.10 64-bit

    Quote Originally Posted by echaskaris View Post
    I want to play this (https://appdb.winehq.org/objectManag...sion&iId=21910)game, but no version of proton will run it and the best version of wine seems to be 1.4. However, I either can't get it to compile when downloaded from winehq or install the binary from launchpad. Playonlinux won't work either, the game isn't available in the list and it's on steam. Please help me install wine 1.4. Thanks.

    Don't believe the ratings. and despite the silver rating it looks like some of recent wine versions might work better.
    for 1.4 it says: Run in 1024x768
    for new test it says it all works but there is stuttering. so maybe reducing resolution the result would be the same as in old version?!

    are you saying you can't install old wine version using Play on linux & manual install option?
    Easy to understand Ubuntu manual with lots of pics: http://ubuntu-manual.org/
    Do i need antivirus/firewall in linux?
    Disk backup (works on newer PC): Clonezilla

  4. #4
    Join Date
    Nov 2007
    Beans
    Hidden!

    Re: Help getting wine 1.4 on Ubuntu 18.10 64-bit

    Just a few hours ago I made a similar post... see if https://lutris.net/games/call-of-duty-black-ops/ has a working script (behind a firewall and can't access gaming sites). Even if not it has similar methods of being able to use different versions of Wine to try and run applications (I am not 100% up to speed how to install specific versions but once already on the system can be choses).

    I am fairly doubtful you will be able to get 1.4 installed and working properly to be honest..
    Gaming on Linux has never been better - Check out Proton on Steam (great user made Proton Database) and Lutris
    How to ask questions the smart way

  5. #5
    Join Date
    Aug 2013
    Beans
    4,126

    Re: Help getting wine 1.4 on Ubuntu 18.10 64-bit

    Quote Originally Posted by mastablasta View Post
    are you saying you can't install old wine version using Play on linux & manual install option?
    POL is broken in 18.04, does it work in 18.10?

  6. #6
    Join Date
    Apr 2019
    Beans
    4

    Re: Help getting wine 1.4 on Ubuntu 18.10 64-bit

    Tried with lutris and the script you showed thenailedone, the game is not starting.

  7. #7
    Join Date
    Nov 2007
    Beans
    Hidden!

    Unhappy Re: Help getting wine 1.4 on Ubuntu 18.10 64-bit

    Quote Originally Posted by echaskaris View Post
    Tried with lutris and the script you showed thenailedone, the game is not starting.
    Yeah I see even https://www.protondb.com/app/42700 reporting it as borked :/

    WineHQ only has official debs going back to 2.4 (and even then there will be doubt in the required dependencies.
    Gaming on Linux has never been better - Check out Proton on Steam (great user made Proton Database) and Lutris
    How to ask questions the smart way

  8. #8
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Help getting wine 1.4 on Ubuntu 18.10 64-bit

    Quote Originally Posted by monkeybrain20122 View Post
    POL is broken in 18.04, does it work in 18.10?
    i'm on 18.04 - yes it is broken. though i think it should be possible to do it on manual install (via their install wizzard). i could be wrong. many things in POL do not work (particularly scripts), but some things still do.

    Quote Originally Posted by thenailedone View Post
    Yeah I see even https://www.protondb.com/app/42700 reporting it as borked :/

    WineHQ only has official debs going back to 2.4 (and even then there will be doubt in the required dependencies.
    based on this the only options seem to be to wait or get windows running.
    Easy to understand Ubuntu manual with lots of pics: http://ubuntu-manual.org/
    Do i need antivirus/firewall in linux?
    Disk backup (works on newer PC): Clonezilla

  9. #9
    Join Date
    Nov 2007
    Beans
    Hidden!

    Re: Help getting wine 1.4 on Ubuntu 18.10 64-bit

    Quote Originally Posted by mastablasta View Post
    based on this the only options seem to be to wait or get windows running.
    I fear that is the price we pay in having the ability to play the latest and greatest, we lose the ability to play the oldies but goodies :/
    Gaming on Linux has never been better - Check out Proton on Steam (great user made Proton Database) and Lutris
    How to ask questions the smart way

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •