Results 1 to 2 of 2

Thread: Issue with PHP mysql driver

  1. #1
    Join Date
    Feb 2011
    Beans
    13

    Question Issue with PHP mysql driver

    Hello All,

    I have Ubuntu 18.04 server running with apache2 and application Mysql based probably since update i have issue with php Msql driver , and i cant find a way to resolve it uninstall reinstall the driver still having same issue .
    When i run command shown below i get following output any idea how to fix it ?
    Please advice
    Thanks

    Code:
    php --ini | grep "Loaded"
    PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_mysql' (tried: /usr/lib/php/20180731/pdo_mysql (/usr/lib/php/20180731/pdo_mysql: cannot open shared object file: No such file or directory), /usr/lib/php/20180731/pdo_mysql.so (/usr/lib/php/20180731/pdo_mysql.so: undefined symbol: mysqlnd_allocator)) in Unknown on line 0
    Loaded Configuration File:         /etc/php/7.3/cli/php.ini

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,615
    Distro
    Kubuntu Development Release

    Re: Issue with PHP mysql driver

    Did you install the php7.3-mysql module?

    Try creating a file in the root of the website with just the single line "<?php phpinfo() ?>". Now access that file from a browser, and you will see a complete list of all the various PHP modules in use. What do you see for MySQL?
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •