Results 1 to 10 of 10

Thread: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

  1. #1
    Join Date
    Jul 2018
    Beans
    21

    Question Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    I've installed Ubuntu 19.04 Disco Dingo, and Grub2 is blacked out due to enabled Fast boot.
    However, it boots perfectly, I just can't see Grub2 menu - I see instead - completely black-blank screen, and few seconds later - Ubuntu starts booting.

    Ubuntu 18.10, Ubuntu 18.04 had no such problem.

    I would like to know where I should report this, and what could be responsible as I have a fear that this bug might be unnoticed even after final release of Ubuntu 19.04 Disco Dingo.

    Any help to trace the responsible project/package is appreciated.
    Last edited by boqsc; April 3rd, 2019 at 10:07 AM.

  2. #2
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 18.10 Cosmic Cuttlefish

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    19.04 is not released yet; thread moved.

  3. #3
    Join Date
    Aug 2008
    Beans
    50

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    This might solve your issue if you use Intel hardware, it will probably not increase boot time.

    Try the following:

    edit /etc/default grub:

    Code:
    sudo nano /etc/default/grub
    Add the boot parameter

    Code:
    i915.fastboot=0
    Update grub

    Code:
    sudo update-grub
    Reboot.
    Kind regards,

    Otto

  4. #4
    Join Date
    Jul 2018
    Beans
    21

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    Well, I have:

    CPU: Intel® Core™ i7-3630QM
    GPU: AMD Radeon™ HD 7670M Graphics (2GB dedicated memory)
    More general information available about the Laptop: http://www.toshiba.co.uk/discontinued-products/satellite-l855-149/


    I did exactly as you wrote:
    vaidas@vaidas-SATELLITE-L855:~$ sudo update-grub
    Sourcing file `/etc/default/grub'
    /usr/sbin/grub-mkconfig: 11: /etc/default/grub: i915.fastboot=0: not found
    vaidas@vaidas-SATELLITE-L855:~$
    Nothing changed, I even rebooted to check if anything got affected.

    it will probably not increase boot time.
    I was expecting exactly this. That's bad news for me, even if what you suggested would have worked.
    And kind of annoying, as Windows 10 is booting way faster than Ubuntu. (By around 6-8 seconds faster)
    I hope that will get fixed and it's just temporal.
    Last edited by boqsc; April 7th, 2019 at 10:45 AM.

  5. #5
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    This is only for Skylake an newer Intel chips.
    i915.fastboot=1 kernel parameter. Fastboot helps provide a clean, flicker-free Linux boot experience.
    New 5.1 kernel will include it by default on Skylake and newer

    Some find removing snaps improves boot time. And they are working on making them faster.
    boot time cut in half by removing snap
    https://ubuntuforums.org/showthread.php?t=2391341
    https://ubuntuforums.org/showthread.php?t=2409173
    https://blog.ubuntu.com/2019/03/28/s...e-improvements

    For your system you can see what takes the time to boot.
    systemd-analyze
    systemd-analyze critical-chain
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #6
    Join Date
    Aug 2008
    Beans
    50

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    I have tested your issue on my laptop

    If /etc/default/grub looks like this, the grub menu will not appear:
    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=4

    If /etc/default/grub looks like this, the grub menu will appear:

    Code:
    GRUB_DEFAULT=0
    # GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=4
    I do not have an entry for Windows

    Best regard, Otto

  7. #7
    Join Date
    Jul 2018
    Beans
    21

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    The file /etc/default/grub that I have, does not contain GRUB_TIMEOUT_STYLE option.
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n 'Simple configuration'

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=2
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

  8. #8
    Join Date
    Jul 2018
    Beans
    21

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    Some insights that systemd gave:

    The critical-chain output as Image:



    The critical-chain output as text:
    Code:
    vaidas@vaidas-SATELLITE-L855:~$ systemd-analyze critical-chain 
    The time after the unit is active or started is printed after the "@" character.
    The time the unit takes to start is printed after the "+" character.
    
    graphical.target @22.790s
    └─multi-user.target @22.790s
      └─kerneloops.service @7.426s +13ms
        └─network-online.target @7.420s
          └─NetworkManager-wait-online.service @1.303s +6.115s
            └─NetworkManager.service @1.167s +135ms
              └─dbus.service @1.164s
                └─basic.target @1.148s
                  └─sockets.target @1.147s
                    └─snapd.socket @1.146s +1ms
                      └─sysinit.target @1.141s
                        └─systemd-backlight@backlight:radeon_bl0.service @1.980s +65
                          └─system-systemd\x2dbacklight.slice @1.967s
                            └─system.slice @155ms
                              └─-.slice @155ms

    Simply launching systemd-analyze, the output:
    Code:
    vaidas@vaidas-SATELLITE-L855:~$ systemd-analyze 
    Startup finished in 6.144s (firmware) + 10.259s (loader) + 2.258s (kernel) + 22.802s (userspace) = 41.464s 
    graphical.target reached after 22.790s in userspace
    Last edited by boqsc; April 7th, 2019 at 08:59 PM.

  9. #9
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    Network manager seems to be an issue.

    Not sure if this helps or not.
    Slow boot issue
    https://bugs.launchpad.net/ubuntu/+s...r/+bug/1723809
    https://forums.linuxmint.com/viewtopic.php?t=282437
    $ systemctl unmask NetworkManager-wait-online.service
    $ systemctl enable NetworkManager-wait-online.service
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  10. #10
    Join Date
    Jul 2018
    Beans
    21

    Re: Grub2 is blacked out, when Fast boot is enabled in Laptop's UEFI

    Before disabling: (Took a picture for fun historical records)


    I Disabled NetworkManager-wait-online.service, haven't felt any huge improvements (actually any)
    Code:
    vaidas@vaidas-SATELLITE-L855:~$  systemctl disable NetworkManager-wait-online.service
    Removed /etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service.
    After Disabling NetworkManager-wait-online.service
    Code:
    vaidas@vaidas-SATELLITE-L855:~$ systemctl status NetworkManager-wait-online.service
    ● NetworkManager-wait-online.service - Network Manager Wait Online
       Loaded: loaded (/lib/systemd/system/NetworkManager-wait-online.service; disab
       Active: inactive (dead)
         Docs: man:nm-online(1)
    lines 1-4/4 (END)

    NetworkManager-wait-online.service seems to be gone from critical-chain of systemd-analyze

    As mentioned - haven't felt any actual improvements, the black screen before loading ubuntu keeps taking a long time.


    Last edited by boqsc; April 7th, 2019 at 09:40 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •