Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: 'Error: BrokenCount>0'

  1. #1
    Join Date
    Apr 2019
    Beans
    11

    'Error: BrokenCount>0'

    The following message appeared on my Ubuntu 16.04 LTS:
    An error ocurred, please run Package Manager from the right-click menu or apt-get in a terminal to see what's wrong. The error message was: 'Error: BrokenCount>0'

    I ran
    Code:
    sudo apt-get install -f[/B] and the output was the following:[INDENT][B]Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following additional packages will be installed:
      python3-qgis-common
    The following NEW packages will be installed:
      python3-qgis-common
    0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
    1 not fully installed or removed.
    Need to get 0 B/4296 kB of archives.
    After this operation, 14,6 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    (Reading database ... 261736 files and directories currently installed.)
    Preparing to unpack .../python3-qgis-common_3.4.6+dfsg-1~xenial1_all.deb ...
    Unpacking python3-qgis-common (3.4.6+dfsg-1~xenial1) ...
    dpkg: error processing archive /var/cache/apt/archives/python3-qgis-common_3.4.6+dfsg-1~xenial1_all.deb (--unpack):
     trying to overwrite '/usr/share/qgis/python/plugins/processing/script/ScriptAlgorithmProvider.py', which is also in package python-qgis-common 1:2.18.16+24xenial
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing:
     /var/cache/apt/archives/python3-qgis-common_3.4.6+dfsg-1~xenial1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Could you guys help me fixing this issue, since I'm a beginner on Linux? Thanks!
    Attached Images Attached Images
    Last edited by deadflowr; April 2nd, 2019 at 08:06 PM. Reason: clean up; added code tags

  2. #2
    Join Date
    Mar 2010
    Beans
    8,760
    Distro
    Ubuntu Mate

    Re: 'Error: BrokenCount>0'

    Hi and welcome to the forum

    Please try this and post back if there were errors or the problem was resolved:

    Code:
    sudo dpkg --configure -a

  3. #3
    Join Date
    Apr 2019
    Beans
    11

    Re: 'Error: BrokenCount>0'

    Output:
    dpkg: dependency problems prevent configuration of python3-qgis:
    python3-qgis depends on python3-qgis-common (= 3.4.6+dfsg-1~xenial1); however:
    Package python3-qgis-common is not installed.

    dpkg: error processing package python3-qgis (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    python3-qgis

  4. #4
    Join Date
    Apr 2019
    Beans
    11

    Re: 'Error: BrokenCount>0'

    Output:
    dpkg: dependency problems prevent configuration of python3-qgis:
    python3-qgis depends on python3-qgis-common (= 3.4.6+dfsg-1~xenial1); however:
    Package python3-qgis-common is not installed.

    dpkg: error processing package python3-qgis (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    python3-qgis

  5. #5
    Join Date
    Mar 2010
    Beans
    8,760
    Distro
    Ubuntu Mate

    Re: 'Error: BrokenCount>0'

    I suggest removing the package:

    Code:
    sudo apt-get remove --purge python3-qgis
    The run this again:

    Code:
    udo dpkg --configure -a
    If there are no more errors then try installing again:

    Code:
    sudo apt-get install python3-qgis
    Obviously, if dpkg does return errors post them here before trying to reinstall so we can try and figure out what is going on.

  6. #6
    Join Date
    Apr 2019
    Beans
    11

    Re: 'Error: BrokenCount>0'

    dpkg didn't return any error, but when running sudo apt-get install python3-qgis it returned the following:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following additional packages will be installed:
    python3-qgis-common
    The following NEW packages will be installed:
    python3-qgis python3-qgis-common
    0 upgraded, 2 newly installed, 0 to remove and 12 not upgraded.
    Need to get 0 B/12,6 MB of archives.
    After this operation, 63,5 MB of additional disk space will be used.
    Do you want to continue? [Y/n]
    (Reading database ... 261678 files and directories currently installed.)
    Preparing to unpack .../python3-qgis-common_3.4.6+dfsg-1~xenial1_all.deb ...
    Unpacking python3-qgis-common (3.4.6+dfsg-1~xenial1) ...
    dpkg: error processing archive /var/cache/apt/archives/python3-qgis-common_3.4.6+dfsg-1~xenial1_all.deb (--unpack):
    trying to overwrite '/usr/share/qgis/python/plugins/processing/script/ScriptAlgorithmProvider.py', which is also in package python-qgis-common 1:2.18.16+24xenial
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Selecting previously unselected package python3-qgis.
    Preparing to unpack .../python3-qgis_3.4.6+dfsg-1~xenial1_amd64.deb ...
    Unpacking python3-qgis (3.4.6+dfsg-1~xenial1) ...
    Errors were encountered while processing:
    /var/cache/apt/archives/python3-qgis-common_3.4.6+dfsg-1~xenial1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  7. #7
    Join Date
    Mar 2010
    Beans
    8,760
    Distro
    Ubuntu Mate

    Re: 'Error: BrokenCount>0'

    Let's see if cleaning things up a bit helps:

    Code:
    sudo apt-get clean
    sudo apt-get update
    sudo dpkg --configure -a
    sudo apt-get install -f
    Post back if there are errors please.

  8. #8
    Join Date
    Apr 2019
    Beans
    11

    Re: 'Error: BrokenCount>0'

    Returned the same errors as before

  9. #9
    Join Date
    Mar 2010
    Beans
    8,760
    Distro
    Ubuntu Mate

    Re: 'Error: BrokenCount>0'

    Couple of questions:

    Did you recently upgrade, if yes from which version to which new version?

    Were you trying to compile from source or adding from the APT directory?

  10. #10
    Join Date
    Apr 2019
    Beans
    11

    Re: 'Error: BrokenCount>0'

    I did not.

    A few days ago, in order to install a program I added a few lines to sources.list

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •