Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Cannot use proprietary Nvidia drivers after update (14.04)

  1. #11
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    7,638
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Do you have anything in your grub configuration that would interfere with the loading of the nvidia kernel module? Particular suspects would be things that invoke a framebuffer.
    None but ourselves can free our minds

  2. #12
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,112
    Distro
    Xubuntu

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Is it possible that the 14.04 won't support the newer Nvidia drivers?

  3. #13
    Join Date
    Jun 2007
    Beans
    17,303

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Are you using secure boot? (if not why do you have shim-signed installed?
    Out of curiosity what version of xserver do you have, inxi -G will show.

    (- I'd suspect that if you install the lts-xenial kernel & xserver things may work (not from -proposed..

  4. #14
    Join Date
    Feb 2015
    Beans
    10

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Here's the content of /etc/default/grub:
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=-1
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    I don't see anything that would interfere with the Nvidia drivers


    Secure Boot should be off. When installing nvidia-384 from the terminal, it clearly said:
    Secure Boot not enabled on this system.
    But I think it was enabled when Ubuntu was initially installed.
    Ubuntu asked to disable it at one point. Either when installing the Nvidia drivers, or after an update (it was years ago, I don't remember fully).
    It required to set a password and to reboot.

    Here's the output of "inxi -G":
    Code:
    Graphics:  Card: NVIDIA GF108 [GeForce GT 630] 
               X.Org: 1.15.1 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz 
               GLX Renderer: Gallium 0.4 on NVC1 GLX Version: 3.0 Mesa 10.1.3

  5. #15
    Join Date
    Feb 2015
    Beans
    10

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Another user on Ask Ubuntu solved it by uninstalling shim-signed. It should be worth a try.

    Interestingly, here's the changelog for the DKMS package from trusty-updates:
    Code:
    dkms (2.2.0.3-1.1ubuntu5.14.04.10) trusty; urgency=medium
    
      * debian/patches/shim_secureboot_support.patch:
        - Move to signing just after module build to ensure it correctly applies
          at kernel update times. (LP: #1772950)
        - Generate a new MOK if there isn't one yet, and use that so sign
          newly-built kernel modules. (LP: #1748983)
      * debian/control: Breaks: shim-signed (<< 1.33.1~14.04.4) to ensure both
        are updated in lock-step since the changes above require a new version of
        update-secureboot-policy to correctly generate the new MOK and enroll it
        in firmware.
    
     -- Mathieu Trudel-Lapierre <cyphermox@ubuntu.com>  Mon, 28 Jan 2019 11:05:49 -0500

  6. #16
    Join Date
    Feb 2019
    Beans
    1

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Hello, I just solved a similar issue on Ubuntu 18.04. It's an issue that I had in the past with Ubuntu 16.04 too and Arch Linux. I was blacklisting the modules that are suggested at several forums but Nouveau would still load on startup, and when I got the Nvidia driver to load the screen was black or with a low resolution.

    First of all I removed and purged the nvidia drivers and reinstalled them (nvidia-driver-415).

    Let's check which modules are related to Nouveau in the system:

    Code:
    $ lsmod | grep nouveau
    
    nouveau              1716224  0
    mxm_wmi                16384  1 nouveau
    wmi                    24576  2 mxm_wmi,nouveau
    video                  45056  2 i915,nouveau
    i2c_algo_bit           16384  2 i915,nouveau
    ttm                   106496  1 nouveau
    drm_kms_helper        172032  3 nvidia_drm,i915,nouveau
    drm                   401408  12 drm_kms_helper,nvidia_drm,i915,ttm,nouveau
    As I said, at /etc/modprobe.d/blacklist.conf I was blacklisting several modules:

    Code:
    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv
    blacklist lbm-nouveau
    options nouveau modeset=0
    alias nouveau off
    alias lbm-nouveau off
    It turns out that this blacklist is incomplete for my system. As you can see in the output of lsmod above, the modules mxm_wmi and ttm are related and exclusive to Nouveau in my system. So I blacklisted those two at blacklist.conf too:

    Code:
    blacklist ttm
    blacklist mxm_wmi
    Remember to run update-initramfs -u after you make these changes so the kernel blacklists these modules.

    I also edited /etc/default/grub and made this change:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
    Code:
    sudo update-grub
    sudo reboot
    To make sure that my nvidia-415 driver is properly loaded, I run a tiny OpenGL program that outputs the current version (the Nouveau driver will restrict you to an ancient 3.x version):

    Code:
    Renderer: GeForce GTX 1050 Ti/PCIe/SSE2
    OpenGL version supported 4.6.0 NVIDIA 415.27
    As you can see it's now loading successfully. My low resolution and black screen issues are gone too.
    Last edited by mikel-losada; February 27th, 2019 at 11:26 AM.

  7. #17
    Join Date
    Feb 2015
    Beans
    10

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    OK, that worked:
    Code:
    sudo apt-get remove shim-signed
    sudo apt-get install nvidia-384
    And then reboot.

    Reminder (to anyone who reads this in the future):
    Make sure Secure Boot is disabled before uninstalling shim-signed.

  8. #18
    Join Date
    Jun 2007
    Beans
    17,303

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Quote Originally Posted by user9992 View Post
    OK, that worked:
    Code:
    sudo apt-get remove shim-signed
    sudo apt-get install nvidia-384
    And then reboot.

    Reminder (to anyone who reads this in the future):
    Make sure Secure Boot is disabled before uninstalling shim-signed.
    You should be good now..
    Users of nvidia with 14.04 on the xenial-lts and 16.04 release kernel itself should be wary of kernel updates from proposed as same issue will occur
    https://bugs.launchpad.net/ubuntu/+s...1/+bug/1573508

  9. #19
    Join Date
    May 2011
    Beans
    1

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Dear mc4man,

    I have exactly the same case as yours. I have installed Nvidia driver 410.48, and stop working when kernel was updated to .143 .
    I do not see a secure boot option in the BIOS menu, but if I do

    >> ls -l /sys/firmware/efi/efivars/Secure*
    -rw-r--r-- 1 root root 5 Mar 21 18:03 /sys/firmware/efi/efivars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c

    so, I am not sure if secure boot is enabled or not... Should still do
    sudo apt-get remove shim-signed

    ?



    I still can pick the previous kernel from GRUB,and works perfectly..... so I do not want to mess with the NVIDIA drivers..., It does not seem wise to do

    sudo apt-get install nvidia-384if the drivers works with all the other kernels from GRUB..
    Please give me some advice.


    Thank you


    Quote Originally Posted by mc4man View Post
    You should be good now..
    Users of nvidia with 14.04 on the xenial-lts and 16.04 release kernel itself should be wary of kernel updates from proposed as same issue will occur
    https://bugs.launchpad.net/ubuntu/+s...1/+bug/1573508

  10. #20
    Join Date
    Jun 2007
    Beans
    17,303

    Re: Cannot use proprietary Nvidia drivers after update (14.04)

    Quote Originally Posted by gonzo66 View Post
    Dear mc4man,

    I have exactly the same case as yours. I have installed Nvidia driver 410.48, and stop working when kernel was updated to .143 .
    I do not see a secure boot option in the BIOS menu, but if I do

    >> ls -l /sys/firmware/efi/efivars/Secure*
    -rw-r--r-- 1 root root 5 Mar 21 18:03 /sys/firmware/efi/efivars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c

    so, I am not sure if secure boot is enabled or not... Should still do
    sudo apt-get remove shim-signed

    ?



    I still can pick the previous kernel from GRUB,and works perfectly..... so I do not want to mess with the NVIDIA drivers..., It does not seem wise to do

    sudo apt-get install nvidia-384if the drivers works with all the other kernels from GRUB..
    Please give me some advice.


    Thank you
    Ubuntu fixed nvidia driver packages for this but only the ones they support. The graphics driver ppa apparently hasn't yet. Whether they ever do so for 14.04 I've no clue

    I'd go with newer drivers & use the 142 kernel (unless ppa takes care of this..
    Last edited by mc4man; March 22nd, 2019 at 01:28 AM.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •