Results 1 to 7 of 7

Thread: My GPU fans spin too fast when booting

  1. #1
    Join Date
    Feb 2016
    Beans
    11

    My GPU fans spin too fast when booting

    When my computer boots up it freezes for a moment and shows a glitch screen and then the fans speed up on maximum speed. It used to be fine before but has just started doing it out ov nowhere. It doesn't happen when I boot into Windows, only Ubuntu Mate even when it's a live CD. My GPU is the AMD Radeon R9 300 series. I would upload a video but I don't know where to post it to.
    Last edited by ash22; 5 Days Ago at 09:36 PM.

  2. #2
    Join Date
    Feb 2019
    Location
    Virginia
    Beans
    16
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: My GPU fans spin too fast when booting

    You'll likely need to use an AMD Open Source driver for Ubuntu to get that card working properly. There is AMDGPU & RadeonDriver projects depending on the card you have.

  3. #3
    Join Date
    Feb 2016
    Beans
    11

    Re: My GPU fans spin too fast when booting

    Quote Originally Posted by aljames2 View Post
    You'll likely need to use an AMD Open Source driver for Ubuntu to get that card working properly. There is AMDGPU & RadeonDriver projects depending on the card you have.
    I alreddy have amdgpu and I've even reinstalled it but when I serch amdgpu on Synaptic, it has two results for the drivers. One is Xserver-xorg-video-amdgpu which I have installed and the other one Xserver-xorg-video-amdgpu-hwe-18.04. Which one am I supposed to use? They both say they work with the card I've got (Tonga). When I try to install the other one I just get a message that says "could not apply changes! Fix broken packages first".
    Last edited by ash22; 4 Days Ago at 12:58 PM.

  4. #4
    Join Date
    Mar 2007
    Location
    Promised Land
    Beans
    641
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: My GPU fans spin too fast when booting

    Should fix broken packages...
    Code:
    sudo apt-get update
    sudo apt-get install -f
    sudo apt-get purge
    After fix, consider installing AMD GFX drivers using Settings>Additional Drivers
    Cheers,
    I am not an expert on anything, but I pretend to be one at times.
    Software expands to consume available system resources.

  5. #5
    Join Date
    Feb 2016
    Beans
    11

    Re: My GPU fans spin too fast when booting

    I still got the error and there weren't any additional drivers to install in the settings
    Last edited by ash22; 4 Days Ago at 08:15 PM.

  6. #6
    Join Date
    Mar 2007
    Location
    Promised Land
    Beans
    641
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: My GPU fans spin too fast when booting

    Please post results of inxi -G between code tags
    Cheers,
    I am not an expert on anything, but I pretend to be one at times.
    Software expands to consume available system resources.

  7. #7
    Join Date
    Feb 2016
    Beans
    11

    Re: My GPU fans spin too fast when booting

    This is the output
    Code:
    Graphics:  Card: Advanced Micro Devices [AMD/ATI] Tonga PRO [Radeon R9 285/380]
               Display Server: x11 (X.Org 1.19.6 )
               drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
               Resolution: 1920x1080@60.00hz
               OpenGL: renderer: AMD Radeon R9 380 Series (TONGA, DRM 3.23.0, 4.15.0-45-generic, LLVM 7.0.0)
               version: 4.5 Mesa 18.2.2
    Last edited by ash22; 3 Days Ago at 09:14 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •