Results 1 to 3 of 3

Thread: QtGui Error When Trying to Install an Old Version of MAME

  1. #1
    Join Date
    Apr 2018
    Beans
    4

    QtGui Error When Trying to Install an Old Version of MAME

    Hello. I've been trying to install a modded version of MAME from 2015. The version can be found at https://github.com/osresearch/mame. Unfortunately, when I try to install it, I run into this problem. I installed this program last year on an older machine, and I had the same error. I fixed the problem by manually finding QtGui and moving it to where it was looking. This doesn't seem to work now. What should I do? Here is the error:
    https://i.imgur.com/AFCCnLf.jpg

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,340
    Distro
    Ubuntu

    Re: QtGui Error When Trying to Install an Old Version of MAME

    Thread moved to Emulators

    Could it be an issue of Ubuntu using qt5 instead of qt4?
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Apr 2018
    Beans
    4

    Re: QtGui Error When Trying to Install an Old Version of MAME

    It most likely is. I installed qt4-default and libqt4-dev and it still didn't work. I then copied all the contents of /usr/include/qt4 to /usr/include
    It got much further but then ran into a BUNCH of undefined reference messages that look like this:
    https://i.imgur.com/gb8lZj2.jpg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •