Results 1 to 1 of 1

Thread: apt-get update got error with sudo apt-get update

  1. #1
    Join Date
    Jan 2019
    Beans
    2

    apt-get update got error with sudo apt-get update

    I'm using Ubuntu

    Code:
    
    
    Code:
    lsb_release -a
    
    No LSB modules are available.
    
    Distributor ID:    Ubuntu
    
    Description:    Ubuntu 18.04.1 LTS
    
    Release:    18.04
    
    Codename:    bionic
    





    The problem i got is when trying to `sudo apt-get update`

    Code:
    Hit:1 https://deb.nodesource.com/node_10.x bionic InReleaseHit:2 https://download.docker.com/linux/ubuntu bionic InRelease                                                                                                                                                   
    
    Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                                      
    
    Hit:4 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                                                        
    
    Get:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]                                                                                                                                     
    
    Hit:8 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease                                                                                                                                           
    
    Hit:5 https://packages.cloud.google.com/apt kubernetes-xenial InRelease                                                                                                                                           
    
    Hit:9 http://vn.archive.ubuntu.com/ubuntu bionic InRelease                                                                                
    
    Hit:10 https://dl.yarnpkg.com/debian stable InRelease                                                                                     
    
    Hit:11 http://vn.archive.ubuntu.com/ubuntu bionic-updates InRelease     
    
    Get:12 http://vn.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
    
    Fetched 158 kB in 4s (43.2 kB/s)     
    
    Error: Timeout was reached
    
    Traceback (most recent call last):
    
      File "/usr/lib/cnf-update-db", line 8, in <module>
    
        from CommandNotFound.db.creator import DbCreator
    
      File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 11, in <module>
    
        import apt_pkg
    
    ImportError: /usr/lib/python3/dist-packages/apt_pkg.cpython-36m-x86_64-linux-gnu.so: symbol _ZN9pkgSystem9LockInnerEv version APTPKG_5.0 not defined in file libapt-pkg.so.5.0 with link time reference
    
    Error in sys.excepthook:
    
    Traceback (most recent call last):
    
      File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 63, in apport_excepthook
    
        from apport.fileutils import likely_packaged, get_recent_crashes
    
      File "/usr/lib/python3/dist-packages/apport/__init__.py", line 5, in <module>
    
        from apport.report import Report
    
      File "/usr/lib/python3/dist-packages/apport/report.py", line 30, in <module>
    
        import apport.fileutils
    
      File "/usr/lib/python3/dist-packages/apport/fileutils.py", line 23, in <module>
    
        from apport.packaging_impl import impl as packaging
    
      File "/usr/lib/python3/dist-packages/apport/packaging_impl.py", line 24, in <module>
    
        import apt
    
      File "/usr/lib/python3/dist-packages/apt/__init__.py", line 23, in <module>
    
        import apt_pkg
    
    ImportError: /usr/lib/python3/dist-packages/apt_pkg.cpython-36m-x86_64-linux-gnu.so: symbol _ZN9pkgSystem9LockInnerEv version APTPKG_5.0 not defined in file libapt-pkg.so.5.0 with link time reference
    
    
    
    
    Original exception was:
    
    Traceback (most recent call last):
    
      File "/usr/lib/cnf-update-db", line 8, in <module>
    
        from CommandNotFound.db.creator import DbCreator
    
      File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 11, in <module>
    
        import apt_pkg
    
    ImportError: /usr/lib/python3/dist-packages/apt_pkg.cpython-36m-x86_64-linux-gnu.so: symbol _ZN9pkgSystem9LockInnerEv version APTPKG_5.0 not defined in file libapt-pkg.so.5.0 with link time reference
    
    Reading package lists... Done
    
    E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
    
    E: Sub-process returned an error code
    
    
    


    The reason i had this error is that i tried to run `sudo apt-get upgrade`.

    It's seem related to <a href="https://ubuntuforums.org/showthread.php?t=2398895" target="_blank">https://ubuntuforums.org/showthread.php?t=2398895</a> . But i tried all solution that mentioned in this thread but i still have this error.

    Moreover, i tried to

    Code:
    
    
    Code:
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libapt-pkg5.0_1.2.29_amd64.deb
    
    sudo dpkg --install --force-downgrade libapt-pkg5.0.1.2.29
    


    As mentioned in <a href="https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1644643" target="_blank">https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1644643</a>.


    Can anyone help me with this error <img src="images/smilies/icon_sad.gif" border="0" alt="" title="Sad" smilieid="11" class="inlineimg">

    Thanks.


    Last edited by iamquang95; January 21st, 2019 at 03:52 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •