Results 1 to 1 of 1

Thread: Wacom Intuos S / Inkscape 0.92 / Gnome Control Center Issue / 18.04

  1. #1
    Join Date
    Jan 2019
    Beans
    1

    Wacom Intuos S / Inkscape 0.92 / Gnome Control Center Issue / 18.04

    Had problems installing "Wacom Intuos S" under Ubuntu 18.04 (Gnome and XWindow System) using Inkscape (0.92). The device has been recognized in "Gnome Control Center" by default. The testarea for handwriting worked well (including pressure sensitivity feature), but no other settings were possible. Inkscape does not offer pressure sensitivity feature of the Intuos. Additionally the center point of the pen and choosen Inkscape tools (e.g. calligraphy) had an offset miles away from each other. This is as an indication of a wrong considered window input area.

    Command "libwacom-list-local-devices" suggest that only a generic Wacom device has been detected:

    [Device]
    Name=Wacom Serial Tablet WACf004
    DeviceMatch=serial:0000:0000;
    Class=ISDV4
    Width=0
    Height=0
    IntegratedIn=Display;System;
    Styli=0xfffff;0xffffe;...


    I tried to update the "libwacom" but there aren't newer files for ubuntu 18.04.

    Finally solved the problems by:

    1. Install latest "tablet-data" and "svg" files attached below in this thread (or "libwacom" project site). If using my files here you have to copy/rename them as follows:


    • "intuos-s-p3.tablet.txt" to directory: "~/share/libwacom" and then rename this file as "intuos-s-p3.tablet"
    • "intuos-s-p3.svg.txt" to directory: "~/share/libwacom/layouts" and then rename this file as "intuos-s-p3.svg"


    2. After rebooting PC the "Gnome Control Center" should show functions for programming buttons and all the other settings being missed before. In my case Inkscape on the other hand listed the "Intuos" as an input device but unfortunately could not save nor change the "window input type" so that the above mentioned tooling offset still was present. As this is obviously an Inkscape bug, all needed settings must be made manually like following:

    3. Close Inkscape and open file "preferences.xml" located in "~/.config/inkscape" with a text-editor

    4. Search for the responsible "Wacom Intuos S" "mode" parameters in the xml element "<group id= "devices">" and change them from "window" to "screen" (see example below). Next save the file and open Inkscape.

    Example:

    Code:
    
    <group
         id="devices">
        <group
           id="P:Wacom Intuos S Pad pad"
           mode="screen"
           axes="x;y;pressure;xtilt;ytilt;wheel"...
    
    And maybe also:

    Code:
    <group
           id="P:Wacom Intuos S Pen stylus"
           mode="screen"
           axes="x;y;pressure;xtilt;ytilt;wheel...."
    Hope this will help other users!



    intuos-s-p3.svg.txtintuos-s-p3.tablet.txt
    Last edited by rb100; January 20th, 2019 at 07:19 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •