Results 1 to 8 of 8

Thread: my boot times are taking a long time, like around 2 to 3 minuts

  1. #1
    Join Date
    Jan 2019
    Beans
    4

    my boot times are taking a long time, like around 2 to 3 minuts

    here what i get when i do dmesg
    https://paste.ubuntu.com/p/mDgSBKp95h/

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    15,437
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: my boot times are taking a long time, like around 2 to 3 minuts

    systemd-analyze blame?

    https://www.tecmint.com/systemd-anal...p-performance/ has a guide with more details.
    Last edited by TheFu; 2 Days Ago at 12:23 AM.

  3. #3
    Join Date
    Jan 2019
    Beans
    4

    Post Re: my boot times are taking a long time, like around 2 to 3 minuts

    i did that and the longest time was 6 seconds

  4. #4
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    15,437
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: my boot times are taking a long time, like around 2 to 3 minuts

    If you have 500 things, each taking 5.5sec, that isn't good.

    I recently built a new system and startup is/was very slow.
    Code:
    graphical.target @1min 8.020s
    └─multi-user.target @1min 8.020s
      └─smbd.service @1min 7.748s +271ms
        └─nmbd.service @49.653s +18.093s
          └─network-online.target @49.652s
            └─network.target @47.711s
              └─networking.service @40.214s +7.496s
                └─apparmor.service @39.118s +1.087s
                  └─local-fs.target @39.076s
                    └─run-cgmanager-fs.mount @43.430s
                      └─local-fs-pre.target @35.377s
                        └─lvm2-monitor.service @2.082s +33.294s
                          └─lvm2-lvmetad.service @2.418s
                            └─lvm2-lvmetad.socket @2.081s
                              └─-.mount @2.077s
                                └─system.slice @2.079s
                                  └─-.slice @2.077s
    I removed network-manager and lxd. I don't use NM and lxd was left over from the system I pulled the install out of. I haven't rebooted yet. One of my SATA devices is complaining a bunch. I already swapped the device out (dvd --> bluray), but it is still complaining. Hope the issue is a bad SATA cable. That's the next thing I try when the system isn't busy.

    I use LVM, so disabling the LVM2 stuff isn't an option for me. LVM is too important to give up for a 2 min startup to me, especially since the machine basically runs 24/7/365 and only gets rebooted when a new libc or kernel requires it.

  5. #5
    Join Date
    Nov 2008
    Location
    Toronto Canada
    Beans
    933
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: my boot times are taking a long time, like around 2 to 3 minuts

    Have you moved around or altered disks or partitions lately?

  6. #6
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    6,008
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: my boot times are taking a long time, like around 2 to 3 minuts

    Do you use Bluetooth? Your dmesg shows it waiting for some 90 seconds between doing the sound and the Bluetooth being initialised. If you don't use it, you might simply disable it.

  7. #7
    Join Date
    Jan 2019
    Beans
    4

    Re: my boot times are taking a long time, like around 2 to 3 minuts

    no there is only one thing that took 6 seconds

  8. #8
    Join Date
    Jan 2019
    Beans
    4

    Re: my boot times are taking a long time, like around 2 to 3 minuts

    when i do systemd-analyze blame his is what i get 6.104s NetworkManager-wait-online.service
    6.104s NetworkManager-wait-online.service
    1.406s plymouth-start.service
    922ms motd-news.service
    886ms fwupd.service
    853ms dev-nvme0n1p2.device
    598ms snapd.service
    343ms vboxdrv.service
    264ms systemd-logind.service
    250ms NetworkManager.service
    211ms systemd-fsck@dev-disk-by\x2duuid-7619\x2d8E97.service
    182ms snap-vlc-768.mount
    179ms snap-gnome\x2dsystem\x2dmonitor-51.mount
    171ms dev-loop0.device
    168ms systemd-resolved.service
    167ms systemd-timesyncd.service
    158ms snap-gtk\x2dcommon\x2dthemes-818.mount
    153ms dev-loop1.device
    150ms snap-gnome\x2dlogs-37.mount
    149ms snap-gnome\x2dcharacters-139.mount
    142ms dev-loop2.device
    139ms dev-loop5.device
    129ms phpsessionclean.service
    127ms dev-loop10.device

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •