Results 1 to 2 of 2

Thread: Grub fails to load kernel after boot-repair

  1. #1
    Join Date
    Jan 2019
    Beans
    1

    Exclamation Grub fails to load kernel after boot-repair

    I have an Ubuntu 14.04 running in a VirtualBox VM with Windows 10 Host. My problem started while installing the requirements for a package HIDAPI which required other packages such as Hidraw. I noticed the installation process was messing with GRUB and some point went to a black screen. After powering on the VM again, the boot menu was just memtest.

    I tried to recover the Grub in several ways:
    Manually (https://www.vijaytechnology.com/2011...ive-ubuntu-cd/)
    Boot-repair (https://ubuntuforums.org/showthread....7#post10871917)

    I run Boot-repair 3 times because the first one failed at purge of grub-install.
    The second one, resulted into no boot menu and booting directly into grub console. Within Grub console I couldn't load the file initrd.img although it was there.
    The third time, I got boot menu with the following options.
    br_boot_menu.jpg

    However, by either choosing Ubuntu or Advance->recovery mode, the booting process gets stuck as follows:

    br_ubuntu_option.jpg

    This is the report of Boot-Repair
    http://paste.ubuntu.com/p/t2YxW5ySPD/

    I would appreciate any help to recover my VM.

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    25,603
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Grub fails to load kernel after boot-repair

    Thread moved to Virtualisation for a more appropriate fit.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •