Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Ubuntu installer does not recognize SSD

  1. #11
    Join Date
    Dec 2018
    Beans
    9

    Re: Ubuntu installer does not recognize SSD

    Following the post https://askubuntu.com/questions/1099...pst-feature-19, I have added the modification
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvme_core.default_ps_max_latency_us=200"
    to the /etc/default/grub file in the SSHD, and updated grub with sudo update-grub.

    Now, the Ubuntu OS installed in the SSHD detects the SSD since I boot the computer.

    I have tried the following. I have booted from the USB and selected "Try Ubuntu". The live Ubuntu didn't recognize the SSD. Therefore, I slept the computer and awaked it. Then, the live Ubuntu was able to see the SSD, and I installed Ubuntu in the SSD. However, I am unable to modify the grub file of the SSD's installation and, then, I am unable to succesfully boot the SSD partition.

    Do you know how can I fix this problem?

  2. #12
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Ubuntu installer does not recognize SSD

    You can edit grub2's boot parameters the same way you edit for the nomodeset boot parameter which is one of the most common required parameters.

    At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.
    How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
    How to add boot parameters, grub menu after install (also grub when UEFI)
    https://wiki.ubuntu.com/Kernel/KernelBootParameters &
    https://help.ubuntu.com/community/Grub2
    http://ubuntuforums.org/showthread.php?t=1613132

    Instructions above should be changed to use sudo -H with any graphical app like gedit.
    sudo -H gedit /etc/default/grub
    or
    sudo nano /etc/default/grub
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #13
    Join Date
    Dec 2018
    Beans
    9

    Re: Ubuntu installer does not recognize SSD

    Thank you very much, Oldfred, it worked by changing grub booting options.

    I am going to mark the post as [Solved] but, before, I am going to summarize all the process so that the post can be helpful to other people in the future.

  4. #14
    Join Date
    Dec 2018
    Beans
    9

    Re: Ubuntu installer does not recognize SSD

    Steps to make Ubuntu see the SSD and to install Ubuntu there:

    1) Boot from the USB with Ubuntu's live installation.

    2) When the grub's menu appears with the options, "Try Ubuntu", "Install Ubuntu", press "e" and you will be able to edit grub's booting options. You will see something similar to this: https://wiki.ubuntu.com/Kernel/KernelBootParameters.

    3) Go to the "linux" line and, after
    Code:
    quiet splash
    , add the words
    Code:
    nvme_core.default_ps_max_latency_us=200
    (see also https://askubuntu.com/questions/1099...pst-feature-19). Then press Ctrl+X to boot with these new option included.

    4) The Ubuntu installer should now be able to see the SSD. Proceed to install.

    5) Steps 1 to 4 only manage to make the Ubuntu installer to see SSD. The new Ubuntu SSD installation will present the same problem: it will not be able to see the SSD at all and will not be able to boot properly. Thus, when booting the new Ubuntu SSD installation for the first time, press "e" at the grub menu ("Ubuntu", "Advanced options for Ubuntu", etc) and repeat steps 1 to 3.

    6) Now the Ubuntu SSD installation should be able to boot properly, but the previous modifications are only provisional. In order to make the booting option
    Code:
    nvme_core.default_ps_max_latency_us=200
    permanent, open the grub file
    Code:
    sudo nano /etc/default/grub
    make the modification
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvme_core.default_ps_max_latency_us=200"
    save the file, and update the grub
    Code:
    sudo update-grub
    7) Enjoy!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •