Results 1 to 1 of 1

Thread: Why is my laptop unlocking itself (18.04)?

  1. #1
    Join Date
    Dec 2018

    Why is my laptop unlocking itself (18.04)?

    Lenovo Y700, Ubuntu 18.04

    You know how sometimes you feel your fingers incorrectly type in your password and you know you're gonna have to wait to type it in again? That's happened a few times for me somewhat recently, except that it's unlocked itself. I was unsure of my self, so passed it off.

    But just a few minutes ago, I typed the first character of my password, and the lock screen didn't change to the login screen. I typed the character again and nothing happened, so I pressed the spacebar to try to get the thing's attention.

    Then it unlocked.

    This is spooked me, so I restarted my laptop and tried logging in with a random string, and nothing happened. I logged in with my regular password and then promptly changed it. Have not yet tried to unlock the laptop with the new password.

    Obviously, something is pretty wrong here. Since I really have no idea how to approach the problem, it seemed inappropriate for AskUbuntu (how would I determine whether or not an answer properly addresses the question?).

    So, any ideas on how to diagnose this? I haven't been doing anything with my laptop that would obviously get it a virus. I'm the only user, and I don't let anyone connect their own flashdrives to it or anything.

    Edit: I tried unlocking my system with my old password, and it worked. However, the terminal only recognizes my new root password. Any suggestions at this point would be greatly appreciated. My laptop is completely vulnerable, so I'm considering re-installing the OS or abandoning Ubuntu altogether.
    Last edited by ebanflo; December 18th, 2018 at 05:03 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts