Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

  1. #11
    Join Date
    Jul 2019
    Beans
    2

    Re: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

    Thank you very much for your helpful post chili,
    it has been working for me a long time. But with the kernel update to 4.15.0-55-generic-x86-64 it stopped working, I tried to reinstall (after removing) using your instruction again, but failed.
    Now I'm running 4.15.0-54 again, with no problems.
    Hoping either the next kernel will work with rtl8821CU-5.2.5.3 or an other solution will be posted.

  2. #12
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,842
    Distro
    Ubuntu 19.04 Disco Dingo

    Re: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

    Quote Originally Posted by rolfrenne View Post
    Thank you very much for your helpful post chili,
    it has been working for me a long time. But with the kernel update to 4.15.0-55-generic-x86-64 it stopped working, I tried to reinstall (after removing) using your instruction again, but failed.
    Now I'm running 4.15.0-54 again, with no problems.
    Hoping either the next kernel will work with rtl8821CU-5.2.5.3 or an other solution will be posted.
    Please run and post:
    Code:
    sudo dkms status
    Usually, when the build fails for a particular kernel version, details can be found in the make.log. I suspect it will be in /var/lib/dkms/rtl8821CU/5.2.5.3/4.15.0-55-generic/x86_64/log/make.log. Please show us:

    Code:
    cat  /var/lib/dkms/rtl8821CU/5.2.5.3/4.15.0-55-generic/x86_64/log/make.log
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #13
    Join Date
    Jul 2019
    Beans
    2

    Re: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

    Thank you very much for the quick response, but I'm sorry, I've purged 4.15.0-55, and there is no /var/lib/dkms/rtl8821CU/5.2.5.3/4.15.0-55-generic/ any more, but I'll report results with the next kernel update.

  4. #14
    Join Date
    Aug 2019
    Beans
    1

    Re: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

    I've been struggling to get this to work for a couple of days now and I still do.
    lsusb gives:
    Code:
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 046a:b103 Cherry GmbH 
    Bus 001 Device 002: ID 0bda:c811 Realtek Semiconductor Corp. 
    Bus 001 Device 004: ID 046a:0023 Cherry GmbH CyMotion Master Linux Keyboard G230
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    So the device is found.

    I'm using Linux Mint 19.1 so I apologize if this is the wrong forum. I tried different kernels versions: 5.2.5-050205-generic (x86_64) and 4.20.17-042017-generic (x86_64)

    Everything mentioned works except
    Code:
    sudo dkms build -m ${DRV_NAME} -v ${DRV_VERSION}
    .
    I get
    Code:
    Kernel preparation unnecessary for this kernel.  Skipping...
    
    Building module:
    cleaning build area...
    'make' KVER=4.20.17-042017-generic..........(bad exit status: 2)
    ERROR (dkms apport): binary package for rtl8821CU: 5.2.5.3 not found
    Error! Bad return status for module build on kernel: 4.20.17-042017-generic (x86_64)
    Consult /var/lib/dkms/rtl8821CU/5.2.5.3/build/make.log for more information.
    as the output (same output on both versions except the kernel version listed).

    In the make.log file it says
    Code:
    cc1: some warnings being treated as errors
    scripts/Makefile.build:291: recipe for target '/var/lib/dkms/rtl8821CU/5.2.5.3/build/os_dep/linux/ioctl_cfg80211.o' failed
    make[2]: *** [/var/lib/dkms/rtl8821CU/5.2.5.3/build/os_dep/linux/ioctl_cfg80211.o] Error 1
    Makefile:1562: recipe for target '_module_/var/lib/dkms/rtl8821CU/5.2.5.3/build' failed
    make[1]: *** [_module_/var/lib/dkms/rtl8821CU/5.2.5.3/build] Error 2
    make[1]: Verzeichnis „/usr/src/linux-headers-4.20.17-042017-generic“ wird verlassen
    Makefile:1923: recipe for target 'modules' failed
    make: *** [modules] Error 2
    in addition to a lot of -Werrors.

    Any idea?

  5. #15
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,842
    Distro
    Ubuntu 19.04 Disco Dingo

    Re: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

    Quote Originally Posted by bastian2001 View Post
    I've been struggling to get this to work for a couple of days now and I still do.
    <snip>
    in addition to a lot of -Werrors.

    Any idea?
    We don't know much about Mint or the 4.20 kernel here. I recommend that you ask here: https://forums.linuxmint.com/viewforum.php?f=53
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  6. #16
    Join Date
    Aug 2019
    Beans
    2

    Re: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

    Hi, i have a problem i received this Errors:

    Code:
    xx@xx:~/rtl8821CU$ sudo dkms build -m ${DRV_NAME} -v ${DRV_VERSION}
    
    Kernel preparation unnecessary for this kernel.  Skipping...
    
    Building module:
    cleaning build area...
    'make' KVER=5.0.0-25-generic.........(bad exit status: 2)
    ERROR (dkms apport): binary package for rtl8821CU: 5.2.5.3 not found
    Error! Bad return status for module build on kernel: 5.0.0-25-generic (x86_64)
    Consult /var/lib/dkms/rtl8821CU/5.2.5.3/build/make.log for more information.
    xx@xx:~/rtl8821CU$ sudo dkms install -m ${DRV_NAME} -v ${DRV_VERSION}
    
    Kernel preparation unnecessary for this kernel.  Skipping...
    
    Building module:
    cleaning build area...
    'make' KVER=5.0.0-25-generic.........(bad exit status: 2)
    ERROR (dkms apport): binary package for rtl8821CU: 5.2.5.3 not found
    Error! Bad return status for module build on kernel: 5.0.0-25-generic (x86_64)
    Consult /var/lib/dkms/rtl8821CU/5.2.5.3/build/make.log for more information.
    Thx for help

  7. #17
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,842
    Distro
    Ubuntu 19.04 Disco Dingo

    Re: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

    Quote Originally Posted by fuul2 View Post
    Hi, i have a problem i received this Errors:

    Code:
    xx@xx:~/rtl8821CU$ sudo dkms build -m ${DRV_NAME} -v ${DRV_VERSION}
    
    <snip>
    Consult /var/lib/dkms/rtl8821CU/5.2.5.3/build/make.log for more information.
    Thx for help
    Please try this method instead: https://askubuntu.com/questions/1164...164982#1164982
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  8. #18
    Join Date
    Aug 2019
    Beans
    2

    Re: Driver for RTL8811 Wireless Adapter for Ubuntu 18.04

    Yeah thx very much,

    Code:
    sudo apt update
    sudo apt install build-essential git dkms
    git clone https://github.com/brektrou/rtl8821CU.git
    cd rtl8821CU
    chmod +x dkms-install.sh
    sudo ./dkms-install.sh
    sudo modprobe 8821cu
    Now it works.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •