Results 1 to 2 of 2

Thread: QEMU doesn't support spice OpenGL

  1. #1
    Join Date
    Nov 2018
    Beans
    1

    QEMU doesn't support spice OpenGL

    Hi there,
    I'm trying to use KVM on my machine (threadripepr 2950 CPU and AMD WX7100 GPU) running ubuntu 18.04.
    I have followed KVM and virtual machine manager and bridge networking procedure and first step was ok.
    I have an issue of using OpenGL ( by selecting the option on Display Spice setting).
    I found this webpage explained the steps for activation openGL. https://at.projects.genivi.org/wiki/...s+acceleration
    Apart of last step verification which is:
    [# dmesg | grep gl [drm] virgl 3d acceleration enabled]
    the rest of the result was ok.
    Would anyone please let me know how I can use and set properly openGL and graphic acceleration on KVM on ubuntu 18.04?

    Cheers
    Last edited by deadflowr; November 13th, 2018 at 05:03 AM. Reason: fix hyperlink link issue

  2. #2
    Join Date
    Feb 2018
    Location
    New Jersey (NYC Area)
    Beans
    58
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: QEMU doesn't support spice OpenGL

    Try this blog page it is Ubuntu specific. The page you refer to is Fedora tested.: https://zingmars.info/2018/07/15/Virgl-with-qemu-and-libvirt-on-ubuntu/

    Also look at this bug report https://bugs.launchpad.net/ubuntu/+s...u/+bug/1540692 it seems that you can enable the OpenStack unsable repository
    Code:
       
    sudo add-apt-repository cloud-archive:stein
    sudo apt update
    sudo apt full-upgrade
    Last edited by richard378; April 22nd, 2019 at 12:22 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •