*I'm a complete newbie**

I'm running linux mint 18.1 on my laptop and was transferring files to my external hard drive. All was going smoothly until the power failed (ok there was no notice before the battery ran out and I hadn't plugged it in).

Now I get an unable to mount error message:
Error mounting /dev/sdb1 at /media/hannah/Maxtor: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=100 0" "/dev/sdb1" "/media/hannah/Maxtor"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdb1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

This thread seems to be what I'm looking for: https://ubuntuforums.org/showthread....nal+hard+drive

Basically -
Answer: "Since it worked before this you can exclude the fakeraid possibility, which leaves a hardware fault or filesystem inconsistency. Linux will not mount a damaged filesystem as a precaution against further damage. As NTFS is a Microsoft fileystem you need to run chkdsk from a Windows system to repair it. The Linux utility ntfsfix is not a viable alternative. You need a Windows system and chkdsk."

Reply: "And that worked! I was able to use a friend's Windows XP and ran chkdsk /f on restart, restarted the computer, ran the chkdsk, restarted again, and then tried the hard drive with my linux, and it worked."

My question is - Do I plug the hard drive into another laptop/PC with windows and run these commands on that to fix it then return the hard drive to my laptop. I know the hard drive works on a macbook, so confident that the hard drive is ok. I am a complete newbie to this so sorry if this is really obvious!