Results 1 to 5 of 5

Thread: Unable to mount external hard drive

  1. #1
    Join Date
    Nov 2018
    Beans
    1

    Unable to mount external hard drive

    *I'm a complete newbie**

    I'm running linux mint 18.1 on my laptop and was transferring files to my external hard drive. All was going smoothly until the power failed (ok there was no notice before the battery ran out and I hadn't plugged it in).

    Now I get an unable to mount error message:
    Error mounting /dev/sdb1 at /media/hannah/Maxtor: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=100 0" "/dev/sdb1" "/media/hannah/Maxtor"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).
    Failed to mount '/dev/sdb1': Input/output error
    NTFS is either inconsistent, or there is a hardware fault, or it's a
    SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
    then reboot into Windows twice. The usage of the /f parameter is very
    important! If the device is a SoftRAID/FakeRAID then first activate
    it and mount a different device under the /dev/mapper/ directory, (e.g.
    /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
    for more details.

    This thread seems to be what I'm looking for: https://ubuntuforums.org/showthread....nal+hard+drive

    Basically -
    Answer: "Since it worked before this you can exclude the fakeraid possibility, which leaves a hardware fault or filesystem inconsistency. Linux will not mount a damaged filesystem as a precaution against further damage. As NTFS is a Microsoft fileystem you need to run chkdsk from a Windows system to repair it. The Linux utility ntfsfix is not a viable alternative. You need a Windows system and chkdsk."

    Reply: "And that worked! I was able to use a friend's Windows XP and ran chkdsk /f on restart, restarted the computer, ran the chkdsk, restarted again, and then tried the hard drive with my linux, and it worked."

    My question is - Do I plug the hard drive into another laptop/PC with windows and run these commands on that to fix it then return the hard drive to my laptop. I know the hard drive works on a macbook, so confident that the hard drive is ok. I am a complete newbie to this so sorry if this is really obvious!

  2. #2
    Join Date
    Oct 2006
    Beans
    56,067

    Re: Unable to mount external hard drive

    Thread moved to the "MINT" forum.

  3. #3
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Unable to mount external hard drive

    It is certainly possible that the drive is unmountable in Linux because it was not removed (or unmounted) before your power failure.

    Regrettably Linux is not capable when it comes to NTFS repair, so I think your first move is to connect it to a Windows computer (any version I think will do) and run chkdsk a couple of times to see if that solves the problem.

    On a general point, if you do not own a Windows machine I would advise that NTFS is not an appropriate filesystem to use with Linux as it is almost unrepairable using Linux operating systems.
    DISTRO: Xubuntu 18.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  4. #4
    Join Date
    Apr 2008
    Beans
    9

    Re: Unable to mount external hard drive

    WARNING!

    Don't give up too soon!

    I had the same problem using an external USB-HD on Kubuntu.
    sudo ntfsfix /dev/sdb1 only ended in
    Going to empty the journal ($LogFile)... OK
    $MFTMirr does not match $MFT (record 3).
    Remount failed: Input/output error
    time and again.
    Then at the about 10th time it suddenly worked and repaired the disk.

  5. #5
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Unable to mount external hard drive

    +1 on not using NTFS unless there isn't any other choice. If this is a Linux external disk, NTFS isn't just more corruptible, but it is also slower and doesn't support normal Unix permissions. Today, those other things might not seem important, but they are. Why have a 30% slower disk for no good reason?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •