Results 1 to 5 of 5

Thread: Connection problem betweem PC and Android phone via KDE connect

  1. #1
    Join Date
    Feb 2014
    Beans
    20

    Connection problem betweem PC and Android phone via KDE connect

    Hi

    Yesterday I installed on my Ubuntu 18.04 KDE Connect and also on my phone with Android 7. All is well, they recognize each other and I can even browse through the files on the phone. Now I wanted to copy my photos (a few Gb) from the phone to the PC. But after a few second the phone dims the screen, then goes black and soon after that the connection seems to get lost. Then I get an error message about error splicing and a missing transport endpoint.

    Now I do not know what to do. On the phone I already checked the only option that I found to keep the wifi alive. But it was already switched on.

    On the Internet I found people stating that it had to do with large files. So I tested it by keeping the phone awake, again and again touching the display. Then the file transfer won't break off. But it did not want to do this permanently.

    Best regards

  2. #2
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    2,322
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Connection problem betweem PC and Android phone via KDE connect

    I would just set the screen timeout to a few minutes temporarily and transfer everything you want then reset timeout to whatever you prefer.

  3. #3
    Join Date
    Feb 2014
    Beans
    20

    Re: Connection problem betweem PC and Android phone via KDE connect

    I have tried to delay the lock to 5 min. No luck.
    I tried to set up the laptop as a device for smart lock. No luck.
    I also disabled the network lock, which is not recommended. But still no luck

  4. #4
    Join Date
    May 2018
    Beans
    26
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Connection problem betweem PC and Android phone via KDE connect

    I think it is the Android phone which is causing the issue.
    Looks like the Android phone is connected to a Wi-fi AP and the wi-fi link goes to sleep when the screen is turned off.

    You can prevent the wi-fi from going to sleep mode when the screen is off.

    On your Android phone: Go to Settings > Wi-Fi settings > Configure > Keep Wi-Fi- on during Sleep - Set this to Always
    The above navigation is for my Honor phone.
    If you have a different phone then the navigation might change but the end setting (Keep Wi-Fi- on during Sleep) should be same.

    That's all. I hope this will help you.

  5. #5
    Join Date
    Feb 2014
    Beans
    20

    Re: Connection problem betweem PC and Android phone via KDE connect

    Thank you, but as mentioned in the initial post, I already had the wifi setting switched to always. Did not solve the issue.

    However, yesterday I set the dim screen setting to the max of 10 minutes. And then I touched the display again and again after a few minutes. Still the copy process of my files broke off, but only after 45 minutes or so. Still, I find it curious that it has something to do with the phone being not dimmed.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •