Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: How-to: Run Ragnarok Online in WINE

  1. #1
    Join Date
    Jun 2006
    Location
    Winder, Georgia, USA
    Beans
    64

    How-to: Run Ragnarok Online in WINE

    Some tips have been adapted from:

    http://appdb.winehq.org/appview.php?iVersionId=928

    This guide assumes that you have the RO client and an installation of a fairly recent WINE

    Step 1: Open a terminal (alt+f2 and type gnome-terminal if in gnome, start->run->konsole if in KDE)

    Step 2: run winecfg

    Step 3: Select the graphics tab, and enable "Emulate a virtual desktop", and set it to a resulution that is supported by the RO client (see the next step)

    Step 4: Locate the RO folder, and launch Setup.exe in wine. Set it to run in fullscreen, and choose a resolution. Make sure the lightmap box is unticked as this can cause problems

    Step 5: open another terminal, or reuse the one you used for step 3 to navigate to the folder you installed RO in

    Step 6: Determine which server you use; sakray would be Sakexe.exe, the main servers would be Ragexe.exe. Private servers are tricky as they tend to use data folders, which for some reason cause problems.

    Step 7: type wine, a space, the name of the executable, another space, and 1rag1 (those are ones, not Ls)

    The client should load properly

    2010: Wow, this game is still around. Well it doesn't look like the client is much different, and WINE has come a long way. You probably won't have problems running it.

    I guess you can still post in this thread if you have problems, and if someone who plays the game in Ubuntu is around, they'll help out.

    2011 edit: No need to apologize for necroing. If RO can live for ten plus years, then this thread can keep popping up.
    Last edited by MKR.; March 19th, 2011 at 09:46 PM. Reason: Adding a note

  2. #2
    Join Date
    Aug 2006
    Location
    Harrisonville, MO
    Beans
    3
    Distro
    Ubuntu 6.06

    Re: How-to: Run Ragnarok Online in WINE

    I'm trying to run Ragnarok Online, but I keep getting this error:

    wine: Call from 0x402052 to unimplemented function MFC42.DLL.6478, aborting
    wine: Unimplemented function MFC42.DLL.6478 called at address 0x402052 (thread 0009), starting debugger...
    WineDbg starting on pid 0x8
    Unhandled exception: unimplemented function MFC42.DLL.6478 called in 32-bit code (0x602bd447).
    Register dump:
    CS:0023 SS:002b DS:002b ES:002b FS:006b GS:0063
    EIP:602bd447 ESP:0033e504 EBP:0033e568 EFLAGS:00000212( - 00 - -IA1)
    EAX:0000194e EBX:602fa280 ECX:00192910 EDX:00110024
    ESI:0033e510 EDI:00000001
    Stack dump:
    0x0033e504: 00010028 00000000 00000000 80000100
    0x0033e514: 00000001 00000000 00402052 00000002
    0x0033e524: 0041c8aa 0000194e 00000002 605a3078
    0x0033e534: 605eb040 605d065c 00110000 60b56a1c
    0x0033e544: ffffffff 00000001 0033e56c 60b3d393
    0x0033e554: 00110000 00000000 000004c8 606588c2
    fixme:ntdll:RtlNtStatusToDosErrorNoTeb no mapping for c0000119
    Backtrace:
    =>1 0x602bd447 call_dll_entry_point+0x67 in ntdll (0x602bd447)
    2 0x00402052 in sakray (+0x2052) (0x00402052)
    3 0x00000000 (0x00000000)
    0x602bd447 call_dll_entry_point+0x67 in ntdll: subl $4,%esp
    Modules:
    Module Address Debug info Name (66 modules)
    PE 400000-424000 Export sakray
    PE 5f400000-5f4ed000 Deferred mfc42
    ELF 60000000-60017000 Deferred ld-linux.so.2
    ELF 60019000-60129000 Deferred libwine.so.1
    ELF 6012b000-60133000 Deferred libxrender.so.1
    ELF 60133000-6013c000 Deferred libxcursor.so.1
    ELF 6013c000-60140000 Deferred libxfixes.so.3
    ELF 60141000-60153000 Deferred libpthread.so.0
    ELF 60154000-60283000 Deferred libc.so.6
    ELF 60283000-60286000 Deferred libdl.so.2
    ELF 60287000-60305000 Export ntdll<elf>
    \-PE 602a0000-60305000 \ ntdll
    ELF 60305000-60327000 Deferred libm.so.6
    ELF 60327000-60330000 Deferred libnss_compat.so.2
    ELF 60330000-60345000 Deferred libnsl.so.1
    ELF 60345000-6034e000 Deferred libnss_nis.so.2
    ELF 6034e000-60358000 Deferred libnss_files.so.2
    ELF 60358000-6045a000 Deferred kernel32<elf>
    \-PE 60370000-6045a000 \ kernel32
    ELF 6048d000-604d4000 Deferred wininet<elf>
    \-PE 604a0000-604d4000 \ wininet
    ELF 604d4000-604f3000 Deferred mpr<elf>
    \-PE 604e0000-604f3000 \ mpr
    ELF 604f3000-60625000 Deferred user32<elf>
    \-PE 60510000-60625000 \ user32
    ELF 60625000-606d7000 Deferred gdi32<elf>
    \-PE 60640000-606d7000 \ gdi32
    ELF 607b2000-607bd000 Deferred libgcc_s.so.1
    ELF 607bd000-60801000 Deferred advapi32<elf>
    \-PE 607d0000-60801000 \ advapi32
    ELF 60801000-60857000 Deferred shlwapi<elf>
    \-PE 60810000-60857000 \ shlwapi
    ELF 60857000-608e7000 Deferred ole32<elf>
    \-PE 60870000-608e7000 \ ole32
    ELF 608e7000-60936000 Deferred rpcrt4<elf>
    \-PE 608f0000-60936000 \ rpcrt4
    ELF 60936000-60955000 Deferred iphlpapi<elf>
    \-PE 60940000-60955000 \ iphlpapi
    ELF 60955000-60968000 Deferred libresolv.so.2
    ELF 60968000-60a4e000 Deferred shell32<elf>
    \-PE 60980000-60a4e000 \ shell32
    ELF 60a4e000-60b10000 Deferred comctl32<elf>
    \-PE 60a60000-60b10000 \ comctl32
    ELF 60b10000-60b72000 Deferred msvcrt<elf>
    \-PE 60b20000-60b72000 \ msvcrt
    ELF 60b72000-60bdb000 Deferred libfreetype.so.6
    ELF 60bdb000-60bef000 Deferred libz.so.1
    ELF 60bef000-60c1d000 Deferred libfontconfig.so.1
    ELF 60c1d000-60c3c000 Deferred libexpat.so.1
    ELF 60c3c000-60cbe000 Deferred winex11<elf>
    \-PE 60c50000-60cbe000 \ winex11
    ELF 60cbe000-60cc6000 Deferred libsm.so.6
    ELF 60cc6000-60cde000 Deferred libice.so.6
    ELF 60cde000-60ce3000 Deferred libxxf86vm.so.1
    ELF 60ce3000-60cf0000 Deferred libxext.so.6
    ELF 60cf0000-60dd6000 Deferred libx11.so.6
    ELF 60dd6000-60dd9000 Deferred libxau.so.6
    ELF 60dd9000-60e5e000 Deferred libgl.so.1
    ELF 60e5e000-61620000 Deferred libglcore.so.1
    ELF 61620000-61622000 Deferred libnvidia-tls.so.1
    ELF 61622000-6163e000 Deferred imm32<elf>
    \-PE 61630000-6163e000 \ imm32
    ELF 61640000-61672000 Deferred uxtheme<elf>
    \-PE 61650000-61672000 \ uxtheme
    PE 780c0000-78121000 Deferred msvcp60
    ELF 7bf00000-7bf03000 Deferred <wine-loader>
    Threads:
    process tid prio (all id:s are in hex)
    0000000a
    0000000b 0
    00000008 (D) C:\Program Files\Gravity\RO\sakray.exe
    00000009 0 <==


    I've configured wine to use native mfc42.dll and got the dll off the web, and put it in windows/system (and windows/system32 AND the RO folder, based on various fixes I've read)... yet this continues to occur. Any ideas?

  3. #3
    Join Date
    Aug 2006
    Location
    Finland
    Beans
    3
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: How-to: Run Ragnarok Online in WINE

    I used mfc42.dll from my XP Pro installation, client loads fine but its very laggy.

    Very nice How-to anyways.

  4. #4
    Join Date
    Sep 2006
    Beans
    21
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How-to: Run Ragnarok Online in WINE

    I tried your method... it sort of worked. After 5 minutes, the client popped up. The interface was in Korean, and there appeared to be splits in the image. The emulated desktop showed two empty windows and it flickered between that and the "fullscreen" Ragnarok. i was able to log into my server successfully, but it took exceptionally long to load the map I was in, and was unplayable due to the flickering. I use a personally hexed client for a private server that uses a data folder, but that doesn't seem to be the only issue from the errors I got. The fact that the client was in Korean leads me to believe that it could not read the Data folder, where translated sprites are located, but the other issues appear to be problems with video and sound emulation. Note that <-(x#) means that this error repeated # times.

    Errors:
    Code:
    fixme:d3d:IWineD3DDeviceImpl_GetAvailableTextureMem (0x1670028) : stub, simulating 64MB for now, returning 64MB left
    fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x1e6aa8)->(0x20024,00000c13)
    fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x1e6aa8) Unhandled flag DDSCL_MULTITHREADED, Uh Oh...
    fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to 16
    fixme:d3d:state_blend Unrecognized dst blend value 0
    fixme:d3d:IWineD3DDeviceImpl_SetRenderState WINED3DRS_POINTSIZE_MIN not supported on this opengl
    err:d3d:IWineD3DDeviceImpl_SetRenderState Multisample antialiasing not supported by gl
    fixme:d3d:IWineD3DDeviceImpl_SetRenderState WINED3DRS_POINTSIZE_MAX not supported on this opengl
    fixme:win:WIN_CreateWindowEx Parent is HWND_MESSAGE
    fixme:imm:ImmReleaseContext (0x20024, 0x16c670): stub
    fixme:imm:ImmReleaseContext (0x20024, 0x16c670): stub
    fixme:d3d_surface:IWineGDISurfaceImpl_Blt Can't handle DDBLT_WAIT flag right now.
    err:dsound:DSOUND_MixOne underrun on sound buffer 0x1e54c0 <- (x7)
    fixme:imm:ImmReleaseContext (0x20024, 0x16c670): stub
    err:dsound:DSOUND_MixOne underrun on sound buffer 0x1e54c0 <-(x4)
    fixme:imm:ImmReleaseContext (0x20024, 0x16c670): stub <-(x6)
    err:dsound:DSOUND_MixOne underrun on sound buffer 0x1e54c0 <-(x24)
    <I killed wine with CTRL+C at this point>
    From this it would seem that it cannot emulate sound, and that it is trying to drop the window from 32 to 16 bits.

    I am running Edgy (beryl was running, I'll try without it) on an unmodified Toshiba Satellite M105-S3031. If anyone knows how to solve these problems, please let me know. I'm dying to be able to play my favorite game on linux

  5. #5
    Join Date
    Feb 2008
    Location
    a building
    Beans
    Hidden!
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: How-to: Run Ragnarok Online in WINE

    (bad idea) for me, i tried to run this like you said but everything froze and i had to hold the power button to force a reboot

  6. #6
    Join Date
    Mar 2008
    Beans
    12

    Re: How-to: Run Ragnarok Online in WINE

    Sorry for the grave dig, but I got an error.

    boe@boe-desktop:~$ wine limitro lragl
    preloader: Warning: failed to reserve range 00000000-60000000
    preloader: Warning: failed to reserve range 00000000-60000000
    err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please report
    What does this mean?

  7. #7
    Join Date
    Jun 2006
    Location
    Winder, Georgia, USA
    Beans
    64

    Re: How-to: Run Ragnarok Online in WINE

    I wrote this guide two years ago. The client has probably changed considerably since then, and I haven't played in about a year. Someone else will have to figure it out.

  8. #8
    Join Date
    Aug 2008
    Beans
    8

    Re: How-to: Run Ragnarok Online in WINE

    Any Idea why it runs slow with ATI cards?

  9. #9
    Join Date
    Aug 2008
    Beans
    2

    Re: How-to: Run Ragnarok Online in WINE

    I was wondering the same thing. Why is the client so laggy when running with ATI cards? Drivers?

  10. #10
    Join Date
    Feb 2009
    Beans
    10

    Re: How-to: Run Ragnarok Online in WINE

    Hi, thanks for your 'how-to'. I can play Ragnarok Online Indonesia (IdRO) now..

    But, my slow inet connection make me.. huffhh... :'(

    Ps:
    I'm using Ubuntu 9.10 Karmic Koala with Wine 1.0.1

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •