Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: No audio output on computer after upgrading to 18.10 beta

  1. #1

    No audio output on computer after upgrading to 18.10 beta

    Just a few days ago I upgraded my HP Notebook from 18.04 to 18.10 beta and now my audio does not work at all. When I go to the audio settings, all I see is a "dummy output". I see this in the terminal:

    Code:
     00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d70] (rev 21)	Subsystem: Hewlett-Packard Company Sunrise Point-LP HD Audio [103c:81eb]
    	Kernel driver in use: snd_hda_intel
    	Kernel modules: snd_hda_intel, snd_soc_skl
    and this:

    Code:
    snd_hda_intel          40960  3snd_hda_codec         126976  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
    snd_hda_core           81920  7 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_soc_skl
    snd_pcm                98304  9 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
    snd                    81920  18 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_rawmidi
    I am not too experienced in this type of thing so I am at all sure what to do but I would really like to be able to listen to youtube videos and play music again. And I cannot even listen to music with headphones either. No audio output at all.

    Thanks,

    Michael Dykes

  2. #2
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: No audio output on computer after upgrading to 18.10 beta

    As it is an upgrade, think to clean the system now, with:
    - gtkorphan
    - bleachbit (as root,select options carefully)

    and also see the output of: "journalctl -b" on next reboot.

  3. #3

    Re: No audio output on computer after upgrading to 18.10 beta

    I tried blechbit and rebooted but to no avail. The results of "journalctl -b" are:

    Code:
    -- Logs begin at Sun 2018-10-07 19:43:18 EDT, end at Sun 2018-10-07 20:57:13 EDT. --
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: microcode: microcode updated early to revision 0xc6, date = 2018-04-17
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: Linux version 4.18.0-8-generic (buildd@lgw01-amd64-055) (gcc version 8.2.0 (Ubuntu 8.2.0-6ubuntu1)) #9-U
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.18.0-8-generic root=UUID=43d6e00e-b8bd-4288-aa92-df274a17b2c6 r
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: KERNEL supported cpus:
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel:   Intel GenuineIntel
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel:   AMD AuthenticAMD
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel:   Centaur CentaurHauls
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: Supporting XSAVE feature 0x008: 'MPX bounds registers'
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: Supporting XSAVE feature 0x010: 'MPX CSR'
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: xstate_offset[3]:  832, xstate_sizes[3]:   64
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: xstate_offset[4]:  896, xstate_sizes[4]:   64
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: x86/fpu: Enabled xstate features 0x1f, context size is 960 bytes, using 'compacted' format.
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-provided physical RAM map:
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x0000000000000000-0x0000000000057fff] usable
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x0000000000058000-0x0000000000058fff] reserved
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x0000000000059000-0x0000000000085fff] usable
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x0000000000086000-0x00000000000fffff] reserved
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000740bcfff] usable
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x00000000740bd000-0x00000000740bdfff] ACPI NVS
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x00000000740be000-0x00000000740e7fff] reserved
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x00000000740e8000-0x000000008a38dfff] usable
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x000000008a38e000-0x000000008a58dfff] type 20
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x000000008a58e000-0x000000008ad7dfff] reserved
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x000000008ad7e000-0x000000008af7dfff] ACPI NVS
    Oct 07 20:54:37 thedoctor-HP-Notebook kernel: BIOS-e820: [mem 0x000000008af7e000-0x000000008affdfff] ACPI data
    lines 1-30

  4. #4
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    2,161
    Distro
    Ubuntu Development Release

    Re: No audio output on computer after upgrading to 18.10 beta

    I'm seeing this same thing in two systems with very different audio hardware. One of the systems has the same hardware as thedoctor818772's. This is the bug report if you want to check that it affects you:

    https://bugs.launchpad.net/ubuntu/+s...o/+bug/1781294

    A workaround:
    Code:
    sudo alsa force-reload
    Catalan Team: Tingueu presents les normes d'or : poseu un títol entenedor i apropiat ; digueu quina versió i variant d'Ubuntu feu servir i a quina màquina; i què heu provat abans de demanar ajut. Si s'ha resolt, marqueu [Solved].

  5. #5

    Re: No audio output on computer after upgrading to 18.10 beta

    Thanks. I tried that code above but to no avail.

  6. #6
    Join Date
    Jun 2007
    Beans
    16,948

    Re: No audio output on computer after upgrading to 18.10 beta

    Try a live session with latest image, if that works then try a fresh install..
    If that works then it's just an issue with upgrades, file a bug specific to that.
    (- whether Ubuntu cares about that anymore I wouldn't know..

  7. #7
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    2,161
    Distro
    Ubuntu Development Release

    Re: No audio output on computer after upgrading to 18.10 beta

    At least for servers, there should be always an upgrade path, shouldn't it?
    Catalan Team: Tingueu presents les normes d'or : poseu un títol entenedor i apropiat ; digueu quina versió i variant d'Ubuntu feu servir i a quina màquina; i què heu provat abans de demanar ajut. Si s'ha resolt, marqueu [Solved].

  8. #8
    Join Date
    Jun 2007
    Beans
    16,948

    Re: No audio output on computer after upgrading to 18.10 beta

    Quote Originally Posted by wgarcia View Post
    At least for servers, there should be always an upgrade path, shouldn't it?
    Well the point here, (dev) would be to 1st determine if this issue is a problem for upgrades only or does also it exist in the current state of 18.10, i.e the latest available image.
    If 'release' upgrades only you might then check if a fresh 18.04 updated, then upgraded to 18.10 shows the issue. If not then it's limited to some 18.04 installs upgraded to 18.10

  9. #9
    Join Date
    Nov 2009
    Beans
    3,228

    Re: No audio output on computer after upgrading to 18.10 beta

    I just upgraded through the ranks from 16.04 to 18.04 (4000 files) to 18.10 (3000 files) installed and all went reasonably ok
    for (7000 files and 6 hours passing by)

    So the sound was working OK upto 18.04 ............. but not working in 18.10 ........
    whether it happens on a clean install I cannot say as I did not try that out.


    I saw this thread and thought to report my problem
    (as the command posted in here by wgarcia - got mine working again)

    so in 18.10 ......... Audio did not work at first ......... but .....
    sudo alsa force-reload

    Made it work OK for my system ASUS

    Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz

    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

    sudo aplay -l

    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    Just thought I would pop this in for information - lightdm applet for sound is usually set muted and when I have
    moved that in the past sound as come on - this time the applet greys out and shows a cross on it after
    doing - sudo alsa force-reload

    The following shows up ..........

    Terminating processes: 1112.

    Unloading ALSA sound driver modules: snd-hrtimer snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-timer).

    Loading ALSA sound driver modules: snd-hrtimer snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.

    ok that is all I can tell you at the moment ....... only got it working last night late on .......

  10. #10
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    2,161
    Distro
    Ubuntu Development Release

    Re: No audio output on computer after upgrading to 18.10 beta

    @23dornot23d I'm seeing everything exactly as you, except on what you comment on the lightdm applet.

    Your sound hardware is different from the sound hardware where I have had this issue, so this makes the third sound hardware where this upgrade problem with sound has happened.

    When I have time I will try a fresh install of 18.10 on one of my hardwares and see if I can reproduce this.
    Catalan Team: Tingueu presents les normes d'or : poseu un títol entenedor i apropiat ; digueu quina versió i variant d'Ubuntu feu servir i a quina màquina; i què heu provat abans de demanar ajut. Si s'ha resolt, marqueu [Solved].

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •