Results 1 to 9 of 9

Thread: Video driver won't load unless I launch "Recovery Menu" first???

  1. #1
    Join Date
    Nov 2007
    Beans
    157

    Question Video driver won't load unless I launch "Recovery Menu" first???

    Help. I don't know why, but suddenly Ubuntu (64bit 18.04.01 LTS) won't start without going through the Recovery Mode menu first. I don't have to check or change anything. Just click "Resume" to finish the boot process. ] (*,)

    The other day I had to manually d/l & reinstall the nVidia graphics driver. Now, every time I start Ubu, The only way I can get back into the normal Ubu desktop is to select "Recovery Mode" first from the GRUB boot menu, and once the text menu appears, select "resume", which finishes the normal boot and everything is fine (including graphics driver.)

    If I simply select "Ubuntu" from Grub, startup switches resolutions a few times, a brief horizontal bar of garbage, then I lose my video signal and my monitor shuts off.

    In Recovery Mode, I try "fix dpkg" but it says it can't connect (I'm connected.) When I do get to the desktop, I run the "Software Updater" and it reports:

    "Failed to Download Repository":

    ...my Internet connection is fine.

    I click OK, and it proceeds to download & install my updates. I don't know which "Repository" it can't connect to in order to remove it.
    And is the the updated video driver (downloaded from nvidia's own website) the reason Ubu won't start normally anymore? The system won't allow me to go back to the old method:


    This is all very annoying. How do I fix this? TIA
    Last edited by Mugsy323; October 5th, 2018 at 10:11 PM.

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,893
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Video driver won't load unless I launch "Recovery Menu" first???

    Mugsy323' Yukkie -

    Nvidia themselves advise do not do that .
    Note that many Linux distributions provide their own packages of the NVIDIA Linux Graphics Driver in the distribution's native package management format. This may interact better with the rest of your distribution's framework, and you may want to use this rather than NVIDIA's official package.
    so now we got to see what it takes to remove the OEM driver;
    what shows:
    Code:
    sudo find / -name "NVIDIA-Linux-*"
    dpkg -l | grep -i nvidia
    lsmod | grep nvidia
    dkms status
    Then we want to know the card we are installing the driver for:
    Code:
    lspci -k|grep -iEA5 'vga|3d'
    to verify the driver to be installed.

    nothing but a thing ?
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  3. #3
    Join Date
    Nov 2007
    Beans
    157

    Re: Video driver won't load unless I launch "Recovery Menu" first???

    Quote Originally Posted by Bashing-om View Post
    Nvidia themselves advise do not do that.
    Live & Learn.

    Thanks for the reply.

    Quote Originally Posted by Bashing-om View Post
    so now we got to see what it takes to remove the OEM driver;
    what shows:
    Code:
    sudo find / -name "NVIDIA-Linux-*"
    Here is what I get executing that first command:

    Code:
    find: ‘/run/user/1000/gvfs’: Permission denied
    /home/mugsy/Downloads/NVIDIA-Linux-x86_64-390.87.run
    find: ‘/proc/2586/task/2586/net’: Invalid argument
    find: ‘/proc/2586/net’: Invalid argument
    Gack!

  4. #4
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,893
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Video driver won't load unless I launch "Recovery Menu" first???

    Mugsy323; Well ,,

    not much given to work with , working with what we have,
    The run file also contains a UN-installer.
    Code:
    cd /home/mugsy/Downloads/
    sudo NVIDIA-Linux-x86_64-390.87.run --uninstall
    try'n 2 help
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  5. #5
    Join Date
    Nov 2007
    Beans
    157

    Re: Video driver won't load unless I launch "Recovery Menu" first???

    Quote Originally Posted by Bashing-om View Post
    not much given to work with , working with what we have,


    Yeah, I saw that coming. I'll let you know. Thanks.

  6. #6
    Join Date
    Nov 2007
    Beans
    157

    Re: Video driver won't load unless I launch "Recovery Menu" first???

    Quote Originally Posted by Bashing-om View Post
    Mugsy323; Well ,,

    not much given to work with , working with what we have,
    The run file also contains a UN-installer.
    Code:
    cd /home/mugsy/Downloads/
    sudo NVIDIA-Linux-x86_64-390.87.run --uninstall
    Sorry for the late reply. Busy weekend. A/C out.

    When I try the above command, I get:

    sudo: NVIDIA-Linux-x86_64-390.87.run: command not found

    I tried "chmod +x NVIDIA-Linux-x86_64-390.87.run" and trying again, but it made no difference.

  7. #7
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,893
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Video driver won't load unless I launch "Recovery Menu" first???

    Mugsy323; Hummm ...

    "find" said:
    /home/mugsy/Downloads/NVIDIA-Linux-x86_64-390.87.run
    what now shows:
    Code:
    ls -al /home/mugsy/Downloads/NVIDIA-Linux-x86_64-390.87.run
    Maybe we got to explicitly declare where the file is.
    " ./Nvidiawhatever.run --uninstall" ??

    maybe ?
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  8. #8
    Join Date
    Nov 2007
    Beans
    157

    Re: Video driver won't load unless I launch "Recovery Menu" first???

    Thx. A little searching online, I found:

    sudo nvidia-uninstall

    nVidia's own uninstaller did the trick. I then rebooted and reinstalled the driver "properly" using the "Software & Updates" utility (just search "driver".)

    Not only did it properly install the latest driver, but Vulkan too, and booting is back to normal! Yea!

    Thanks.

    PS: You were probably right about needing the "./" prefix.

  9. #9
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,893
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Video driver won't load unless I launch "Recovery Menu" first???

    Mugsy323; Outstanding

    Pleased ya got it fingered out .

    If this matter is concluded to your satisfaction ->
    Please mark this thread solved;
    aides others seeking the solution,
    helps keep the forum clean and
    precludes others miss-directing efforts to aid.
    https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads

    and we have more fun else-when
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •