Results 1 to 2 of 2

Thread: Error al ejecutar Ka lite, posible error en la instalación.

  1. #1
    Join Date
    Sep 2018
    Beans
    1

    Error al ejecutar Ka lite, posible error en la instalación.

    Hola!
    ¡Buenas noches!

    Estoy tratando de instalar Ka lite de Khan Academy en Ubuntu 18.04 64 bits Gnome:
    https://ka-lite.readthedocs.io/en/latest/installguide/install_all.html#linux

    Aparentemente si se instala, pero al momento de iniciarlo me da la siguiente dirección:
    http://127.0.0.1:7005/ a donde ingreso, pero todo queda en blanco.

    ¿Alguien tiene alguna idea de como solucionarlo?

    Estoy instalando en Ubuntu 18.04 de 64 bits.


    /home/user/.kalite/server.log contiene:

    PHP Code:
    [INFO] [2018-09-22 21:16:51,475cherrypy.error: [22/Sep/2018:21:16:51ENGINE Listening for SIGHUP.
    [
    INFO] [2018-09-22 21:16:51,476cherrypy.error: [22/Sep/2018:21:16:51ENGINE Listening for SIGTERM.
    [
    INFO] [2018-09-22 21:16:51,476cherrypy.error: [22/Sep/2018:21:16:51ENGINE Listening for SIGUSR1.
    [
    INFO] [2018-09-22 21:16:51,477cherrypy.error: [22/Sep/2018:21:16:51ENGINE Bus STARTING
    [INFO] [2018-09-22 21:16:51,477cherrypy.error: [22/Sep/2018:21:16:51]  Loading and serving the Django application
    [INFO] [2018-09-22 21:16:51,490cherrypy.error: [22/Sep/2018:21:16:51ENGINE Started monitor thread '_TimeoutMonitor'.
    [
    INFO] [2018-09-22 21:16:51,716cherrypy.error: [22/Sep/2018:21:16:51ENGINE Serving on http://0.0.0.0:7005
    [INFO] [2018-09-22 21:16:51,716cherrypy.error: [22/Sep/2018:21:16:51ENGINE Bus STARTED
    [ERROR] [2018-09-22 21:16:57,402cherrypy.error: [22/Sep/2018:21:16:57]  ENGINE GEOSException(u'Could not parse version info string  "3.6.2-CAPI-1.10.2 4d2925d6"',)
    Traceback (most recent call last):
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/cherrypy/wsgiserver/wsgiserver2.py"line 1353in communicate
        req
    .respond()
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/cherrypy/wsgiserver/wsgiserver2.py"line 868in respond
        self
    .server.gateway(self).respond()
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/cherrypy/wsgiserver/wsgiserver2.py"line 2257in respond
        response 
    self.req.server.wsgi_app(self.envself.start_response)
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/cherrypy/_cptree.py"line 299in __call__
        
    return app(environstart_response)
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/handlers/wsgi.py"line 255in __call__
        response 
    self.get_response(request)
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/handlers/base.py"line 178in get_response
        response 
    self.handle_uncaught_exception(requestresolversys.exc_info())
      
    File  "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/handlers/base.py",  line 220in handle_uncaught_exception
        
    if resolver.urlconf_module is None:
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/urlresolvers.py"line 342in urlconf_module
        self
    ._urlconf_module import_module(self.urlconf_name)
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/utils/importlib.py"line 35in import_module
        __import__
    (name)
      
    File "/usr/lib/python2.7/dist-packages/kalite/distributed/urls.py"line 14in <module>
        
    from import api_urls
      File 
    "/usr/lib/python2.7/dist-packages/kalite/distributed/api_urls.py"line 12in <module>
        
    import kalite.coachreports.api_urls
      File 
    "/usr/lib/python2.7/dist-packages/kalite/coachreports/api_urls.py"line 3in <module>
        
    from .api_resources import PlaylistProgressResourcePlaylistProgressDetailResource
      File 
    "/usr/lib/python2.7/dist-packages/kalite/coachreports/api_resources.py"line 3in <module>
        
    from tastypie.resources import Resource
      File 
    "/usr/lib/python2.7/dist-packages/kalite/packages/dist/tastypie/resources.py"line 20in <module>
        
    from django.contrib.gis.db.models.fields import GeometryField
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/__init__.py",  line 5in <module>
        
    from django.contrib.gis.db.models.aggregates import *
      
    File  "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/aggregates.py",  line 2in <module>
        
    from django.contrib.gis.db.models.sql import GeomField
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/sql/__init__.py",  line 2in <module>
        
    from django.contrib.gis.db.models.sql.query import GeoQuery
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/sql/query.py",  line 4in <module>
        
    from django.contrib.gis.db.models.fields import GeometryField
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/fields.py",  line 4in <module>
        
    from django.contrib.gis import forms
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/forms/__init__.py",  line 2in <module>
        
    from django.contrib.gis.forms.fields import GeometryField
      File 
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/forms/fields.py"line 8in <module>
        
    from django.contrib.gis.geos import GEOSExceptionGEOSGeometry
      File 
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/__init__.py"line 6in <module>
        
    from django.contrib.gis.geos.geometry import GEOSGeometrywkt_regexhex_regex
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/geometry.py",  line 16in <module>
        
    from django.contrib.gis.geos.coordseq import GEOSCoordSeq
      File 
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/coordseq.py"line 9in <module>
        
    from django.contrib.gis.geos.libgeos import CS_PTR
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/libgeos.py",  line 131in <module>
        
    _verinfo geos_version_info()
      
    File  "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/libgeos.py",  line 126in geos_version_info
        raise GEOSException
    ('Could not parse version info string "%s"' ver)
    GEOSExceptionCould not parse version info string "3.6.2-CAPI-1.10.2 4d2925d6"

    [ERROR] [2018-09-22 21:16:59,482cherrypy.error: [22/Sep/2018:21:16:59]  ENGINE GEOSException(u'Could not parse version info string  "3.6.2-CAPI-1.10.2 4d2925d6"',)
    Traceback (most recent call last):
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/cherrypy/wsgiserver/wsgiserver2.py"line 1353in communicate
        req
    .respond()
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/cherrypy/wsgiserver/wsgiserver2.py"line 868in respond
        self
    .server.gateway(self).respond()
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/cherrypy/wsgiserver/wsgiserver2.py"line 2257in respond
        response 
    self.req.server.wsgi_app(self.envself.start_response)
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/cherrypy/_cptree.py"line 299in __call__
        
    return app(environstart_response)
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/handlers/wsgi.py"line 255in __call__
        response 
    self.get_response(request)
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/handlers/base.py"line 178in get_response
        response 
    self.handle_uncaught_exception(requestresolversys.exc_info())
      
    File  "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/handlers/base.py",  line 220in handle_uncaught_exception
        
    if resolver.urlconf_module is None:
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/urlresolvers.py"line 342in urlconf_module
        self
    ._urlconf_module import_module(self.urlconf_name)
      
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/utils/importlib.py"line 35in import_module
        __import__
    (name)
      
    File "/usr/lib/python2.7/dist-packages/kalite/distributed/urls.py"line 14in <module>
        
    from import api_urls
      File 
    "/usr/lib/python2.7/dist-packages/kalite/distributed/api_urls.py"line 12in <module>
        
    import kalite.coachreports.api_urls
      File 
    "/usr/lib/python2.7/dist-packages/kalite/coachreports/api_urls.py"line 3in <module>
        
    from .api_resources import PlaylistProgressResourcePlaylistProgressDetailResource
      File 
    "/usr/lib/python2.7/dist-packages/kalite/coachreports/api_resources.py"line 3in <module>
        
    from tastypie.resources import Resource
      File 
    "/usr/lib/python2.7/dist-packages/kalite/packages/dist/tastypie/resources.py"line 20in <module>
        
    from django.contrib.gis.db.models.fields import GeometryField
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/__init__.py",  line 5in <module>
        
    from django.contrib.gis.db.models.aggregates import *
      
    File  "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/aggregates.py",  line 2in <module>
        
    from django.contrib.gis.db.models.sql import GeomField
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/sql/__init__.py",  line 2in <module>
        
    from django.contrib.gis.db.models.sql.query import GeoQuery
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/sql/query.py",  line 4in <module>
        
    from django.contrib.gis.db.models.fields import GeometryField
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/fields.py",  line 4in <module>
        
    from django.contrib.gis import forms
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/forms/__init__.py",  line 2in <module>
        
    from django.contrib.gis.forms.fields import GeometryField
      File 
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/forms/fields.py"line 8in <module>
        
    from django.contrib.gis.geos import GEOSExceptionGEOSGeometry
      File 
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/__init__.py"line 6in <module>
        
    from django.contrib.gis.geos.geometry import GEOSGeometrywkt_regexhex_regex
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/geometry.py",  line 16in <module>
        
    from django.contrib.gis.geos.coordseq import GEOSCoordSeq
      File 
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/coordseq.py"line 9in <module>
        
    from django.contrib.gis.geos.libgeos import CS_PTR
      File  
    "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/libgeos.py",  line 131in <module>
        
    _verinfo geos_version_info()
      
    File  "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/libgeos.py",  line 126in geos_version_info
        raise GEOSException
    ('Could not parse version info string "%s"' ver)
    GEOSExceptionCould not parse version info string "3.6.2-CAPI-1.10.2 4d2925d6" 
    Cuando ejecuto

    kalite manage setup

    Traceback (most recent call last):
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/management/base.py", line 224, in run_from_argv
    self.execute(*args, **options.__dict__)
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/management/base.py", line 263, in execute
    output = self.handle(*args, **options)
    File "/usr/lib/python2.7/dist-packages/kalite/distributed/management/commands/setup.py", line 477, in handle
    call_command("collectstatic_js_reverse", interactive=False)
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/management/__init__.py", line 161, in call_command
    return klass.execute(*args, **defaults)
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/management/base.py", line 263, in execute
    output = self.handle(*args, **options)
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/django_js_reverse/management/commands/collectstatic_js_reverse.py", line 26, in handle
    content = urls_js()
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/django_js_reverse/views.py", line 50, in urls_js
    'urls': sorted(list(prepare_url_list(default_urlresolver))),
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/django_js_reverse/views.py", line 74, in prepare_url_list
    for url_name in urlresolver.reverse_dict.keys():
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/urlresolvers.py", line 297, in reverse_dict
    self._populate()
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/urlresolvers.py", line 263, in _populate
    for pattern in reversed(self.url_patterns):
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/urlresolvers.py", line 347, in url_patterns
    patterns = getattr(self.urlconf_module, "urlpatterns", self.urlconf_module)
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/urlresolvers.py", line 342, in urlconf_module
    self._urlconf_module = import_module(self.urlconf_name)
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/utils/importlib.py", line 35, in import_module
    __import__(name)
    File "/usr/lib/python2.7/dist-packages/kalite/distributed/urls.py", line 14, in <module>
    from . import api_urls
    File "/usr/lib/python2.7/dist-packages/kalite/distributed/api_urls.py", line 12, in <module>
    import kalite.coachreports.api_urls
    File "/usr/lib/python2.7/dist-packages/kalite/coachreports/api_urls.py", line 3, in <module>
    from .api_resources import PlaylistProgressResource, PlaylistProgressDetailResource
    File "/usr/lib/python2.7/dist-packages/kalite/coachreports/api_resources.py", line 3, in <module>
    from tastypie.resources import Resource
    File "/usr/lib/python2.7/dist-packages/kalite/packages/dist/tastypie/resources.py", line 20, in <module>
    from django.contrib.gis.db.models.fields import GeometryField
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/__init__.py", line 5, in <module>
    from django.contrib.gis.db.models.aggregates import *
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/aggregates.py", line 2, in <module>
    from django.contrib.gis.db.models.sql import GeomField
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/sql/__init__.py", line 2, in <module>
    from django.contrib.gis.db.models.sql.query import GeoQuery
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/sql/query.py", line 4, in <module>
    from django.contrib.gis.db.models.fields import GeometryField
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/db/models/fields.py", line 4, in <module>
    from django.contrib.gis import forms
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/forms/__init__.py", line 2, in <module>
    from django.contrib.gis.forms.fields import GeometryField
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/forms/fields.py", line 8, in <module>
    from django.contrib.gis.geos import GEOSException, GEOSGeometry
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/__init__.py", line 6, in <module>
    from django.contrib.gis.geos.geometry import GEOSGeometry, wkt_regex, hex_regex
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/geometry.py", line 16, in <module>
    from django.contrib.gis.geos.coordseq import GEOSCoordSeq
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/coordseq.py", line 9, in <module>
    from django.contrib.gis.geos.libgeos import CS_PTR
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/libgeos.py", line 131, in <module>
    _verinfo = geos_version_info()
    File "/usr/lib/python2.7/dist-packages/kalite/packages/bundled/django/contrib/gis/geos/libgeos.py", line 126, in geos_version_info
    raise GEOSException('Could not parse version info string "%s"' % ver)
    GEOSException: Could not parse version info string "3.7.0-CAPI-1.11.0 673b9939"



    Espero me puedan orientar!

    ¡gracias!

  2. #2
    Join Date
    Jun 2014
    Beans
    15

    Re: Error al ejecutar Ka lite, posible error en la instalación.

    Hola, eso me huele a un bug del mismo desarrollo, especialmente en la función "geos_version_info()" de python, el cual no es capaz de procesar el texto de la versión de CAPI, probablemente está intentando utilizar un componente con una versión inesperada por el desarrollador.

    En cualquier caso no es un problema de ubuntu sino del desarrollador de la aplicación. Te sugiero que te contactes con ellos y reportes el fallo para obtener soporte.

    Saludos.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •