Results 1 to 8 of 8

Thread: Stella in 18.04

  1. #1
    Join Date
    Sep 2018
    Beans
    5

    Stella in 18.04

    Good evening, good morning & good afternoon!
    I have recently installed Ubuntu 18.04 for the first timeand have started playing round with the system and installing the new softwareI require.
    VLC, Gimp, OpenShot, Ardour and Audacity all work perfectlyfine on the first installation but for some unknown reason I cannot get Stella(Atari 2600 Emulator) to work?
    It looks like it installs fine but when I hit run followingthe download nothing happens, I have tried going into programs and the Stellabutton is there, but again, if I click on it I get a spinny wheel for a fewseconds and then nothing……
    Does anyone know what is causing this issue?
    I love playing Atari 2600 and I have been running Stella inWindows fine for years….
    Please help!

    CX40
    Last edited by ajgreeny; September 13th, 2018 at 02:21 PM. Reason: Font normalised; please use the forum default font.

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,453
    Distro
    Ubuntu

    Re: Stella in 18.04

    Thread moved to Emulators

    stella's execution command is stella, so if you run it from a terminal, what is the output:
    Code:
    stella
    please post back any results it shows.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Sep 2018
    Beans
    5

    Re: Stella in 18.04


  4. #4
    Join Date
    Sep 2018
    Beans
    5

    Re: Stella in 18.04

    david@dday1sc:~$ stella
    ERROR: Couldn't load settings file
    dbus[9997]: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file ../../../dbus/dbus-message.c line 1362.
    This is normally a bug in some application using the D-Bus library.

    D-Bus not built with -rdynamic so unable to print a backtrace
    Aborted (core dumped)
    david@dday1sc:~$ ^C
    david@dday1sc:~$

  5. #5
    Join Date
    Sep 2018
    Beans
    5

    Re: Stella in 18.04

    NB

    Sorry for just posting links and the output, where I my manners!

    Thank you for any support you can offer

  6. #6
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,270

    Re: Stella in 18.04

    I installed it to see what's up, and didn't have any problem - using Ubuntu 18.04. First time using, but I was able to easily find some game files, loaded one, and that worked fine. (I am more familiar with atari800 program - we have used that for years.)

    Did you install from the Ubuntu repository? Or something else? Possibly a different version?

    Details:

    Code:
    dmn@Roxanne:~$ apt show stella
    Package: stella
    Version: 5.1.1-1
    Priority: optional
    Section: universe/otherosfs
    Origin: Ubuntu
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Original-Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
    Bugs: https://bugs.launchpad.net/ubuntu/+filebug
    Installed-Size: 6,746 kB

  7. #7
    Join Date
    Sep 2018
    Beans
    5

    Re: Stella in 18.04

    I just ran sudo apt-get install stella

  8. #8
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,270

    Re: Stella in 18.04

    Quote Originally Posted by cx40hero View Post
    I just ran sudo apt-get install stella
    I did the same, so we have the same version.
    ERROR: Couldn't load settings file
    The settings file would most likely be ~/.config/stella/stellarc
    Do you see any problems?
    Compare my listing - check owner and permissions - can you read the file itself in a text editor?
    Code:
    dmn@Roxanne:~/.config/stella$ ls -l
    total 20
    drwxrwxr-x 2 dmn dmn 4096 Sep 13 12:45 cfg
    drwxrwxr-x 2 dmn dmn 4096 Sep 13 12:45 nvram
    drwxrwxr-x 2 dmn dmn 4096 Sep 13 13:50 state
    -rw-rw-r-- 1 dmn dmn    0 Sep 13 19:27 stella.pro
    -rw-rw-r-- 1 dmn dmn 5025 Sep 13 19:27 stellarc
    The three direcories here are empty.

    The line after the ERROR: line (about dbus) I can't analyze. That may not be important, just some system output you get when you use terminal. But I can't say for sure.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •