Results 1 to 10 of 10

Thread: How to set resume=uuid

Hybrid View

  1. #1
    Join Date
    Oct 2009
    Beans
    412

    How to set resume=uuid

    Since I had to change the HD in my Dell Dimension 1100, running 18.04, I am having a problem shown during updates as:

    Code:
    W: initramfs-tools configuration sets RESUME=UUID=6752bc85-87bd-4f55-a01d-d966557ff115W: but no matching swap device is available.
    I: The initramfs will attempt to resume from /dev/sda5
    I: (UUID=eb8347d0-623b-4b9a-95f1-da527c084617)
    I: Set the RESUME variable to override this.
    but I did set the new UUID in /etc/fstab and in /etc/initramfs-tools/conf.d/resume - is there anywhere else that I have to touch?

    Thanks

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: How to set resume=uuid

    On mine early on in Development I had changed "/etc/initramfs-tools/conf.d/resume"
    To
    Code:
    RESUME=NONE
    or you could just comment the line (by putting a # in the beginning of the line)
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  3. #3
    Join Date
    Oct 2009
    Beans
    412

    Re: How to set resume=uuid

    When I change that file, is there any activation that I have to process prior to 'update-initramfs'? Or I have to reboot?

  4. #4
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: How to set resume=uuid

    Yes, thanks for pointing that out. >>It's been a long time ago since I had done that so my old memory forgot to add that.
    Code:
    sudo update-initramfs -u
    I would still reboot also.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  5. #5
    Join Date
    Oct 2009
    Beans
    412

    Re: How to set resume=uuid

    I did comment that line in /etc/initramfs-tools/conf.d/resume and did update-initramfs -u but I'm still getting the same message - Isn't there some other file that keeps spitting out that old UUID?

  6. #6
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: How to set resume=uuid

    In going back to my old notes I keep I had tried to solve this with "/etc/default/grub" BUT that did not solve it for me.

    So I then did the steps I had already shown you in post#2

    But lets give this a whril then:
    Code:
    sudo blkid
    Now here on mine it shows for swap:
    Code:
    UUID="b007b23d-e1b5-40de-a8fb-dc2d89f83347"
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a device; this may
    # be used with UUID= as a more robust way to name devices that works even if
    # disks are added and removed. See fstab(5).
    #
    # <file system>             <mount point>  <type>  <options>  <dump>  <pass>
    UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347 swap           swap    defaults,noati$
    UUID=ed5a7d7e-281d-48d6-a50c-e9705c769a63 /              ext4    defaults,noati$
    
    /dev/disk/by-uuid/09771289047AED44 /mnt/09771289047AED44 auto nosuid,nodev,nofa$
    /dev/disk/by-uuid/25B65825105A7849 /mnt/25B65825105A7849 auto nosuid,nodev,nofa$
    /dev/disk/by-id/usb-SanDisk_Ultra_4C530001050423123075-0:0-part2 /mnt/usb-SanDi$
    So just now to be sure it works here at least:
    Code:
    sudoedit /etc/fstab
    Save and close.
    Now add your UUID>>>>and again here:
    Code:
    sudoedit /etc/initramfs-tools/conf.d/resume
    Save and close.>>And for good measure run:
    Code:
    sudo update-initramfs -u -k all
    Fingers Crossed
    Last edited by 1fallen; September 12th, 2018 at 11:44 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  7. #7
    Join Date
    Oct 2009
    Beans
    412

    Re: How to set resume=uuid

    Yeah, I had all this done - /etc/fstab as well as /etc/initramfs-tools/conf.d/resume have the correct UUID and I did 'sudo initramfs-update -u -k all' but it keeps giving the same message. I was wondering, is it necessary to run 'mkswap /dev/sda5' besides the editing on the files above?
    Last edited by danielsender; September 13th, 2018 at 02:25 AM.

  8. #8
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: How to set resume=uuid

    The only way for me to see the warning on my end is to remove the file in "/etc/initramfs-tools/conf.d/resume"
    As seen:

    Code:
     sudo update-initramfs -u -k all
    [sudo] password for me: 
    update-initramfs: Generating /boot/initrd.img-4.18.5-041805-lowlatency
    I: The initramfs will attempt to resume from /dev/sda2
    I: (UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347)
    I: Set the RESUME variable to override this.
    update-initramfs: Generating /boot/initrd.img-4.15.0-34-generic
    I: The initramfs will attempt to resume from /dev/sda2
    I: (UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347)
    I: Set the RESUME variable to override this.
    update-initramfs: Generating /boot/initrd.img-4.15.0-31-generic
    I: The initramfs will attempt to resume from /dev/sda2
    I: (UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347)
    I: Set the RESUME variable to override this.
    update-initramfs: Generating /boot/initrd.img-4.15.0-29-generic
    I: The initramfs will attempt to resume from /dev/sda2
    I: (UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347)
    I: Set the RESUME variable to override this.
    update-initramfs: Generating /boot/initrd.img-4.15.0-26-generic
    I: The initramfs will attempt to resume from /dev/sda2
    I: (UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347)
    I: Set the RESUME variable to override this.
    Now after i recreate the file "/etc/initramfs-tools/conf.d/resume":
    Code:
     sudo update-initramfs -u -k all
    update-initramfs: Generating /boot/initrd.img-4.18.5-041805-lowlatency
    update-initramfs: Generating /boot/initrd.img-4.15.0-34-generic
    update-initramfs: Generating /boot/initrd.img-4.15.0-31-generic
    update-initramfs: Generating /boot/initrd.img-4.15.0-29-generic
    update-initramfs: Generating /boot/initrd.img-4.15.0-26-generic
    All is good.
    Now if I change to "RESUME=NONE"
    Code:
    sudo update-initramfs -u -k all
    update-initramfs: Generating /boot/initrd.img-4.18.5-041805-lowlatency
    W: initramfs-tools configuration sets RESUME=NONE
    W: but no matching swap device is available.
    update-initramfs: Generating /boot/initrd.img-4.15.0-34-generic
    W: initramfs-tools configuration sets RESUME=NONE
    W: but no matching swap device is available.
    update-initramfs: Generating /boot/initrd.img-4.15.0-31-generic
    W: initramfs-tools configuration sets RESUME=NONE
    W: but no matching swap device is available.
    update-initramfs: Generating /boot/initrd.img-4.15.0-29-generic
    W: initramfs-tools configuration sets RESUME=NONE
    W: but no matching swap device is available.
    update-initramfs: Generating /boot/initrd.img-4.15.0-26-generic
    W: initramfs-tools configuration sets RESUME=NONE
    W: but no matching swap device is available.
    But when I add the UUID like:
    Code:
    RESUME=UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347
    I now show:
    Code:
     sudo update-initramfs -u -k all
    update-initramfs: Generating /boot/initrd.img-4.18.5-041805-lowlatency
    update-initramfs: Generating /boot/initrd.img-4.15.0-34-generic
    update-initramfs: Generating /boot/initrd.img-4.15.0-31-generic
    update-initramfs: Generating /boot/initrd.img-4.15.0-29-generic
    update-initramfs: Generating /boot/initrd.img-4.15.0-26-generic
    Maybe check for typeo's in both "etc/fstab" and in "etc/initramfs-tools/conf.d/resume"
    I'll post mine just for reference only: "etc/fstab"
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/sdb2 during installation
    UUID=b66538cb-b17b-4e11-b2eb-e7c049d2f762 /               ext4    errors=remount-ro 0       1
    # swap was on /dev/sda2 during installation
    UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347 none            swap    sw              0       0
    Now "/etc/initramfs-tools/conf.d/resume"
    Code:
    RESUME=UUID=b007b23d-e1b5-40de-a8fb-dc2d89f83347
    Last edited by 1fallen; September 13th, 2018 at 02:09 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  9. #9
    Join Date
    Oct 2009
    Beans
    412

    Re: How to set resume=uuid

    I found what the problem was: generally whenever I modified some parameter(s) in a configuration file and just for my records, I create another file with the extension "orig", so in this case I placed in the same folder (/etc/initramfs-tools/conf.d) a file called resume.orig with the old UUID. Apparently, the program update-initramfs does not look at the exact name of the file but reads whatever is in that folder or to any file that starts with the characters "resume", so it kept reading the old file even though it wasn't called "resume". So I just removed resume.orig and the problem went away.

    Thank you very much for your time and effort.

    Daniel
    Last edited by danielsender; September 13th, 2018 at 06:29 PM.

  10. #10
    Join Date
    Jul 2019
    Beans
    1

    Re: How to set resume=uuid

    Thank You!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •