Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: RTL8723BE & kernel 4.15.0-33

  1. #1
    Join Date
    Dec 2011
    Beans
    17

    RTL8723BE & kernel 4.15.0-33

    Hello guys,

    Wondering if anyone with the same issue around here.

    I'm a very unhappy owner of the above wifi chipset (RTL8723BE). On my laptop it has never worked out of the box, but I've learnt what it likes and it's been doing fine with the ant_sel parameter set to 2.

    It's been working right up until the last update to kernel 4.15.0-33. Now its behaving like it would with a wrong ant_sel value, but no matter what i set this parameter to the wifi signal is very weak. Seems like it's ignoring my configuration. I will post a few show commands in a second.
    I'm on kubuntu 18.04.1

    edit: here comes some info about the wifi

    uname -a
    Linux sf71h 4.15.0-33-generic #36-Ubuntu SMP Wed Aug 15 16:00:05 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


    lspci -knn | grep Net -A3
    03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:81c1]
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be




    lshw -class network
    *-network
    description: Wireless interface
    product: RTL8723BE PCIe Wireless Network Adapter
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlo1
    version: 00
    serial: 3c:a0:67:67:2e:89
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=rtl8723be driverversion=4.15.0-33-generic firmware=N/A latency=0 link=yes multicast=yes wireless=IEEE 802.11
    resources: irq:17 ioport:3000(size=256) memory:c1100000-c1103fff



    ifconfig
    wlo1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 3c:a0:67:67:2e:89 txqueuelen 1000 (Ethernet)
    RX packets 32 bytes 4760 (4.7 KB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 92 bytes 17816 (17.8 KB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    iwconfig
    wlo1 IEEE 802.11 ESSIDff/any
    Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
    Retry short limit:7 RTS thr=2347 B Fragment thrff
    Power Managementn


    modinfo
    filename: /lib/modules/4.15.0-33-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko
    firmware: rtlwifi/rtl8723befw_36.bin
    firmware: rtlwifi/rtl8723befw.bin
    description: Realtek 8723BE 802.11n PCI wireless
    license: GPL
    author: Realtek WlanFAE <wlanfae@realtek.com>
    author: PageHe <page_he@realsil.com.cn>
    srcversion: 4460AA5584590927164B1F2
    alias: pci:v000010ECd0000B723sv*sd*bc*sc*i*
    depends: rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
    retpoline: Y
    intree: Y
    name: rtl8723be
    vermagic: 4.15.0-33-generic SMP mod_unload
    signat: PKCS#7
    signer:
    sig_key:
    sig_hashalgo: md4
    parm: swenc:Set to 1 for software crypto (default 0)
    (bool)
    parm: ips:Set to 0 to not use link power save (default 1)
    (bool)
    parm: swlps:Set to 1 to use SW control power save (default 0)
    (bool)
    parm: fwlps:Set to 1 to use FW control power save (default 1)
    (bool)
    parm: msi:Set to 1 to use MSI interrupts mode (default 0)
    (bool)
    parm: aspm:Set to 1 to enable ASPM (default 1)
    (int)
    parm: debug_level:Set debug level (0-5) (default 0) (int)
    parm: debug_mask:Set debug mask (default 0) (ullong)
    parm: disable_watchdog:Set to 1 to disable the watchdog (default 0)
    (bool)
    parm: ant_sel:Set to 1 or 2 to force antenna number (default 0)
    (int)

    dmesg | grep rtl8723be
    [ 33.260643] rtl8723be: Using firmware rtlwifi/rtl8723befw_36.bin
    [ 33.419742] rtl8723be 0000:03:00.0 wlo1: renamed from wlan0
    Rolling back to previous kernel 4.15.0-32 returns correct functionality.

    Thank you.
    Last edited by PippoPalmieri; August 23rd, 2018 at 09:24 PM. Reason: added wifi info

  2. #2
    Join Date
    May 2014
    Location
    /home
    Beans
    6,766
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: RTL8723BE & kernel 4.15.0-33

    In kernel 4.15.0-33, delete the conf file from /etc/modprobe.d where you set the parameter, likely ant_sel=2, then lets test the other options
    Code:
    sudo modprobe -r rtl8723be
    sudo modprobe rtl8723be ant_sel=0
    iwlist scan | egrep -i 'ssid|quality'
    sudo modprobe -r rtl8723be
    sudo modprobe rtl8723be ant_sel=1
    iwlist scan | egrep -i 'ssid|quality'
    sudo modprobe -r rtl8723be
    sudo modprobe rtl8723be ant_sel=2
    iwlist scan | egrep -i 'ssid|quality'
    Post results

  3. #3
    Join Date
    Dec 2011
    Beans
    17

    Re: RTL8723BE & kernel 4.15.0-33

    Thank you for your help!

    Here's the output.
    I have removed the modprobe.d conf file before running the commands as asked.

    cj@sf71h:~$ sudo modprobe -r rtl8723be
    cj@sf71h:~$ sudo modprobe rtl8723be ant_sel=0
    cj@sf71h:~$ iwlist scan | egrep -i 'ssid|quality'
    vmnet1 Interface doesn't support scanning.

    vmnet8 Interface doesn't support scanning.

    virbr0-nic Interface doesn't support scanning.

    enp2s0 Interface doesn't support scanning.

    lo Interface doesn't support scanning.

    virbr0 Interface doesn't support scanning.

    Quality=34/70 Signal level=-76 dBm
    ESSID:"WiFi_2.4"



    cj@sf71h:~$ sudo modprobe -r rtl8723be
    cj@sf71h:~$ sudo modprobe rtl8723be ant_sel=1
    cj@sf71h:~$ iwlist scan | egrep -i 'ssid|quality'
    vmnet1 Interface doesn't support scanning.

    vmnet8 Interface doesn't support scanning.

    virbr0-nic Interface doesn't support scanning.

    enp2s0 Interface doesn't support scanning.

    lo Interface doesn't support scanning.

    virbr0 Interface doesn't support scanning.

    Quality=34/70 Signal level=-76 dBm
    ESSID:"WiFi_2.4"




    cj@sf71h:~$ sudo modprobe -r rtl8723be
    cj@sf71h:~$ sudo modprobe rtl8723be ant_sel=2
    cj@sf71h:~$ iwlist scan | egrep -i 'ssid|quality'
    vmnet1 Interface doesn't support scanning.

    vmnet8 Interface doesn't support scanning.

    virbr0-nic Interface doesn't support scanning.

    enp2s0 Interface doesn't support scanning.

    lo Interface doesn't support scanning.

    virbr0 Interface doesn't support scanning.

    Quality=26/70 Signal level=-84 dBm
    ESSID:"WiFi_2.4"
    It would seem that ant_sel 2 yields even worse results than 0 or 1 now.
    Last edited by PippoPalmieri; August 23rd, 2018 at 10:06 PM.

  4. #4
    Join Date
    May 2014
    Location
    /home
    Beans
    6,766
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: RTL8723BE & kernel 4.15.0-33

    Not the results I was expecting as I expected ant_se; set to 0 or 1 to be a much higher signal strength

  5. #5
    Join Date
    Dec 2011
    Beans
    17

    Re: RTL8723BE & kernel 4.15.0-33

    I will try posting somewhere else too to get a few more eyeballs on this. I will report if I find something.
    I would think it's an issue with the latest kernel.

    edit: after some googling i found the following

    https://bugzilla.kernel.org/show_bug.cgi?id=83641#c23

    also plenty of results googling rtl8723be with kernel 4.16, I think the problem looks the same
    Last edited by PippoPalmieri; August 24th, 2018 at 08:59 AM.

  6. #6
    Join Date
    Aug 2018
    Beans
    3

    Re: RTL8723BE & kernel 4.15.0-33

    I'm having the same problem here - everything was just fine on 4.15.0-32, no wireless networks visible on 4.15.0-33, and the ant-sel trick doesn't change it. Cold boot makes no difference in -33, booting back to -32 works instantly.
    RTL4723BE on an HP 24-g080 all-in-one, showing fine in lspci in -33.

    Originally building the machine needed the ant-sel to get anything but the very weakest of signal. Now, there's just zero.

    The "pending patch" (from March...?) at https://bugzilla.kernel.org/show_bug.cgi?id=83641#c9 patches rt8723be/hw.c - but where am I looking for that? The only thing in /lib/modules/4.15.0-33-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/ is rtl8723be.ko and that's non-text.

  7. #7
    Join Date
    Dec 2011
    Beans
    17

    Re: RTL8723BE & kernel 4.15.0-33

    Quote Originally Posted by adrian-z View Post
    but where am I looking for that? The only thing in /lib/modules/4.15.0-33-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/ is rtl8723be.ko and that's non-text.
    I believe they're talking about what you'll find in the kernel source. So if you want to use 4.15.0-33 it would be about downloading the source, patching the modules and recompiling I think.
    Also,before doing that, it's worth a shot trying to use the module provided here https://github.com/lwfinger/rtlwifi_new
    If that has the same commit it might work.

    But anyway, I found a very good explanation of the issue here (that also explains why bluetooth has been working like crap):
    https://git.kernel.org/pub/scm/linux...49a90a87dc5081

    Anyway, I am using the old kernel until my workaround arrives, an intel wifi chipset...
    Last edited by PippoPalmieri; August 24th, 2018 at 12:49 PM.

  8. #8
    Join Date
    Aug 2018
    Beans
    3

    Re: RTL8723BE & kernel 4.15.0-33

    Quote Originally Posted by PippoPalmieri View Post
    Also,before doing that, it's worth a shot trying to use the module provided here https://github.com/lwfinger/rtlwifi_new
    If that has the same commit it might work.
    Goes fine right up until the modprobe line to install - "required key not available".

    Anyway, I am using the old kernel until my workaround arrives, an intel wifi chipset...
    Now, there's a thought... <reaches for TPLink USB adapter>
    <edit> That works, but a poor signal...
    Last edited by adrian-z; August 24th, 2018 at 02:12 PM.

  9. #9
    Join Date
    Dec 2011
    Beans
    17

    Re: RTL8723BE & kernel 4.15.0-33

    Quote Originally Posted by adrian-z View Post
    Goes fine right up until the modprobe line to install - "required key not available".

    Try disabling secure boot from bios.

  10. #10
    Join Date
    Aug 2018
    Beans
    3

    Re: RTL8723BE & kernel 4.15.0-33

    Quote Originally Posted by PippoPalmieri View Post
    Try disabling secure boot from bios.
    <slaps forehead> Of course.

    Disable secure boot, into -33, and the Realtek WiFi is working straight off. Thanks, guys!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •