Results 1 to 3 of 3

Thread: No unity-greeter on startup

  1. #1
    Join Date
    Aug 2018
    Beans
    1

    No unity-greeter on startup

    So recently I've been messing around with different desktops. (I'm on ubuntu 18.04)

    I tried out xfce (xubuntu) and decided to switch to unity rather.

    I now have Unity working as it should except for one thing: the start-up login page still uses the xfce style.
    When I lock my pc, it still uses the unity style as it should.

    I've tried purging all xubuntu related files, but no luck.

    I'm pretty new to this sort of thing, so any help is appreciated.

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: No unity-greeter on startup

    First you will need to clean up and disable the old settings via:
    Code:
    sudo mv /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf.disabled
    Reinstall unity-greeter to remove any changes in /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml
    Code:
    sudo apt install --reinstall unity-greeter


    NOTE:To enable it back>> "only if needed".(This will restore what it was like before)
    Code:
    sudo mv /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf.disabled /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
    Restarting the lightdm is needed
    Code:
    sudo systemctl restart lightdm
    Check to see if there any other dconf overrides file that take priority
    Code:
    grep -rn -e "com.canonical.unity-greeter" -e "background=" -e "draw-user-backgrounds=" /usr/share/glib-2.0/schemas/
    Last edited by 1fallen; August 5th, 2018 at 04:58 PM. Reason: make clear
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  3. #3
    Join Date
    Mar 2017
    Location
    Gubertino
    Beans
    1,018
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: No unity-greeter on startup

    You can also switch to the unity greeter by creating your own overriding conf file.
    Firstly make sure unity-greeter is installed...
    Code:
    sudo apt install unity-greeter
    Create your custom config...
    Code:
    echo -e "[Seat:*]\nuser-session=unity\ngreeter-session=unity-greeter" | sudo tee /etc/lightdm/lightdm.conf.d/99-my-settings.conf
    Creates this config. Attachment 280657
    Reboot.


    If you want to revert changes simply remove the custom config...
    Code:
    sudo rm /etc/lightdm/lightdm.conf.d/99-my-settings.conf
    Last edited by guber2; August 6th, 2018 at 04:09 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •