Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Xorg? 'startx' session problem

  1. #21
    Join Date
    Apr 2008
    Location
    Southern California, USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Xorg? 'startx' session problem

    What is the mount point:
    Code:
    lip 04 22:23:16 ubuntu udisksd[659]: mountpoint /media/zolo/AL-X86_64 is invalid, cannot recover the canonical path Cleaning up mount point /media/zolo/AL-X86_64 (device 11:0 is not mounted)
    mountpoint /media/zolo/5A30-B09C is invalid, cannot recover the canonical path 
    Cleaning up mount point /media/zolo/5A30-B09C (device 8:49 is not mounted)
    Also something amiss here
    Code:
    ** (process:1734): WARNING **: 18:09:13.815: xdg-autostart.vala:125: Error: Error opening directory ?/home/zolo/.config/autostart?: No such file or directory
    ** Message: 18:09:13.815: xdg-autostart.vala:39: Processing /etc/xdg/autostart/nvidia-settings-autostart.desktop file.
    ** Message: 18:09:13.816: xdg-autostart.vala:94: Launching: sh -c '/usr/bin/nvidia-settings --load-config-only' (nvidia-settings-autostart.desktop)
    ** Message: 18:09:13.816: xdg-autostart.vala:39: Processing /etc/xdg/autostart/gnome-keyring-ssh.desktop file.
    ** Message: 18:09:13.816: xdg-autostart.vala:64: Not found in OnlyShowIn list, aborting.
    ** Message: 18:09:13.816: xdg-autostart.vala:39: Processing /etc/xdg/autostart/xdg-user-dirs.desktop file.
    ** Message: 18:09:13.816: xdg-autostart.vala:94: Launching: xdg-user-dirs-update (xdg-user-dirs.desktop)
    ** Message: 18:09:13.816: xdg-autostart.vala:39: Processing /etc/xdg/autostart/gnome-keyring-pkcs11.desktop file.
    ** Message: 18:09:13.816: xdg-autostart.vala:64: Not found in OnlyShowIn list, aborting.
    ** Message: 18:09:13.816: xdg-autostart.vala:39: Processing /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop file.
    ** Message: 18:09:13.816: xdg-autostart.vala:64: Not found in OnlyShowIn list, aborting.
    ** Message: 18:09:13.816: xdg-autostart.vala:39: Processing /etc/xdg/autostart/pulseaudio.desktop file.
    ** Message: 18:09:13.820: xdg-autostart.vala:94: Launching: start-pulseaudio-x11 (pulseaudio.desktop)
    ** Message: 18:09:13.820: xdg-autostart.vala:39: Processing /etc/xdg/autostart/xfsettingsd.desktop file.
    ** Message: 18:09:13.820: xdg-autostart.vala:64: Not found in OnlyShowIn list, aborting.
    ** Message: 18:09:13.820: xdg-autostart.vala:39: Processing /etc/xdg/autostart/gnome-keyring-secrets.desktop file.
    ** Message: 18:09:13.820: xdg-autostart.vala:64: Not found in OnlyShowIn list, aborting.
    ** Message: 18:09:13.820: xdg-autostart.vala:39: Processing /etc/xdg/autostart/at-spi-dbus-bus.desktop file.
    ** Message: 18:09:13.820: xdg-autostart.vala:94: Launching: /usr/lib/at-spi2-core/at-spi-bus-launcher --launch-immediately (at-spi-dbus-bus.desktop)
    ** Message: 18:09:13.825: x-terminal-emulator has very limited support, consider choose another terminal
    Failed to connect to session manager: Nie udało się połączyć z menadżerem sesji: SESSION_MANAGER environment variable not defined
    Try booting with "quiet splash" remove from linux line, and look for error messages.
    Then if unsuccessful add "nomodeset" to end of linux, and see if you can then boot.

  2. #22
    Join Date
    Jul 2018
    Beans
    18

    Re: Xorg? 'startx' session problem

    Code:
    sudo apt install haveged
    sudo systemctl enable haveged
    It looks like you're having the same problem as I posted here: https://ubuntuforums.org/showthread....0#post13781140

    It's a bug in the recent 4.15.0-24 kernel. It should be fixed soon, I hope, but in the meantime, installing and enabling haveged as shown above should resolve the issue.

    Good luck.

  3. #23
    Join Date
    Jul 2018
    Beans
    9

    Re: Xorg? 'startx' session problem

    Sorry Guys for late response but all day yesterday I spent in hospital in orthognathic surgery department - really nightmare.
    Despite presently the kernel I use is : 4.17.4-041704-generic
    The solution advised by apeitheo2 solved the problem. System starts strightaway.
    I must admit that on the same beginning I mindlessly upgraded the kernel and nvidia-driver because I prefer LTS setting. So now I will do a fresh install and will keep LTS settings.

    There is a great experience to use Ubuntu especially because - ITS COMMUNITY - the strongest advantage this distro.

    It is good to know that I can build great system based on Ubuntu and if something goes wrong I will obtain a help.

    That is why MANY THANKS FOR ALL OF YOU, FOR YOUR TIME AND HELP.
    Best regards
    yarooch

  4. #24
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,647
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Xorg? 'startx' session problem

    yarooh - Great !

    Pleased there is resolution . Glad that you followed through and provided the confirmation.

    - just keep on keep'n on -
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •