Results 1 to 3 of 3

Thread: E: Sub-process /usr/bin/dpkg returned an error code (1)

  1. #1
    Join Date
    Jul 2018
    Beans
    1

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Hello,

    I am testing out Zentyal 5.1 commercial version, but when I install packages (DC, DNS, DHCP) I get the following error code Sub-process /usr/bin/dpkg returned an error code (1).

    I will post an output of sudo dpkg --configure -a

    Code:
    Setting up zentyal-firewall (5.1) ...
    
    
    service zentyal_webadmin does not exist.dpkg:error processing package zentyal-firewall (--configure):
     
    subprocess installed post-installation script returned error exit status 1
    
    
    
    
    dpkg: dependency problems prevent configuration of zentyal-dhcp:
     
    zentyal-dhcp depends on zentyal-firewall; however:
      
    Package zentyal-firewall is not configured yet.
    
    
    
    
    
    
    dpkg: error processing package zentyal-dhcp (--configure):
     
    dependency problems - leaving unconfigured
    
    
    dpkg: dependency problems prevent configuration of zentyal-ntp:
     
    zentyal-ntp depends on zentyal-firewall; however:
      
    Package zentyal-firewall is not configured yet.
    
    
    
    
    
    
    dpkg: error processing package zentyal-ntp (--configure):
     
    dependency problems - leaving unconfigured
    
    
    dpkg: dependency problems prevent configuration of zentyal-samba:
     
    zentyal-samba depends on zentyal-firewall; however:
      
    Package zentyal-firewall is not configured yet.
     
    zentyal-samba depends on zentyal-ntp; however:
      
    Package zentyal-ntp is not configured yet.
    
    
    
    
    
    
    dpkg: error processing package zentyal-samba (--configure):
     
    dependency problems - leaving unconfigured
    
    
    dpkg: dependency problems prevent configuration of zentyal-dns:
     
    zentyal-dns depends on zentyal-firewall; however:
      
    Package zentyal-firewall is not configured yet.
    
    
    
    
    
    
    dpkg: error processing package zentyal-dns (--configure):
     
    dependency problems - leaving unconfigured
    
    
    dpkg: dependency problems prevent configuration of zentyal-mail:
     
    zentyal-mail depends on zentyal-samba; however:
      
    Package zentyal-samba is not configured yet.
    
    
    
    
    
    
    dpkg: error processing package zentyal-mail (--configure):
     
    dependency problems - leaving unconfigured
    
    
    dpkg: dependency problems prevent configuration of zentyal-openvpn:
     
    zentyal-openvpn depends on zentyal-firewall; however:
      
    Package zentyal-firewall is not configured yet.
    
    
    
    
    
    
    dpkg: error processing package zentyal-openvpn (--configure):
     
    dependency problems - leaving unconfigured
    
    
    dpkg: dependency problems prevent configuration of zentyal-groupware:
     
    zentyal-groupware depends on zentyal-mail; however:
      
    Package zentyal-mail is not configured yet.
    
    
    
    
    
    
    dpkg: error processing package zentyal-groupware (--configure):
     
    dependency problems - leaving unconfigured
    
    
    dpkg: dependency problems prevent configuration of zentyal-sogo:
     
    zentyal-sogo depends on zentyal-mail; however:
      
    Package zentyal-mail is not configured yet.
    
    
    
    
    
    
    dpkg: error processing package zentyal-sogo (--configure):
     
    dependency problems - leaving unconfigured
    
    
    Errors were encountered while processing:
     
    zentyal-firewall
     zentyal-dhcp
     zentyal-ntp
     zentyal-samba
     zentyal-dns
     zentyal-mail
     
    zentyal-openvpn
     zentyal-groupware
     zentyal-sogo
    


    Tried configuring the firewall, still smae error. Need help thank you.


  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Is the system fully up-to date?
    Code:
    sudo apt update
    sudo apt full-upgrade
    Do those work without any errors? You may need to reboot after the 2nd cmd, but only if it completes without errors and creates a file called /var/run/reboot-needed

    If that is all working, then we can try an tackle other issues.

  3. #3
    Join Date
    Oct 2017
    Location
    City of Waterfalls-Ph
    Beans
    157
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Bump
    corn ubuntuforums community.
    Open Source platform where the real world of human is here. Click here for Solve thread
    Rock n' Roll People.
    From: mike_08

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •