Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

  1. #1
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    I have the GT 710 nvidia gigabyte card.

    Code:
    ~$  lspci -nnk | grep -iA3 vga
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:128b] (rev a1)
    	Subsystem: NVIDIA Corporation Device [10de:128b]
    	Kernel driver in use: nvidia
    	Kernel modules: nvidiafb, nouveau, nvidia_384_drm, nvidia_384
    I've installed the 384.130 (recommended) nvidia drivers but it only loads the cpu graphics (very low).
    No other nvidia drivers.

    Code:
    ~$ dpkg -l | grep -i nvidia
    ii  bbswitch-dkms                               0.8-3ubuntu1                                 amd64        Interface for toggling the power on NVIDIA Optimus video cards
    ii  libcuda1-384                                384.130-0ubuntu0.16.04.1                     amd64        NVIDIA CUDA runtime library
    ii  nvidia-384                                  384.130-0ubuntu0.16.04.1                     amd64        NVIDIA binary driver - version 384.130
    ii  nvidia-opencl-icd-384                       384.130-0ubuntu0.16.04.1                     amd64        NVIDIA OpenCL ICD
    ii  nvidia-prime                                0.8.2                                        amd64        Tools to enable NVIDIA's Prime
    ii  nvidia-settings                             361.42-0ubuntu1                              amd64        Tool for configuring the NVIDIA graphics driver
    MotherBoard is UEFI but I disabled it leaving only legacy (after the problem ofc) and secure boot is disabled.

    Code:
    ~$ sudo lshw -C display
      *-display               
           description: VGA compatible controller
           product: NVIDIA Corporation
           vendor: NVIDIA Corporation
           physical id: 0
           bus info: pci@0000:01:00.0
           version: a1
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
           configuration: driver=nvidia latency=0
           resources: irq:26 memory:f6000000-f6ffffff memory:e8000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff
    Code:
    cat /var/log/gpu-manager.log
    log_file: /var/log/gpu-manager.log
    last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
    new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
    can't access /run/u-d-c-fglrx-was-loaded file
    Looking for fglrx modules in /lib/modules/4.13.0-45-generic/updates/dkms
    Looking for nvidia modules in /lib/modules/4.13.0-45-generic/updates/dkms
    Found nvidia module: nvidia_384_modeset.ko
    Is nvidia loaded? yes
    Was nvidia unloaded? no
    Is nvidia blacklisted? no
    Is fglrx loaded? no
    Was fglrx unloaded? no
    Is fglrx blacklisted? no
    Is intel loaded? no
    Is radeon loaded? no
    Is radeon blacklisted? no
    Is amdgpu loaded? no
    Is amdgpu blacklisted? no
    Is nouveau loaded? no
    Is nouveau blacklisted? yes
    Is fglrx kernel module available? no
    Is nvidia kernel module available? yes
    Vendor/Device Id: 10de:128b
    BusID "PCI:1@0:0:0"
    Is boot vga? yes
    Skipping "/dev/dri/card0", driven by "nvidia-drm"
    Skipping "/dev/dri/card0", driven by "nvidia-drm"
    Skipping "/dev/dri/card0", driven by "nvidia-drm"
    Skipping "/dev/dri/card0", driven by "nvidia-drm"
    Does it require offloading? no
    last cards number = 1
    Has amd? no
    Has intel? no
    Has nvidia? yes
    How many cards? 1
    Has the system changed? No
    main_arch_path x86_64-linux-gnu, other_arch_path i386-linux-gnu
    Current alternative: /usr/lib/nvidia-384/ld.so.conf
    Current core alternative: (null)
    Current egl alternative: /usr/lib/nvidia-384/ld.so.conf
    Is nvidia enabled? yes
    Is nvidia egl enabled? yes
    Is fglrx enabled? no
    Is mesa enabled? no
    Is mesa egl enabled? no
    Is pxpress enabled? no
    Is prime enabled? no
    Is prime egl enabled? no
    Is nvidia available? yes
    Is nvidia egl available? no
    Is fglrx available? no
    Is fglrx-core available? no
    Is mesa available? yes
    Is mesa egl available? yes
    Is pxpress available? no
    Is prime available? yes
    Is prime egl available? no
    Single card detected
    Driver is already loaded and enabled
    Nothing to do
    No change - nothing to do
    Code:
    ~$ cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/sda1 during installation
    UUID=74193c2c-b4d5-4ca6-8393-bfab275446d0 /               ext4    errors=remount-ro 0       1
    # swap was on /dev/sda5 during installation
    UUID=d2c39301-5321-4c89-82ad-4d3ac8930fc0 none            swap    sw              0       0
    Code:
    ~$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
    BIOS
    Code:
    ~$ sudo find / -name "NVIDIA-Linux-*"
    find: ‘/run/user/1000/gvfs’: Permission denied
    ???

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    these boards can be problematic at times.
    can we see the output of:
    Code:
    sudo dpkg -l | grep linux-
    And this also please:
    Code:
    uname -r
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  3. #3
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    Code:
    sudo dpkg -l | grep linux-
    Code:
    ii  linux-base                                  4.5ubuntu1~16.04.1                           all          Linux image base package
    ii  linux-firmware                              1.157.19                                     all          Firmware for Linux kernel drivers
    ii  linux-generic                               4.4.0.128.134                                amd64        Complete Generic Linux kernel and headers
    ii  linux-generic-hwe-16.04                     4.13.0.45.64                                 amd64        Complete Generic Linux kernel and headers
    ii  linux-headers-4.13.0-36                     4.13.0-36.40~16.04.1                         all          Header files related to Linux kernel version 4.13.0
    ii  linux-headers-4.13.0-36-generic             4.13.0-36.40~16.04.1                         amd64        Linux kernel headers for version 4.13.0 on 64 bit x86 SMP
    ii  linux-headers-4.13.0-45                     4.13.0-45.50~16.04.1                         all          Header files related to Linux kernel version 4.13.0
    ii  linux-headers-4.13.0-45-generic             4.13.0-45.50~16.04.1                         amd64        Linux kernel headers for version 4.13.0 on 64 bit x86 SMP
    ii  linux-headers-4.4.0-128                     4.4.0-128.154                                all          Header files related to Linux kernel version 4.4.0
    ii  linux-headers-4.4.0-128-generic             4.4.0-128.154                                amd64        Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
    ii  linux-headers-generic                       4.4.0.128.134                                amd64        Generic Linux kernel headers
    ii  linux-headers-generic-hwe-16.04             4.13.0.45.64                                 amd64        Generic Linux kernel headers
    ii  linux-image-4.13.0-36-generic               4.13.0-36.40~16.04.1                         amd64        Linux kernel image for version 4.13.0 on 64 bit x86 SMP
    ii  linux-image-4.13.0-45-generic               4.13.0-45.50~16.04.1                         amd64        Linux kernel image for version 4.13.0 on 64 bit x86 SMP
    ii  linux-image-4.4.0-128-generic               4.4.0-128.154                                amd64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
    ii  linux-image-extra-4.13.0-36-generic         4.13.0-36.40~16.04.1                         amd64        Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP
    ii  linux-image-extra-4.13.0-45-generic         4.13.0-45.50~16.04.1                         amd64        Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP
    ii  linux-image-extra-4.4.0-128-generic         4.4.0-128.154                                amd64        Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
    ii  linux-image-generic                         4.4.0.128.134                                amd64        Generic Linux kernel image
    ii  linux-image-generic-hwe-16.04               4.13.0.45.64                                 amd64        Generic Linux kernel image
    ii  linux-libc-dev:amd64                        4.4.0-128.154                                amd64        Linux Kernel Headers for development
    ii  linux-sound-base                            1.0.25+dfsg-0ubuntu5                         all          base package for ALSA and OSS sound systems
    ii  syslinux-common                             3:6.03+dfsg-11ubuntu1                        all          collection of bootloaders (common)
    ii  syslinux-legacy                             2:3.63+dfsg-2ubuntu8                         amd64        Bootloader for Linux/i386 using MS-DOS floppies
    Code:
    uname -r
    Code:
    4.13.0-45-generic

  4. #4
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    Great thanks. All looks good there.
    the drivers from an added ppa seem to help in this case.
    Code:
    sudo add-apt-repository ppa:graphics-drivers/ppa
    followed with:
    Code:
    sudo apt update && sudo apt full-upgrade
    and
    Code:
    sudo apt install nvidia-384
    and reboot to load any new changes made. and fingers crossed.
    EDIT:I should mention to revert any changes with any added PPA (If needed) use ppa-purge via:
    install with:
    Code:
    sudo apt-get install ppa-purge
    in our case here clean up with:
    Code:
    sudo apt-add-repository --remove ppa:graphics-drivers/ppa
    And Substitute "ppa:graphics-drivers/ppa" with the correct named PPA
    Last edited by 1fallen; June 25th, 2018 at 04:51 PM. Reason: Added a revert to help
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  5. #5
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    No, didn't do the trick. But now i can choose from the 390 and 396 too. Coming from the 18.04 version distro (seeking more stability) my experience tells me they are the same for my graphics card.
    Last edited by dias19; June 25th, 2018 at 06:01 PM.

  6. #6
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    Quote Originally Posted by dias19 View Post
    No, didn't do the trick.
    Hmm?
    What dose this show:
    Code:
    apt policy nvidia-384
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  7. #7
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    Code:
    ~$ apt policy nvidia-384
    nvidia-384:
      Installed: 384.130-0ubuntu0.16.04.1
      Candidate: 384.130-0ubuntu0.16.04.1
      Version table:
     *** 384.130-0ubuntu0.16.04.1 500
            500 http://gr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
            500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
            100 /var/lib/dpkg/status
         384.130-0ubuntu0~gpu16.04.1 500
            500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial/main amd64 Packages
    Should I try the 390/396? I'm open to any kind of suggestions.
    Last edited by dias19; June 25th, 2018 at 06:12 PM.

  8. #8
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    Ah ok the driver did not install over the oringal driver.
    Lets start clean:
    Code:
    sudo apt remove --purge nvidia*
    and then:
    Code:
    sudo apt autoremove
    and reinstall
    Code:
    sudo apt install nvidia-384 nvidia-settings
    and again reboot.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  9. #9
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    Code:
    dpkg -l | grep -i nvidia
    ii  bbswitch-dkms                               0.8-3ubuntu1                                 amd64        Interface for toggling the power on NVIDIA Optimus video cards
    ii  libcuda1-384                                384.130-0ubuntu0.16.04.1                     amd64        NVIDIA CUDA runtime library
    ii  nvidia-384                                  384.130-0ubuntu0.16.04.1                     amd64        NVIDIA binary driver - version 384.130
    ii  nvidia-opencl-icd-384                       384.130-0ubuntu0.16.04.1                     amd64        NVIDIA OpenCL ICD
    ii  nvidia-prime                                0.8.2                                        amd64        Tools to enable NVIDIA's Prime
    ii  nvidia-settings                             396.24-0ubuntu0~gpu16.04.1                   amd64        Tool for configuring the NVIDIA graphics driver
    Code:
    $ apt policy nvidia-384
    nvidia-384:
      Installed: 384.130-0ubuntu0.16.04.1
      Candidate: 384.130-0ubuntu0.16.04.1
      Version table:
     *** 384.130-0ubuntu0.16.04.1 500
            500 http://gr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
            500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
            100 /var/lib/dpkg/status
         384.130-0ubuntu0~gpu16.04.1 500
            500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial/main amd64 Packages
    Didn't work.

  10. #10
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: (16.04LTS) GT 710 Nvidia Graphics card - drivers problem

    This happens some times
    This troubles me though:
    Mine:
    Code:
    dpkg -l | grep -i nvidia
    ii  libnvidia-cfg1-390:amd64              390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA binary OpenGL/GLX configuration library
    ii  libnvidia-common-390                  390.67-0ubuntu0~gpu18.04.1                      all          Shared files used by the NVIDIA libraries
    ii  libnvidia-compute-390:amd64           390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA libcompute package
    ii  libnvidia-compute-390:i386            390.67-0ubuntu0~gpu18.04.1                      i386         NVIDIA libcompute package
    ii  libnvidia-decode-390:amd64            390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA Video Decoding runtime libraries
    ii  libnvidia-decode-390:i386             390.67-0ubuntu0~gpu18.04.1                      i386         NVIDIA Video Decoding runtime libraries
    ii  libnvidia-encode-390:amd64            390.67-0ubuntu0~gpu18.04.1                      amd64        NVENC Video Encoding runtime library
    ii  libnvidia-encode-390:i386             390.67-0ubuntu0~gpu18.04.1                      i386         NVENC Video Encoding runtime library
    ii  libnvidia-fbc1-390:amd64              390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
    ii  libnvidia-fbc1-390:i386               390.67-0ubuntu0~gpu18.04.1                      i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
    ii  libnvidia-gl-390:amd64                390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
    ii  libnvidia-gl-390:i386                 390.67-0ubuntu0~gpu18.04.1                      i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
    ii  libnvidia-ifr1-390:amd64              390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
    ii  libnvidia-ifr1-390:i386               390.67-0ubuntu0~gpu18.04.1                      i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
    ii  nvidia-390                            390.67-0ubuntu0~gpu18.04.1                      amd64        Transitional package for nvidia-driver-390
    ii  nvidia-compute-utils-390              390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA compute utilities
    ii  nvidia-dkms-390                       390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA DKMS package
    ii  nvidia-driver-390                     390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA driver metapackage
    ii  nvidia-kernel-common-390              390.67-0ubuntu0~gpu18.04.1                      amd64        Shared files used with the kernel module
    ii  nvidia-kernel-source-390              390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA kernel source package
    ii  nvidia-prime                          0.8.8                                           all          Tools to enable NVIDIA's Prime
    ii  nvidia-settings                       396.24-0ubuntu0~gpu18.04.1                      amd64        Tool for configuring the NVIDIA graphics driver
    ii  nvidia-utils-390                      390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA driver support binaries
    ii  xserver-xorg-video-nvidia-390         390.67-0ubuntu0~gpu18.04.1                      amd64        NVIDIA binary Xorg driver
    And:
    Code:
    apt policy nvidia-390
    nvidia-390:
      Installed: 390.67-0ubuntu0~gpu18.04.1
      Candidate: 390.67-0ubuntu0~gpu18.04.1
      Version table:
     *** 390.67-0ubuntu0~gpu18.04.1 500
            500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main amd64 Packages
            100 /var/lib/dpkg/status
    Sometimes it takes multiple tries && sometimes after purging nvidia a reboot helps before trying to install again.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •