Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Concerns about required installation of inappropriate microcodes

  1. #11
    Join Date
    Jun 2016
    Beans
    1,663
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Concerns about required installation of inappropriate microcodes

    Quote Originally Posted by mc4man View Post
    Re: 2
    Do you have a particular reason to be using linux-image-generic in your vm?
    Yes and no -

    1) It's just what was installed by the Xubuntu 18.04 ISO, and I never had any reason to pay much attention to this until now.

    2) Since I use the VM for testing stuff that I may later use on my host, I would like both to run the same kernel, so that they're as close as possible. But in theory this wouldn't necessarily require the kernel metapackages to be the same, right?
    Xubuntu 18.04/MacBookPro9,1 ♦ Debian 9/Mageia 6/Xubuntu 16.04/VirtualBox
    If your questions are resolved to your satisfaction, please use Thread Tools > "Mark this thread as solved..."

  2. #12
    Join Date
    Jun 2007
    Beans
    16,845

    Re: Concerns about required installation of inappropriate microcodes

    I've no experience with virtual installs but would expect there are virtual versions of the various linux meta packages. ( and these wouldn't depend on the microcode packages.

    In general the linux metapackages are a convenience for kernel upgrades, not a requirement for using or upgrading.
    So for instance here removing either or both the microcode packages would remove
    linux-generic
    linux-image-generic
    linux-signed-generic
    Nothing would change other than a future upgrade wouldn't be as easy as simply upgrading the meta packages when available.

    I'd guess on your vm you could remove the mc packges, note which meta packages are being removed, then install their virtual counterparts..??

  3. #13
    Join Date
    Jun 2016
    Beans
    1,663
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Concerns about required installation of inappropriate microcodes

    Quote Originally Posted by mc4man View Post
    I'd guess on your vm you could remove the mc packges, note which meta packages are being removed, then install their virtual counterparts..??
    Code:
    $ sudo apt-get purge amd64-microcode intel-microcode
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      iucode-tool linux-headers-generic thermald
    Use 'sudo apt autoremove' to remove them.
    The following packages will be REMOVED:
      amd64-microcode* intel-microcode* linux-generic* linux-image-generic*
    0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
    After this operation, 1,672 kB disk space will be freed.
    Do you want to continue? [Y/n] n
    Abort.
    So I think I would need to A) mark linux-headers-generic as manually installed, and B) replace linux-image-generic. Of the kernel metapackages listed here, none of them are quite what's needed. linux-image-virtual is close, but it doesn't have a dependency on the latest linux-modules-extra package which is apparently necessary - as a test, removing the linux-modules-extra packages resulted in no audio, and reinstalling it brought audio back.
    Last edited by halogen2; June 13th, 2018 at 06:28 PM.
    Xubuntu 18.04/MacBookPro9,1 ♦ Debian 9/Mageia 6/Xubuntu 16.04/VirtualBox
    If your questions are resolved to your satisfaction, please use Thread Tools > "Mark this thread as solved..."

  4. #14
    Join Date
    Jun 2016
    Beans
    1,663
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Concerns about required installation of inappropriate microcodes

    Since I couldn't find a good kernel metapackage for my VirtualBox VM, and no other ideas, I take it there isn't an ideal solution for my VirtualBox VM, so marking this solved. Thanks again to all who replied
    Xubuntu 18.04/MacBookPro9,1 ♦ Debian 9/Mageia 6/Xubuntu 16.04/VirtualBox
    If your questions are resolved to your satisfaction, please use Thread Tools > "Mark this thread as solved..."

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •