Results 1 to 3 of 3

Thread: UEFI Boot Failure

  1. #1
    Join Date
    May 2018

    UEFI Boot Failure

    Hi guys,

    I have an old Macbook Pro (2010) that use UEFI interface. Awhile back when Mac stopped supporting upgrades on this technology I switched to running different flavors of linux on it. Every flavor I tried worked fine and the OSes all performed well. I recently had Ubuntu Mate on the laptop and whilst installing some NASA software the laptop crashed and wouldn't boot. When I woulf start up the laptop I would get to a GRUB> prompt, informing me I have ma minimal command set to work with. I could ls my devices and see my hdd and my filesystem.

    I left it to one-side for a few weeks until I had enough time to work on it. I decided I would install Ubuntu 18.04 on there and create a UEFI bootable USB drive. UEFI found the USB drive and starting the process but quickly failed to the GRUB> command prompt and the restrictive instruction set. I wanted to see if anyone had any suggestions for resolving the issue.

    I have tried using:
    1. The Super_GRUB2 application but this did not work.
    2. The Rescatux usb application but again it failed.
    3. Obviously, it won't run the live usb.

    Any thoughts or help would be greatly appreciated.


  2. #2
    Join Date
    Oct 2006

    Re: UEFI Boot Failure

    Thread moved to the "Apple Hardware Users" forum.

  3. #3
    Join Date
    Jun 2009
    SW Forida

    Re: UEFI Boot Failure

    Do not know Mac, but rEFInd was originally Mac orientated.

    You may be able to create a rEFInd boot flash drive and use it to boot or fix things.
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts