Results 1 to 3 of 3

Thread: Ubuntu 18.04 & Realtek R8822BE

  1. #1
    Join Date
    Apr 2018
    Beans
    2

    Ubuntu 18.04 & Realtek R8822BE

    Hi,

    I've installed Ubuntu 18.04 x64 on a Intel Z370 motherboard (Asus Z370-I). The integreated wifi/bt card is a Realtek R8822BE.
    The wifi seems to works after desactivating of the secure boot option on the Bios but the bluetooth doen't work.
    I tried those methods here and there... Without success, kernel error (here the make.log) :
    Code:
    root@Hostname:~# dkms install bluetooth-4.4/0.1 
    Kernel preparation unnecessary for this kernel.  Skipping...
    
    Building module:
    cleaning build area...(bad exit status: 2)
    make -j12 KERNELRELEASE=4.15.0-20-generic -C /lib/modules/4.15.0-20-generic/build M=/var/lib/dkms/bluetooth-4.4/0.1/build...(bad exit status: 2)
    ERROR (dkms apport): binary package for bluetooth-4.4: 0.1 not found
    Error! Bad return status for module build on kernel: 4.15.0-20-generic (x86_64)
    Consult /var/lib/dkms/bluetooth-4.4/0.1/build/make.log for more information.
    I tried on the french forum to resolve my problem but no chance for now. You can see some practical info on the topic.
    https://forum.ubuntu-fr.org/viewtopic.php?id=2025513

    Thanks !

  2. #2
    Join Date
    May 2014
    Location
    /home
    Beans
    8,790
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Ubuntu 18.04 & Realtek R8822BE

    Your kernel should already have what I added to the bluetooth-4.4 on github. I think the Linux firmware for the device isn't quite correct

  3. #3
    Join Date
    Apr 2018
    Beans
    2

    Re: Ubuntu 18.04 & Realtek R8822BE

    Hi, some updates has resolve my issue. Thanks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •