Results 1 to 5 of 5

Thread: Installation of PHP fails

  1. #1
    Join Date
    May 2017
    Beans
    36

    Installation of PHP fails

    Code:
    ~$ sudo apt install php7.0-cli
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following additional packages will be installed:
      php-common php7.0-common php7.0-json php7.0-opcache php7.0-readline
    Suggested packages:
      php-pear
    The following NEW packages will be installed
      php-common php7.0-cli php7.0-common php7.0-json php7.0-opcache
      php7.0-readline
    0 to upgrade, 6 to newly install, 0 to remove and 12 not to upgrade.
    Need to get 2,238 kB of archives.
    After this operation, 9,630 kB of additional disk space will be used.
    Do you want to continue? [Y/n] 
    Err:1 http://security.ubuntu.com/ubuntu zesty-security/main amd64 php7.0-common amd64 7.0.22-0ubuntu0.17.04.1
      404  Not Found [IP: 91.189.88.152 80]
    Err:2 http://gb.archive.ubuntu.com/ubuntu zesty/main amd64 php-common all 1:49
      404  Not Found [IP: 91.189.88.162 80]
    Err:3 http://security.ubuntu.com/ubuntu zesty-security/main amd64 php7.0-json amd64 7.0.22-0ubuntu0.17.04.1
      404  Not Found [IP: 91.189.88.152 80]
    Err:4 http://security.ubuntu.com/ubuntu zesty-security/main amd64 php7.0-opcache amd64 7.0.22-0ubuntu0.17.04.1
      404  Not Found [IP: 91.189.88.152 80]
    Err:5 http://security.ubuntu.com/ubuntu zesty-security/main amd64 php7.0-readline amd64 7.0.22-0ubuntu0.17.04.1
      404  Not Found [IP: 91.189.88.152 80]
    Err:6 http://security.ubuntu.com/ubuntu zesty-security/main amd64 php7.0-cli amd64 7.0.22-0ubuntu0.17.04.1
      404  Not Found [IP: 91.189.88.152 80]
    Err:2 http://gb.archive.ubuntu.com/ubuntu zesty/main i386 php-common all 1:49
      404  Not Found [IP: 91.189.88.162 80]
    E: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/p/php-defaults/php-common_49_all.deb  404  Not Found [IP: 91.189.88.162 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/p/php7.0/php7.0-common_7.0.22-0ubuntu0.17.04.1_amd64.deb  404  Not Found [IP: 91.189.88.152 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/p/php7.0/php7.0-json_7.0.22-0ubuntu0.17.04.1_amd64.deb  404  Not Found [IP: 91.189.88.152 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/p/php7.0/php7.0-opcache_7.0.22-0ubuntu0.17.04.1_amd64.deb  404  Not Found [IP: 91.189.88.152 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/p/php7.0/php7.0-readline_7.0.22-0ubuntu0.17.04.1_amd64.deb  404  Not Found [IP: 91.189.88.152 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/p/php7.0/php7.0-cli_7.0.22-0ubuntu0.17.04.1_amd64.deb  404  Not Found [IP: 91.189.88.152 80]
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    So I tried apt-get update:
    Code:
    Ign:1 http://gb.archive.ubuntu.com/ubuntu zesty InRelease
    Err:2 http://gb.archive.ubuntu.com/ubuntu zesty Release
      404  Not Found [IP: 91.189.88.149 80]
    Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
    Get:4 http://dl.google.com/linux/chrome/deb stable Release [1,189 B]
    Get:5 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]
    Get:6 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,350 B]
    Reading package lists... Done      
    E: The repository 'http://gb.archive.ubuntu.com/ubuntu zesty Release' does no longer have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Installation of PHP fails

    17.04 has been out of support for a few months now so that explains your problem.
    either upgrade/install 17.10 or stay with the LTS 16.04 supported till 2021
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  3. #3
    Join Date
    May 2017
    Beans
    36

    Re: Installation of PHP fails

    What, and in three months upgrade again? No. Forget it, I'm going back to Windows. Canonical forcing people to upgrade is unacceptable.
    Last edited by Irihapeti; April 3rd, 2018 at 11:38 PM. Reason: Language

  4. #4
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    13,687
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Installation of PHP fails

    Almost a year ago a poster informed you about the long term support option. The long- versus short term support choice can hardly come as a surprise.

    https://ubuntuforums.org/showthread....1#post13647997
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  5. #5
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Installation of PHP fails

    And we're done. I'd like to remind everyone to please be courteous and polite.

    Closed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •