Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Problem updating ubuntu (unmet dependencies + mismatch on package)

  1. #1
    Join Date
    May 2011
    Beans
    115

    Problem updating ubuntu (unmet dependencies + mismatch on package)

    Yesterday I tried to update my ubuntu 18 system and now the nvidia driver is no longer working. I tried to do sudo apt-get update followed by sudo apt-get upgrade but that gives me the following errors:

    Code:
    The following packages have unmet dependencies:
      libnvidia-ifr1-390 : Depends: libnvidia-gl-390 but it is not installed
      libnvidia-ifr1-390:i386 : Depends: libnvidia-gl-390:i386 but it is not installed
      nvidia-driver-390 : Depends: libnvidia-gl-390 (= 390.42-0ubuntu1+gpu18.04.1) but it is not installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution)
    So I try the apt --fix-broken install but this gives me:

    Code:
    Preparing to unpack .../libnvidia-gl-390_390.42-0ubuntu1+gpu18.04_1_amd64.deb ...
    diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 to /user/lib/x86_64-linux-gnu/libGL.so.1.distrib by nvidia-340
    dpkg-divert: error: mismatch on package
    I also tried to purge all nvidia packages but that didn't work either.

    Any solutions to this? If possible I'd like to revert whatever was updated that causes this but no idea how to do that.

    Thanks

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    26,654
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    Thread moved to Ubuntu Development Version, a more appropriate forum.

  3. #3
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,088
    Distro
    Kubuntu 19.04 Disco Dingo

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    Many people are having issues with NVIDIA support in the upcoming release. I've just decided to wait until the actual release and am relying on the nouveau driver for now.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  4. #4
    Join Date
    May 2011
    Beans
    115

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    Ok that's fine but how do I recover from this? At this moment I cannot update/upgrade anything as I get these errors

  5. #5
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    For what ever reason I have noticed a few users here using "apt-get" instead of just "apt" from 16.04 and 17.10 and newer. (Seems to cause apt related problems)
    EDIT: These problems are seen with the combination of "apt-get" and "apt".

    And have you yet tried:
    Code:
    sudo apt-get clean
    sudo apt-get update
    sudo apt-get install -f
    sudo dpkg -a --configure
    sudo apt-get dist-upgrade
    I myself rarely use apt-get any longer>(To be noted only)
    EG:
    Code:
    sudo apt clean
    sudo apt update
    sudo apt install -f
    sudo dpkg -a --configure
    sudo apt dist-upgrade
    Or
    sudo apt full-upgrade
    I'm not saying this will fix your present problem, but just what I have noticed.
    Last edited by 1fallen; March 27th, 2018 at 08:14 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  6. #6
    Join Date
    Jan 2018
    Beans
    140

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    Quote Originally Posted by jorritTyb View Post
    I tried to do sudo apt-get update followed by sudo apt-get upgrade but that gives me the following errors:
    Did you try a:

    Code:
    sudo apt dist-upgrade
    That is what I use exclusively, especially when you are on a development release, as it ensures to replace all older packages with newer versions and even remove older packages and dependencies.

  7. #7
    Join Date
    May 2011
    Beans
    115

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    These commands didn't fix it. sudo dpkg -a --configure (after doing the other commands you mentioned) works a long time and then says:

    Errors were encountered while processing:
    nvidia-driver-390
    libnvidia-ifr1-390:amd64
    libnvidia-ifr1-390:i386
    A dist-upgrade or even a full-upgrade doesn't help either.

    Almost every apt (or apt-get) command that I try complains about 'unmet dependencies' and recommends that I do 'apt --fix-broken install'. However that command keeps erroring out with the 'dpkg-divert' error. Is there a way of force removing those nvidia packages? I tried purge but that gives the errors above again.

    Edit: if all else fails I'm willing to go back to the normal version of ubuntu too. However, no idea how to do that now given the state this is in?


    So no matter what I do I can't seem to get rid of these three erroring packages. Any clues? Thanks!
    Last edited by jorritTyb; March 28th, 2018 at 05:10 AM.

  8. #8
    Join Date
    May 2011
    Beans
    115

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    Nobody has any idea on how I can get unstuck here? Thanks

  9. #9
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    If you have synaptic installed you could try and fix it that way by removing the broken packages.

  10. #10
    Join Date
    May 2011
    Beans
    115

    Re: Problem updating ubuntu (unmet dependencies + mismatch on package)

    How would I do that with synaptic? Note that I cannot open a graphical environment (broken drivers). Everything has to be done with commandline

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •