It worked until first reboot, then I got black screen everytime I booted without the acpi_osi settings. Back to acpi_osi=! and acpi_osi="Windows 2009" and no touchpad